summaryrefslogtreecommitdiffstats
path: root/recipes-demo/navigation/ondemandnavi_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/navigation/ondemandnavi_git.bb')
-rw-r--r--recipes-demo/navigation/ondemandnavi_git.bb13
1 files changed, 4 insertions, 9 deletions
diff --git a/recipes-demo/navigation/ondemandnavi_git.bb b/recipes-demo/navigation/ondemandnavi_git.bb
index d1069c31..922a70fd 100644
--- a/recipes-demo/navigation/ondemandnavi_git.bb
+++ b/recipes-demo/navigation/ondemandnavi_git.bb
@@ -18,7 +18,10 @@ SRCREV = "1a014832f3da70e413650e0eeb4f40e598feb257"
S = "${WORKDIR}/git"
-inherit qmake5 pkgconfig
+inherit qmake5 pkgconfig agl-app
+
+AGL_APP_ID = "navigation"
+AGL_APP_NAME = "Navigation"
do_install:append() {
# Currently using default global client and CA certificates
@@ -33,14 +36,6 @@ do_install:append() {
install -m 0644 ${WORKDIR}/navigation.token ${D}${sysconfdir}/xdg/AGL/navigation/
}
-# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
-do_install:append() {
- sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/navigation.desktop
- echo "DBusActivatable=true" >> ${D}${datadir}/applications/navigation.desktop
-}
-
-FILES:${PN} += "${datadir}/icons/"
-
RDEPENDS:${PN} += " \
qtlocation \
flite \