aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-demo/navigation/ondemandnavi_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/navigation/ondemandnavi_git.bb')
-rw-r--r--recipes-demo/navigation/ondemandnavi_git.bb20
1 files changed, 18 insertions, 2 deletions
diff --git a/recipes-demo/navigation/ondemandnavi_git.bb b/recipes-demo/navigation/ondemandnavi_git.bb
index c89ddebb..da198025 100644
--- a/recipes-demo/navigation/ondemandnavi_git.bb
+++ b/recipes-demo/navigation/ondemandnavi_git.bb
@@ -10,13 +10,29 @@ DEPENDS = "qtquickcontrols2 qtlocation libqtappfw"
PV = "2.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "1593664d2f17ab563c7ad81215696b1ac6a3bd7b"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH} \
+ file://navigation.conf \
+ file://navigation.token \
+"
+SRCREV = "1a014832f3da70e413650e0eeb4f40e598feb257"
S = "${WORKDIR}/git"
inherit qmake5 pkgconfig
+do_install:append() {
+ # Currently using default global client and CA certificates
+ # for KUKSA.val SSL, installing app specific ones would go here.
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/navigation
+ install -m 0644 ${WORKDIR}/navigation.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/navigation.token ${D}${sysconfdir}/xdg/AGL/navigation/
+}
+
FILES:${PN} += "${datadir}/icons/"
RDEPENDS:${PN} += " \