summaryrefslogtreecommitdiffstats
path: root/recipes-demo/phone/phone_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/phone/phone_git.bb')
-rw-r--r--recipes-demo/phone/phone_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-demo/phone/phone_git.bb b/recipes-demo/phone/phone_git.bb
index 61050bc3..e8b8d9ab 100644
--- a/recipes-demo/phone/phone_git.bb
+++ b/recipes-demo/phone/phone_git.bb
@@ -17,6 +17,12 @@ S = "${WORKDIR}/git"
inherit qmake5 pkgconfig
+# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
+do_install:append() {
+ sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/phone.desktop
+ echo "DBusActivatable=true" >> ${D}${datadir}/applications/phone.desktop
+}
+
FILES:${PN} += "${datadir}/icons/ ${datadir}/sounds/"
RDEPENDS:${PN} += "libqtappfw"