summaryrefslogtreecommitdiffstats
path: root/recipes-demo/phone/phone_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/phone/phone_git.bb')
-rw-r--r--recipes-demo/phone/phone_git.bb25
1 files changed, 15 insertions, 10 deletions
diff --git a/recipes-demo/phone/phone_git.bb b/recipes-demo/phone/phone_git.bb
index dd867227..41ca0e61 100644
--- a/recipes-demo/phone/phone_git.bb
+++ b/recipes-demo/phone/phone_git.bb
@@ -6,19 +6,24 @@ SECTION = "apps"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
+DEPENDS = " \
+ qtquickcontrols2 \
+ libqtappfw \
+ libhomescreen \
+ gstreamer1.0 \
+"
PV = "1.0+git${SRCPV}"
-S = "${WORKDIR}/git"
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 \
- libqtappfw \
- libhomescreen \
- gstreamer1.0 \
-"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
inherit qmake5 aglwgt
-RDEPENDS_${PN} += "agl-service-telephony agl-service-bluetooth-pbap libqtappfw"
+RDEPENDS_${PN} += " \
+ agl-service-telephony \
+ agl-service-bluetooth-pbap \
+ libqtappfw \
+"