summaryrefslogtreecommitdiffstats
path: root/recipes-demo/radio/radio_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/radio/radio_git.bb')
-rw-r--r--recipes-demo/radio/radio_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-demo/radio/radio_git.bb b/recipes-demo/radio/radio_git.bb
index 57b6df8b..fcbbd634 100644
--- a/recipes-demo/radio/radio_git.bb
+++ b/recipes-demo/radio/radio_git.bb
@@ -31,6 +31,12 @@ do_install:append() {
install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${sysconfdir}/xdg/AGL/radio-presets.conf
}
+# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
+do_install:append() {
+ sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/radio.desktop
+ echo "DBusActivatable=true" >> ${D}${datadir}/applications/radio.desktop
+}
+
FILES:${PN} += "${sysconfdir}/xdg/AGL/* ${datadir}/icons/"
RDEPENDS:${PN} += "libqtappfw"