summaryrefslogtreecommitdiffstats
path: root/recipes-demo/radio/radio_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/radio/radio_git.bb')
-rw-r--r--recipes-demo/radio/radio_git.bb10
1 files changed, 2 insertions, 8 deletions
diff --git a/recipes-demo/radio/radio_git.bb b/recipes-demo/radio/radio_git.bb
index fcbbd634..22b22010 100644
--- a/recipes-demo/radio/radio_git.bb
+++ b/recipes-demo/radio/radio_git.bb
@@ -19,7 +19,7 @@ SRCREV = "f48bb2aab34273bd5b3cc1f9f9d88afbfb231d6b"
S = "${WORKDIR}/git"
-inherit qmake5 pkgconfig
+inherit qmake5 pkgconfig agl-app
# ALS, CES, FOSDEM available
AGL_RADIO_PRESETS_LOCALE ?= "CES"
@@ -31,12 +31,6 @@ do_install:append() {
install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${sysconfdir}/xdg/AGL/radio-presets.conf
}
-# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
-do_install:append() {
- sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/radio.desktop
- echo "DBusActivatable=true" >> ${D}${datadir}/applications/radio.desktop
-}
-
-FILES:${PN} += "${sysconfdir}/xdg/AGL/* ${datadir}/icons/"
+FILES:${PN} += "${sysconfdir}/xdg/AGL/*"
RDEPENDS:${PN} += "libqtappfw"