summaryrefslogtreecommitdiffstats
path: root/recipes-demo/radio
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/radio')
-rw-r--r--recipes-demo/radio/files/0001-Migrate-to-Qt-6.patch103
-rw-r--r--recipes-demo/radio/radio_git.bb7
2 files changed, 107 insertions, 3 deletions
diff --git a/recipes-demo/radio/files/0001-Migrate-to-Qt-6.patch b/recipes-demo/radio/files/0001-Migrate-to-Qt-6.patch
new file mode 100644
index 000000000..245324c4b
--- /dev/null
+++ b/recipes-demo/radio/files/0001-Migrate-to-Qt-6.patch
@@ -0,0 +1,103 @@
+From a1a5be00d1e5ba0d857b9b83769a2c666c2be313 Mon Sep 17 00:00:00 2001
+From: Indivara Weerasuriya <1806262-indivara@users.noreply.git.qt.io>
+Date: Wed, 24 Jul 2024 09:46:03 +0900
+Subject: [PATCH] Migrate to Qt 6
+
+---
+ app/Radio.qml | 24 ++++++++++++------------
+ 1 file changed, 12 insertions(+), 12 deletions(-)
+
+diff --git a/app/Radio.qml b/app/Radio.qml
+index bd67c84..d2950af 100644
+--- a/app/Radio.qml
++++ b/app/Radio.qml
+@@ -60,7 +60,7 @@ ApplicationWindow {
+ anchors.right: parent.right
+ anchors.bottom: controls.top
+ fillMode: Image.Stretch
+- source: './images/HMI_Radio_Equalizer.svg'
++ source: 'qrc:/images/HMI_Radio_Equalizer.svg'
+ }
+ Item {
+ id: controls
+@@ -83,11 +83,11 @@ ApplicationWindow {
+ Row {
+ spacing: 20
+ Image {
+- source: './images/FM_Icons_FM.svg'
++ source: 'qrc:/images/FM_Icons_FM.svg'
+ }
+ // ToggleButton {
+-// offImage: './images/FM_Icons_FM.svg'
+-// onImage: './images/FM_Icons_AM.svg'
++// offImage: 'qrc:/images/FM_Icons_FM.svg'
++// onImage: 'qrc:/images/FM_Icons_AM.svg'
+ // onCheckedChanged: {
+ // radio.band = checked ? radio.amBand : radio.fmBand
+ // radio.frequency = radio.minFrequency
+@@ -146,7 +146,7 @@ ApplicationWindow {
+ }
+
+ ImageButton {
+- offImage: './images/AGL_MediaPlayer_BackArrow.svg'
++ offImage: 'qrc:/images/AGL_MediaPlayer_BackArrow.svg'
+ Timer {
+ running: parent.pressed
+ triggeredOnStart: true
+@@ -162,7 +162,7 @@ ApplicationWindow {
+ }
+
+ ImageButton {
+- offImage: './images/AGL_MediaPlayer_ForwardArrow.svg'
++ offImage: 'qrc:/images/AGL_MediaPlayer_ForwardArrow.svg'
+ Timer {
+ running: parent.pressed
+ triggeredOnStart: true
+@@ -181,7 +181,7 @@ ApplicationWindow {
+
+ ImageButton {
+ id: play
+- offImage: './images/AGL_MediaPlayer_Player_Play.svg'
++ offImage: 'qrc:/images/AGL_MediaPlayer_Player_Play.svg'
+ onClicked: {
+ radio.start()
+ }
+@@ -190,7 +190,7 @@ ApplicationWindow {
+ when: radio.playing
+ PropertyChanges {
+ target: play
+- offImage: './images/AGL_MediaPlayer_Player_Pause.svg'
++ offImage: 'qrc:/images/AGL_MediaPlayer_Player_Pause.svg'
+ onClicked: radio.stop()
+ }
+ }
+@@ -207,7 +207,7 @@ ApplicationWindow {
+
+ ImageButton {
+ id: scanBackwardBtn
+- offImage: './images/AGL_MediaPlayer_BackArrow.svg'
++ offImage: 'qrc:/images/AGL_MediaPlayer_BackArrow.svg'
+ states: [
+ State {
+ when: radio.playing
+@@ -224,7 +224,7 @@ ApplicationWindow {
+
+ ImageButton {
+ id: scanForwardBtn
+- offImage: './images/AGL_MediaPlayer_ForwardArrow.svg'
++ offImage: 'qrc:/images/AGL_MediaPlayer_ForwardArrow.svg'
+ states: [
+ State {
+ when: radio.playing
+@@ -284,9 +284,9 @@ ApplicationWindow {
+ source: {
+ switch (model.modelData.band) {
+ case radio.fmBand:
+- return './images/FM_Icons_FM.svg'
++ return 'qrc:/images/FM_Icons_FM.svg'
+ case radio.amBand:
+- return './images/FM_Icons_AM.svg'
++ return 'qrc:/images/FM_Icons_AM.svg'
+ }
+ return null
+ }
diff --git a/recipes-demo/radio/radio_git.bb b/recipes-demo/radio/radio_git.bb
index c9d8ed7af..06112a046 100644
--- a/recipes-demo/radio/radio_git.bb
+++ b/recipes-demo/radio/radio_git.bb
@@ -6,7 +6,7 @@ SECTION = "apps"
LICENSE = "Apache-2.0 & GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-DEPENDS = "qtquickcontrols2 libqtappfw"
+DEPENDS = "qtdeclarative libqtappfw"
PV = "1.0+git${SRCPV}"
@@ -14,12 +14,13 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/radio;protocol=https;bra
file://presets-ALS.conf \
file://presets-CES.conf \
file://presets-FOSDEM.conf \
-"
+ file://0001-Migrate-to-Qt-6.patch \
+ "
SRCREV = "aef392d9df8bb5e4ada4b3f8f44016e8a839d154"
S = "${WORKDIR}/git"
-inherit qmake5 pkgconfig agl-app
+inherit qt6-qmake pkgconfig agl-app
AGL_APP_NAME = "Radio"