summaryrefslogtreecommitdiffstats
path: root/recipes-demo
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo')
-rw-r--r--recipes-demo/flutter-ics-homescreen/files/change_grpc_port.patch21
-rw-r--r--recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml3
-rw-r--r--recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb7
3 files changed, 5 insertions, 26 deletions
diff --git a/recipes-demo/flutter-ics-homescreen/files/change_grpc_port.patch b/recipes-demo/flutter-ics-homescreen/files/change_grpc_port.patch
deleted file mode 100644
index 2c0488b9..00000000
--- a/recipes-demo/flutter-ics-homescreen/files/change_grpc_port.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From 7a7dfd8756c8c742aa3cd829a3644e6ec977aa8b Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Lisandro=20P=C3=A9rez=20Meyer?= <lperezmeyer@ics.com>
-Date: Tue, 14 Nov 2023 14:59:45 +0000
-Subject: [PATCH] Set the default port to 55555.
-
-The Docker images seems to be using 55556.
----
- config/config.yaml | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/config/config.yaml b/config/config.yaml
-index 138fe4b..a552299 100644
---- a/config/config.yaml
-+++ b/config/config.yaml
-@@ -1,2 +1,2 @@
- hostname: localhost
--port: 55556
-+port: 55555
---
-2.25.1
-
diff --git a/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml b/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml
index f73418a8..eb29ea73 100644
--- a/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml
+++ b/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml
@@ -1,2 +1,3 @@
-authorization : "/etc/xdg/AGL/homescreen/ics-homescreen.token"
+port : 55555
+authorization : "/etc/xdg/AGL/ics-homescreen/ics-homescreen.token"
use-tls : true
diff --git a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
index aa3e923e..7774c808 100644
--- a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
+++ b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
@@ -7,13 +7,12 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-ics-homescreen;protocol=https;branch=${AGL_BRANCH} \
- file://change_grpc_port.patch \
file://flutter-ics-homescreen.json \
file://flutter-ics-homescreen.service \
file://ics-homescreen.yaml \
file://ics-homescreen.token \
"
-SRCREV = "70ec8a79a121471a004e7e4c23157d10157e136f"
+SRCREV = "94b78fd369c318baf1a98d4f510d791ea9f17017"
S = "${WORKDIR}/git"
@@ -37,9 +36,9 @@ do_install:append() {
# be readable by other users, but currently that's not doable
# until a packaging/sandboxing/MAC scheme is (re)implemented or
# something like OAuth is plumbed in as an alternative.
- install -d ${D}${sysconfdir}/xdg/AGL/homescreen
+ install -d ${D}${sysconfdir}/xdg/AGL/ics-homescreen
install -m 0644 ${WORKDIR}/ics-homescreen.yaml ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/ics-homescreen.token ${D}${sysconfdir}/xdg/AGL/homescreen/
+ install -m 0644 ${WORKDIR}/ics-homescreen.token ${D}${sysconfdir}/xdg/AGL/ics-homescreen/
}
FILES:${PN} += "${datadir} ${sysconfdir}/xdg/AGL"