summaryrefslogtreecommitdiffstats
path: root/recipes-demo
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo')
-rw-r--r--recipes-demo/agl-persistent-storage-api/agl-persistent-storage-api_git.bb2
-rw-r--r--recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb6
-rw-r--r--recipes-demo/agl-service-hvac/agl-service-hvac_git.bb6
-rw-r--r--recipes-demo/agl-service-radio/agl-service-radio_git.bb2
-rw-r--r--recipes-demo/agl-vss-helper/agl-vss-helper.bb11
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard_git.bb6
-rw-r--r--recipes-demo/cluster-receiver/cluster-receiver_git.bb2
-rw-r--r--recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb2
-rw-r--r--recipes-demo/dashboard/dashboard_git.bb4
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb18
-rw-r--r--recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb18
-rw-r--r--recipes-demo/homescreen/homescreen_git.bb6
-rw-r--r--recipes-demo/hvac/hvac_git.bb4
-rw-r--r--recipes-demo/launcher/launcher_git.bb2
-rw-r--r--recipes-demo/mediaplayer/mediaplayer_git.bb4
-rw-r--r--recipes-demo/native-shell-client/native-shell-client_agldemo.inc2
-rw-r--r--recipes-demo/navigation/ondemandnavi-config_1.0.bb8
-rw-r--r--recipes-demo/navigation/ondemandnavi_git.bb8
-rw-r--r--recipes-demo/navigation/tbtnavi_git.bb12
-rw-r--r--recipes-demo/radio/radio_git.bb8
-rw-r--r--recipes-demo/simple-can-simulator/simple-can-simulator.bb7
21 files changed, 73 insertions, 65 deletions
diff --git a/recipes-demo/agl-persistent-storage-api/agl-persistent-storage-api_git.bb b/recipes-demo/agl-persistent-storage-api/agl-persistent-storage-api_git.bb
index 63a315fd6..f4ac31b2a 100644
--- a/recipes-demo/agl-persistent-storage-api/agl-persistent-storage-api_git.bb
+++ b/recipes-demo/agl-persistent-storage-api/agl-persistent-storage-api_git.bb
@@ -38,7 +38,7 @@ do_install:append () {
mv ${D}/usr/bin/server ${D}/usr/bin/agl-service-persistent-storage
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}
fi
}
diff --git a/recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb b/recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb
index a1f6f795c..11662cf33 100644
--- a/recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb
+++ b/recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb
@@ -44,9 +44,9 @@ do_install:append() {
# until a packaging/sandboxing/MAC scheme is (re)implemented or
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer
- install -m 0644 ${WORKDIR}/agl-service-audiomixer.conf.default ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/agl-service-audiomixer.conf.gateway-demo ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/agl-service-audiomixer.token ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer/
+ install -m 0644 ${UNPACKDIR}/agl-service-audiomixer.conf.default ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/agl-service-audiomixer.conf.gateway-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/agl-service-audiomixer.token ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer/
}
FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/recipes-demo/agl-service-hvac/agl-service-hvac_git.bb b/recipes-demo/agl-service-hvac/agl-service-hvac_git.bb
index 721cdd7d2..95bc39eab 100644
--- a/recipes-demo/agl-service-hvac/agl-service-hvac_git.bb
+++ b/recipes-demo/agl-service-hvac/agl-service-hvac_git.bb
@@ -42,9 +42,9 @@ do_install:append() {
# until a packaging/sandboxing/MAC scheme is (re)implemented or
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/agl-service-hvac
- install -m 0644 ${WORKDIR}/agl-service-hvac.conf.default ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/agl-service-hvac.conf.gateway-demo ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/agl-service-hvac.token ${D}${sysconfdir}/xdg/AGL/agl-service-hvac/
+ install -m 0644 ${UNPACKDIR}/agl-service-hvac.conf.default ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/agl-service-hvac.conf.gateway-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/agl-service-hvac.token ${D}${sysconfdir}/xdg/AGL/agl-service-hvac/
}
FILES:${PN} += "${systemd_system_unitdir}"
diff --git a/recipes-demo/agl-service-radio/agl-service-radio_git.bb b/recipes-demo/agl-service-radio/agl-service-radio_git.bb
index bc5175243..2c5025a26 100644
--- a/recipes-demo/agl-service-radio/agl-service-radio_git.bb
+++ b/recipes-demo/agl-service-radio/agl-service-radio_git.bb
@@ -29,7 +29,7 @@ inherit meson pkgconfig systemd
SYSTEMD_SERVICE:${PN} = "agl-service-radio.service"
do_install:append() {
- install -D -m 0644 ${WORKDIR}/radio.conf.kvm-demo ${D}${sysconfdir}/xdg/AGL.conf
+ install -D -m 0644 ${UNPACKDIR}/radio.conf.kvm-demo ${D}${sysconfdir}/xdg/AGL.conf
}
PACKAGE_BEFORE_PN += "${PN}-conf-kvm-demo"
diff --git a/recipes-demo/agl-vss-helper/agl-vss-helper.bb b/recipes-demo/agl-vss-helper/agl-vss-helper.bb
index 88e14511a..be555dab8 100644
--- a/recipes-demo/agl-vss-helper/agl-vss-helper.bb
+++ b/recipes-demo/agl-vss-helper/agl-vss-helper.bb
@@ -8,6 +8,9 @@ SRC_URI = "file://agl-vss-helper.py \
file://agl-vss-helper.service \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit systemd
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
@@ -17,11 +20,11 @@ do_compile[noexec] = "1"
do_install() {
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/${BPN}.py ${D}${sbindir}
+ install -m 0755 ${UNPACKDIR}/${BPN}.py ${D}${sbindir}
install -d ${D}${sysconfdir}/xdg/AGL/${BPN}
- install -m 0644 ${WORKDIR}/${BPN}.yaml ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/${BPN}.token ${D}${sysconfdir}/xdg/AGL/${BPN}/
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -m 0644 ${UNPACKDIR}/${BPN}.yaml ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/${BPN}.token ${D}${sysconfdir}/xdg/AGL/${BPN}/
+ install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
}
RDEPENDS:${PN} = " \
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
index dd0e411a3..99a05fb99 100644
--- a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
@@ -33,16 +33,16 @@ CLUSTER_DEMO_VSS_HOSTNAME ??= "192.168.10.2"
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
do_install:append() {
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
# VIS authorization token file for KUKSA.val should ideally not
# be readable by other users, but currently that's not doable
# until a packaging/sandboxing/MAC scheme is (re)implemented or
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/cluster-dashboard
- install -m 0644 ${WORKDIR}/cluster-dashboard.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/cluster-dashboard.conf ${D}${sysconfdir}/xdg/AGL/
sed -i "s/^server = .*/server = \"${CLUSTER_DEMO_VSS_HOSTNAME}\"/" ${D}${sysconfdir}/xdg/AGL/cluster-dashboard.conf
- install -m 0644 ${WORKDIR}/cluster-dashboard.token ${D}${sysconfdir}/xdg/AGL/cluster-dashboard/
+ install -m 0644 ${UNPACKDIR}/cluster-dashboard.token ${D}${sysconfdir}/xdg/AGL/cluster-dashboard/
}
RDEPENDS:${PN} += " \
diff --git a/recipes-demo/cluster-receiver/cluster-receiver_git.bb b/recipes-demo/cluster-receiver/cluster-receiver_git.bb
index 70e660c57..ec701b387 100644
--- a/recipes-demo/cluster-receiver/cluster-receiver_git.bb
+++ b/recipes-demo/cluster-receiver/cluster-receiver_git.bb
@@ -26,7 +26,7 @@ inherit cmake pkgconfig systemd
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
do_install:append() {
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
}
RDEPENDS:${PN} += " \
diff --git a/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb b/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb
index e146a00d4..2dcc31cb5 100644
--- a/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb
+++ b/recipes-demo/cluster-receiver/qt-cluster-receiver_git.bb
@@ -27,7 +27,7 @@ inherit cmake_qt5 pkgconfig systemd
do_install:append() {
# Only install unit, do not enable it by default
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
}
RDEPENDS:${PN} += " \
diff --git a/recipes-demo/dashboard/dashboard_git.bb b/recipes-demo/dashboard/dashboard_git.bb
index 8ea658b10..5a03be92e 100644
--- a/recipes-demo/dashboard/dashboard_git.bb
+++ b/recipes-demo/dashboard/dashboard_git.bb
@@ -35,8 +35,8 @@ do_install:append() {
# until a packaging/sandboxing/MAC scheme is (re)implemented or
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/dashboard
- install -m 0644 ${WORKDIR}/dashboard.conf ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/dashboard.token ${D}${sysconfdir}/xdg/AGL/dashboard/
+ install -m 0644 ${UNPACKDIR}/dashboard.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/dashboard.token ${D}${sysconfdir}/xdg/AGL/dashboard/
}
RDEPENDS:${PN} += " \
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index 2c9109c70..a13f176d5 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -36,19 +36,19 @@ SYSTEMD_SERVICE:${PN} = "flutter-cluster-dashboard.service"
do_compile[network] = "1"
do_install:append() {
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
- install -D -m 0644 ${WORKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
+ install -D -m 0644 ${UNPACKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
- install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
+ install -D -m 0644 ${UNPACKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
install -d ${D}${sysconfdir}/xdg/AGL/cluster-dashboard
- install -m 0644 ${WORKDIR}/cluster-dashboard.yaml ${D}${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.default
- install -m 0644 ${WORKDIR}/cluster-dashboard.yaml.demo ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/cluster-dashboard.yaml.gateway-demo ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/cluster-dashboard.yaml.kvm-demo ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/cluster-dashboard.yaml.kvm-demo-preconfigured ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/cluster-dashboard.token ${D}${sysconfdir}/xdg/AGL/cluster-dashboard/
+ install -m 0644 ${UNPACKDIR}/cluster-dashboard.yaml ${D}${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.default
+ install -m 0644 ${UNPACKDIR}/cluster-dashboard.yaml.demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/cluster-dashboard.yaml.gateway-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/cluster-dashboard.yaml.kvm-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/cluster-dashboard.yaml.kvm-demo-preconfigured ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/cluster-dashboard.token ${D}${sysconfdir}/xdg/AGL/cluster-dashboard/
}
ALTERNATIVE_LINK_NAME[cluster-dashboard.yaml] = "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml"
diff --git a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
index be9f3af0d..063f6caca 100644
--- a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
+++ b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
@@ -38,23 +38,23 @@ APP_AOT_EXTRA:append = " ${DISABLE_BG_ANIMATION}"
do_compile[network] = "1"
do_install:append() {
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
- install -D -m 0644 ${WORKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
+ install -D -m 0644 ${UNPACKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
- install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
+ install -D -m 0644 ${UNPACKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
# VIS authorization token file for KUKSA.val should ideally not
# be readable by other users, but currently that's not doable
# until a packaging/sandboxing/MAC scheme is (re)implemented or
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/ics-homescreen
- install -m 0644 ${WORKDIR}/ics-homescreen.yaml ${D}${sysconfdir}/xdg/AGL/ics-homescreen.yaml.default
- install -m 0644 ${WORKDIR}/ics-homescreen.yaml.gateway-demo ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/ics-homescreen.yaml.kvm-demo ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/ics-homescreen.yaml.kvm-gateway-demo ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/ics-homescreen.token ${D}${sysconfdir}/xdg/AGL/ics-homescreen/
- install -m 0644 ${WORKDIR}/radio-presets.yaml ${D}${sysconfdir}/xdg/AGL/ics-homescreen/
+ install -m 0644 ${UNPACKDIR}/ics-homescreen.yaml ${D}${sysconfdir}/xdg/AGL/ics-homescreen.yaml.default
+ install -m 0644 ${UNPACKDIR}/ics-homescreen.yaml.gateway-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/ics-homescreen.yaml.kvm-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/ics-homescreen.yaml.kvm-gateway-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/ics-homescreen.token ${D}${sysconfdir}/xdg/AGL/ics-homescreen/
+ install -m 0644 ${UNPACKDIR}/radio-presets.yaml ${D}${sysconfdir}/xdg/AGL/ics-homescreen/
}
ALTERNATIVE_LINK_NAME[ics-homescreen.yaml] = "${sysconfdir}/xdg/AGL/ics-homescreen.yaml"
diff --git a/recipes-demo/homescreen/homescreen_git.bb b/recipes-demo/homescreen/homescreen_git.bb
index 1f8e0c775..e5c03197c 100644
--- a/recipes-demo/homescreen/homescreen_git.bb
+++ b/recipes-demo/homescreen/homescreen_git.bb
@@ -40,7 +40,7 @@ OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel'
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
do_install:append() {
- install -D -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
+ install -D -m0644 ${UNPACKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
# Currently using default global client and CA certificates
# for KUKSA.val SSL, installing app specific ones would go here.
@@ -50,8 +50,8 @@ do_install:append() {
# until a packaging/sandboxing/MAC scheme is (re)implemented or
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/homescreen
- install -m 0644 ${WORKDIR}/homescreen.conf ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/homescreen.token ${D}${sysconfdir}/xdg/AGL/homescreen/
+ install -m 0644 ${UNPACKDIR}/homescreen.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/homescreen.token ${D}${sysconfdir}/xdg/AGL/homescreen/
}
RDEPENDS:${PN} += " \
diff --git a/recipes-demo/hvac/hvac_git.bb b/recipes-demo/hvac/hvac_git.bb
index 2ac6a69b1..988fb79bb 100644
--- a/recipes-demo/hvac/hvac_git.bb
+++ b/recipes-demo/hvac/hvac_git.bb
@@ -37,8 +37,8 @@ do_install:append() {
# until a packaging/sandboxing/MAC scheme is (re)implemented or
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/hvac
- install -m 0644 ${WORKDIR}/hvac.conf ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/hvac.token ${D}${sysconfdir}/xdg/AGL/hvac/
+ install -m 0644 ${UNPACKDIR}/hvac.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/hvac.token ${D}${sysconfdir}/xdg/AGL/hvac/
}
RDEPENDS:${PN} += " \
diff --git a/recipes-demo/launcher/launcher_git.bb b/recipes-demo/launcher/launcher_git.bb
index c46a4a182..7a9de880c 100644
--- a/recipes-demo/launcher/launcher_git.bb
+++ b/recipes-demo/launcher/launcher_git.bb
@@ -35,7 +35,7 @@ PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
do_install:append() {
- install -D -m0644 ${WORKDIR}/launcher.service ${D}${systemd_system_unitdir}/launcher.service
+ install -D -m0644 ${UNPACKDIR}/launcher.service ${D}${systemd_system_unitdir}/launcher.service
}
RDEPENDS:${PN} += " \
diff --git a/recipes-demo/mediaplayer/mediaplayer_git.bb b/recipes-demo/mediaplayer/mediaplayer_git.bb
index 976dcc8dc..5bced0bb9 100644
--- a/recipes-demo/mediaplayer/mediaplayer_git.bb
+++ b/recipes-demo/mediaplayer/mediaplayer_git.bb
@@ -31,8 +31,8 @@ do_install:append() {
# until a packaging/sandboxing/MAC scheme is (re)implemented or
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/mediaplayer
- install -m 0644 ${WORKDIR}/mediaplayer.conf ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/mediaplayer.token ${D}${sysconfdir}/xdg/AGL/mediaplayer/
+ install -m 0644 ${UNPACKDIR}/mediaplayer.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/mediaplayer.token ${D}${sysconfdir}/xdg/AGL/mediaplayer/
}
RDEPENDS:${PN} += "libqtappfw mpd"
diff --git a/recipes-demo/native-shell-client/native-shell-client_agldemo.inc b/recipes-demo/native-shell-client/native-shell-client_agldemo.inc
index 4c1dc1012..6a48a9d7b 100644
--- a/recipes-demo/native-shell-client/native-shell-client_agldemo.inc
+++ b/recipes-demo/native-shell-client/native-shell-client_agldemo.inc
@@ -7,7 +7,7 @@ inherit systemd
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
do_install:append() {
- install -D -m 0644 ${WORKDIR}/native-shell-client.service ${D}${systemd_system_unitdir}/native-shell-client.service
+ install -D -m 0644 ${UNPACKDIR}/native-shell-client.service ${D}${systemd_system_unitdir}/native-shell-client.service
}
RCONFLICTS:${PN} = "homescreen"
diff --git a/recipes-demo/navigation/ondemandnavi-config_1.0.bb b/recipes-demo/navigation/ondemandnavi-config_1.0.bb
index 644102ed3..26c228125 100644
--- a/recipes-demo/navigation/ondemandnavi-config_1.0.bb
+++ b/recipes-demo/navigation/ondemandnavi-config_1.0.bb
@@ -6,8 +6,10 @@ LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
-SRC_URI = "file://naviconfig.ini \
- "
+SRC_URI = "file://naviconfig.ini"
+
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
inherit allarch
@@ -16,7 +18,7 @@ MAPBOX_ACCESS_TOKEN ?= ""
do_compile[noexec] = "1"
do_install () {
- install -D -m 644 ${WORKDIR}/naviconfig.ini ${D}${sysconfdir}/naviconfig.ini
+ install -D -m 644 ${UNPACKDIR}/naviconfig.ini ${D}${sysconfdir}/naviconfig.ini
if [ -n "${MAPBOX_ACCESS_TOKEN}" ]; then
sed -i -e 's/MAPBOX_ACCESS_TOKEN/${MAPBOX_ACCESS_TOKEN}/;s/\("enableOSM":\)true/\1false/' \
${D}${sysconfdir}/naviconfig.ini
diff --git a/recipes-demo/navigation/ondemandnavi_git.bb b/recipes-demo/navigation/ondemandnavi_git.bb
index cf53b2bad..a9e6a44cf 100644
--- a/recipes-demo/navigation/ondemandnavi_git.bb
+++ b/recipes-demo/navigation/ondemandnavi_git.bb
@@ -34,10 +34,10 @@ do_install:append() {
# until a packaging/sandboxing/MAC scheme is (re)implemented or
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/navigation
- install -m 0644 ${WORKDIR}/navigation.conf ${D}${sysconfdir}/xdg/AGL/navigation.conf.default
- install -m 0644 ${WORKDIR}/navigation.conf.kvm-demo ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/navigation.conf.gateway-demo ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/navigation.token ${D}${sysconfdir}/xdg/AGL/navigation/
+ install -m 0644 ${UNPACKDIR}/navigation.conf ${D}${sysconfdir}/xdg/AGL/navigation.conf.default
+ install -m 0644 ${UNPACKDIR}/navigation.conf.kvm-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/navigation.conf.gateway-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/navigation.token ${D}${sysconfdir}/xdg/AGL/navigation/
}
ALTERNATIVE_LINK_NAME[navigation.conf] = "${sysconfdir}/xdg/AGL/navigation.conf"
diff --git a/recipes-demo/navigation/tbtnavi_git.bb b/recipes-demo/navigation/tbtnavi_git.bb
index 3c6571b15..d94fcf9a4 100644
--- a/recipes-demo/navigation/tbtnavi_git.bb
+++ b/recipes-demo/navigation/tbtnavi_git.bb
@@ -41,9 +41,9 @@ inherit meson systemd pkgconfig update-alternatives
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
do_install:append() {
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
- install -D -m 0644 ${WORKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
+ install -D -m 0644 ${UNPACKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
# Currently using default global client and CA certificates
# for KUKSA.val SSL, installing app specific ones would go here.
@@ -53,10 +53,10 @@ do_install:append() {
# until a packaging/sandboxing/MAC scheme is (re)implemented or
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/tbtnavi
- install -m 0644 ${WORKDIR}/tbtnavi.conf ${D}${sysconfdir}/xdg/AGL/tbtnavi.conf.default
- install -m 0644 ${WORKDIR}/tbtnavi.conf.kvm-demo ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/tbtnavi.conf.gateway-demo ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/tbtnavi.token ${D}${sysconfdir}/xdg/AGL/tbtnavi/
+ install -m 0644 ${UNPACKDIR}/tbtnavi.conf ${D}${sysconfdir}/xdg/AGL/tbtnavi.conf.default
+ install -m 0644 ${UNPACKDIR}/tbtnavi.conf.kvm-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/tbtnavi.conf.gateway-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/tbtnavi.token ${D}${sysconfdir}/xdg/AGL/tbtnavi/
}
ALTERNATIVE_LINK_NAME[tbtnavi.conf] = "${sysconfdir}/xdg/AGL/tbtnavi.conf"
diff --git a/recipes-demo/radio/radio_git.bb b/recipes-demo/radio/radio_git.bb
index c9d8ed7af..ba8c70ba3 100644
--- a/recipes-demo/radio/radio_git.bb
+++ b/recipes-demo/radio/radio_git.bb
@@ -27,10 +27,10 @@ AGL_APP_NAME = "Radio"
AGL_RADIO_PRESETS_LOCALE ?= "CES"
do_install:append() {
install -d ${D}${sysconfdir}/xdg/AGL
- install -m 0644 ${WORKDIR}/presets-CES.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-CES.conf
- install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-ALS.conf
- install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-FOSDEM.conf
- install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${sysconfdir}/xdg/AGL/radio-presets.conf
+ install -m 0644 ${UNPACKDIR}/presets-CES.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-CES.conf
+ install -m 0644 ${UNPACKDIR}/presets-ALS.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-ALS.conf
+ install -m 0644 ${UNPACKDIR}/presets-FOSDEM.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-FOSDEM.conf
+ install -m 0644 ${UNPACKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${sysconfdir}/xdg/AGL/radio-presets.conf
}
FILES:${PN} += "${sysconfdir}/xdg/AGL/*"
diff --git a/recipes-demo/simple-can-simulator/simple-can-simulator.bb b/recipes-demo/simple-can-simulator/simple-can-simulator.bb
index 947e0c6a5..76a81e04d 100644
--- a/recipes-demo/simple-can-simulator/simple-can-simulator.bb
+++ b/recipes-demo/simple-can-simulator/simple-can-simulator.bb
@@ -1,15 +1,18 @@
DESCRIPTION = "Simulator that generates CAN messages of a driving car"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/simple_can_simulator.py;beginline=2;endline=22;md5=9bb9c582301261d21460d2bc5bb8c225"
+LIC_FILES_CHKSUM = "file://${UNPACKDIR}/simple_can_simulator.py;beginline=2;endline=22;md5=9bb9c582301261d21460d2bc5bb8c225"
SRC_URI = "file://simple_can_simulator.py"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/simple_can_simulator.py ${D}${sbindir}
+ install -m 0755 ${UNPACKDIR}/simple_can_simulator.py ${D}${sbindir}
}
RDEPENDS:${PN} = "python3"