summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python3-cantools_37.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python3-cantools_37.0.1.bb')
-rw-r--r--recipes-devtools/python/python3-cantools_37.0.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-cantools_37.0.1.bb b/recipes-devtools/python/python3-cantools_37.0.1.bb
new file mode 100644
index 00000000..9642bc52
--- /dev/null
+++ b/recipes-devtools/python/python3-cantools_37.0.1.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "CAN BUS tools in Python 3."
+HOMEPAGE = "https://github.com/eerimoq/cantools"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d9aa4ec07de78abae21c490c9ffe61bd"
+
+SRC_URI[sha256sum] = "5852ad9fd17ddd7b1a1ce87b21b000e7f5716b358cdac4fdaca13b3e292f4c99"
+
+PYPI_PACKAGE = "cantools"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-can \
+ ${PYTHON_PN}-bitstruct \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-textparser \
+"
+
+CLEANBROKEN = "1"