summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb')
-rw-r--r--recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb b/recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb
new file mode 100644
index 00000000..4c3dfaa9
--- /dev/null
+++ b/recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb
@@ -0,0 +1,15 @@
+SUMMARY = "A final implementation of JSONPath for Python that aims to be standard compliant, including arithmetic and binary comparison operators and providing clear AST for metaprogramming."
+HOMEPAGE = "https://github.com/h2non/jsonpath-ng"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+PYPI_PACKAGE = "jsonpath-ng"
+
+SRC_URI[sha256sum] = "a273b182a82c1256daab86a313b937059261b5c5f8c4fa3fc38b882b344dd567"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-ply \
+ python3-six \
+"