summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python')
-rw-r--r--recipes-devtools/python/python3-anytree_2.8.0.bb16
-rw-r--r--recipes-devtools/python/python3-argparse-addons_0.7.0.bb10
-rw-r--r--recipes-devtools/python/python3-can-j1939_2.0.6.bb13
-rw-r--r--recipes-devtools/python/python3-cantools_39.%.bbappend1
-rw-r--r--recipes-devtools/python/python3-cantools_agldemo.inc3
-rw-r--r--recipes-devtools/python/python3-deprecation_2.1.0.bb12
-rw-r--r--recipes-devtools/python/python3-graphql-core_3.2.3.bb12
-rw-r--r--recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb15
-rw-r--r--recipes-devtools/python/python3-py-expression-eval_0.3.14.bb14
-rw-r--r--recipes-devtools/python/python3-setuptools-git-versioning_1.7.4.bb17
10 files changed, 0 insertions, 113 deletions
diff --git a/recipes-devtools/python/python3-anytree_2.8.0.bb b/recipes-devtools/python/python3-anytree_2.8.0.bb
deleted file mode 100644
index 1b4628a9..00000000
--- a/recipes-devtools/python/python3-anytree_2.8.0.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-SUMMARY = "Powerful and Lightweight Python Tree Data Structure"
-HOMEPAGE = "https://github.com/c0fec0de/anytree"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
-PYPI_PACKAGE = "anytree"
-
-SRC_URI[sha256sum] = "3f0f93f355a91bc3e6245319bf4c1d50e3416cc7a35cc1133c1ff38306bbccab"
-
-inherit pypi setuptools3
-
-do_install:append () {
- rm -f ${D}${prefix}/LICENSE
-}
-
-BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-devtools/python/python3-argparse-addons_0.7.0.bb b/recipes-devtools/python/python3-argparse-addons_0.7.0.bb
deleted file mode 100644
index e0ff0c3f..00000000
--- a/recipes-devtools/python/python3-argparse-addons_0.7.0.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-SUMMARY = "Additional Python argparse types and actions."
-HOMEPAGE = "https://github.com/eerimoq/argparse_addons"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=515e9da3e929c7b40dd13458363110a7"
-
-PYPI_PACKAGE = "argparse_addons"
-
-SRC_URI[sha256sum] = "f5da0fe676953e39bee7a6d0a9b2f5ccdcbf9d6a6b9929997caf8f6c6b23a5fb"
-
-inherit pypi setuptools3
diff --git a/recipes-devtools/python/python3-can-j1939_2.0.6.bb b/recipes-devtools/python/python3-can-j1939_2.0.6.bb
deleted file mode 100644
index b479340a..00000000
--- a/recipes-devtools/python/python3-can-j1939_2.0.6.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-SUMMARY = "An implementation of the CAN SAE J1939 standard for Python."
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=32e7309a8200a5f4b7aec6efcfb8e77e"
-PYPI_PACKAGE = "can-j1939"
-
-SRC_URI[sha256sum] = "beda5bf2e2502c4a7d97a989075c56b98e33e49b619ef8054ed13aca911be3d3"
-
-inherit pypi setuptools3
-
-RDEPENDS:${PN} += " \
- python3-can \
- python3-numpy \
-"
diff --git a/recipes-devtools/python/python3-cantools_39.%.bbappend b/recipes-devtools/python/python3-cantools_39.%.bbappend
deleted file mode 100644
index 17531c73..00000000
--- a/recipes-devtools/python/python3-cantools_39.%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'python3-cantools_agldemo.inc', '', d)}
diff --git a/recipes-devtools/python/python3-cantools_agldemo.inc b/recipes-devtools/python/python3-cantools_agldemo.inc
deleted file mode 100644
index a4c6aa3a..00000000
--- a/recipes-devtools/python/python3-cantools_agldemo.inc
+++ /dev/null
@@ -1,3 +0,0 @@
-RDEPENDS:${PN} += "\
- python3-argparse-addons \
-"
diff --git a/recipes-devtools/python/python3-deprecation_2.1.0.bb b/recipes-devtools/python/python3-deprecation_2.1.0.bb
deleted file mode 100644
index c4b3a1cf..00000000
--- a/recipes-devtools/python/python3-deprecation_2.1.0.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-SUMMARY = "A library to handle automated deprecations"
-HOMEPAGE = "https://github.com/briancurtin/deprecation"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
-PYPI_PACKAGE = "deprecation"
-
-SRC_URI[sha256sum] = "72b3bde64e5d778694b0cf68178aed03d15e15477116add3fb773e581f9518ff"
-
-inherit pypi setuptools3
-
-BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-devtools/python/python3-graphql-core_3.2.3.bb b/recipes-devtools/python/python3-graphql-core_3.2.3.bb
deleted file mode 100644
index b12957a4..00000000
--- a/recipes-devtools/python/python3-graphql-core_3.2.3.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-SUMMARY = "GraphQL implementation for Python"
-HOMEPAGE = "https://github.com/graphql-python/graphql-core"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=73706fb002de2debc52328afd1688817"
-
-PYPI_PACKAGE = "graphql-core"
-
-SRC_URI[sha256sum] = "06d2aad0ac723e35b1cb47885d3e5c45e956a53bc1b209a9fc5369007fe46676"
-
-inherit pypi setuptools3
-
-BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb b/recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb
deleted file mode 100644
index 4c3dfaa9..00000000
--- a/recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-SUMMARY = "A final implementation of JSONPath for Python that aims to be standard compliant, including arithmetic and binary comparison operators and providing clear AST for metaprogramming."
-HOMEPAGE = "https://github.com/h2non/jsonpath-ng"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-PYPI_PACKAGE = "jsonpath-ng"
-
-SRC_URI[sha256sum] = "a273b182a82c1256daab86a313b937059261b5c5f8c4fa3fc38b882b344dd567"
-
-inherit pypi setuptools3
-
-RDEPENDS:${PN} += " \
- python3-ply \
- python3-six \
-"
diff --git a/recipes-devtools/python/python3-py-expression-eval_0.3.14.bb b/recipes-devtools/python/python3-py-expression-eval_0.3.14.bb
deleted file mode 100644
index 15a295f1..00000000
--- a/recipes-devtools/python/python3-py-expression-eval_0.3.14.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "Python Mathematical Expression Evaluator"
-HOMEPAGE = "https://github.com/AxiaCore/py-expression-eval"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=5a9126e7f56a0cf3247050de7f10d0f4"
-
-# NOTE: Pulling from github.com instead of pypi.org as the tarfiles on
-# the latter do not include the LICENSE file.
-
-SRC_URI = "git://github.com/axiacore/py-expression-eval.git;protocol=https;branch=master"
-SRCREV = "e7cfbedb3cdb1c428ae3dfbc967fe43deffa5e64"
-
-S = "${WORKDIR}/git"
-
-inherit setuptools3
diff --git a/recipes-devtools/python/python3-setuptools-git-versioning_1.7.4.bb b/recipes-devtools/python/python3-setuptools-git-versioning_1.7.4.bb
deleted file mode 100644
index 698a3bb6..00000000
--- a/recipes-devtools/python/python3-setuptools-git-versioning_1.7.4.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "Use git repo data for building a version number according PEP-440"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=f22e7cb81b49604c2450680982bdc067"
-PYPI_PACKAGE = "setuptools-git-versioning"
-
-DEPENDS = "python3-six-native"
-
-SRC_URI[sha256sum] = "be2901afcb7c865e3b500a38183598657fd029a1a72c8d1dfc7fbffb5c227dac"
-
-inherit pypi setuptools3
-
-RDEPENDS:${PN} += " \
- python3-setuptools \
- python3-six \
-"
-
-BBCLASSEXTEND = "native"