summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/weston-agl-driver-conf.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/wayland/weston-agl-driver-conf.bb')
-rw-r--r--recipes-graphics/wayland/weston-agl-driver-conf.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston-agl-driver-conf.bb b/recipes-graphics/wayland/weston-agl-driver-conf.bb
new file mode 100644
index 00000000..763103d4
--- /dev/null
+++ b/recipes-graphics/wayland/weston-agl-driver-conf.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Weston systemd configuration to run as agl-driver user"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit systemd allarch features_check
+
+REQUIRED_DISTRO_FEATURES = "wayland systemd"
+
+SRC_URI = "file://weston-agl-driver.conf"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ # Install override drop-in
+ install -d ${D}${systemd_system_unitdir}/weston.service.d
+ install -m 0644 ${WORKDIR}/weston-agl-driver.conf ${D}${systemd_system_unitdir}/weston.service.d/
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "weston agl-users"