summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/weston-terminal-conf.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/wayland/weston-terminal-conf.bb')
-rw-r--r--recipes-graphics/wayland/weston-terminal-conf.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston-terminal-conf.bb b/recipes-graphics/wayland/weston-terminal-conf.bb
index abc23cb4..573e2df0 100644
--- a/recipes-graphics/wayland/weston-terminal-conf.bb
+++ b/recipes-graphics/wayland/weston-terminal-conf.bb
@@ -4,6 +4,7 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7ca
SRC_URI = " \
file://org.freedesktop.weston.wayland-terminal.desktop \
+ file://weston-terminal.desktop \
"
inherit allarch
@@ -11,9 +12,19 @@ inherit allarch
do_install() {
install -d ${D}${datadir}/applications
install -m 0644 ${WORKDIR}/org.freedesktop.weston.wayland-terminal.desktop ${D}${datadir}/applications
+
+ # Enable systemd sandboxing override as a demonstration
+ mkdir -p ${D}${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d/
+ ln -sf ${sysconfdir}/systemd/sandboxing/no-network.conf ${D}${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d/
+
+ # HACK - install .desktop file for systemd until applaunchd can do enumeration with homescreen names and icons
+ install -m 0644 ${WORKDIR}/weston-terminal.desktop ${D}${datadir}/applications/
}
-FILES:${PN} = "${datadir}/applications"
+FILES:${PN} = " \
+ ${datadir}/applications \
+ ${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d \
+"
RDEPENDS:${PN} = " \
weston \