aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/wayland')
-rw-r--r--recipes-graphics/wayland/weston/0001-weston-patch-for-wl-shell-emulator.patch50
-rw-r--r--recipes-graphics/wayland/weston_1.5.0.bbappend5
2 files changed, 55 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston/0001-weston-patch-for-wl-shell-emulator.patch b/recipes-graphics/wayland/weston/0001-weston-patch-for-wl-shell-emulator.patch
new file mode 100644
index 00000000..0e149159
--- /dev/null
+++ b/recipes-graphics/wayland/weston/0001-weston-patch-for-wl-shell-emulator.patch
@@ -0,0 +1,50 @@
+---
+ ivi-shell/ivi-layout-export.h | 19 +++++++++++++++++++
+ ivi-shell/ivi-layout.c | 2 ++
+ 2 files changed, 21 insertions(+)
+
+diff --git a/ivi-shell/ivi-layout-export.h b/ivi-shell/ivi-layout-export.h
+index 8a92009..7f93c82 100644
+--- a/ivi-shell/ivi-layout-export.h
++++ b/ivi-shell/ivi-layout-export.h
+@@ -185,6 +185,25 @@ struct ivi_controller_interface {
+ int32_t (*commit_changes)(void);
+
+ /**
++ * \brief Creates an ivi_layout_surface.
++ *
++ * \return IVI_SUCCEEDED if the method call was successful
++ * \return IVI_FAILED if the method call was failed
++ */
++ struct ivi_layout_surface* (*surface_create)(
++ struct weston_surface *wl_surface,
++ uint32_t id_surface);
++
++ /**
++ * \brief Configure an ivi_layout_surface
++ *
++ * \return IVI_SUCCEEDED if the method call was successful
++ * \return IVI_FAILED if the method call was failed
++ */
++ void (*surface_configure)(struct ivi_layout_surface *ivisurf,
++ int32_t width, int32_t height);
++
++ /**
+ * surface controller interface
+ */
+
+diff --git a/ivi-shell/ivi-layout.c b/ivi-shell/ivi-layout.c
+index 51d0a8d..76891bf 100644
+--- a/ivi-shell/ivi-layout.c
++++ b/ivi-shell/ivi-layout.c
+@@ -2870,6 +2870,8 @@ static struct ivi_controller_interface ivi_controller_interface = {
+ */
+ .commit_changes = ivi_layout_commit_changes,
+
++ .surface_create = ivi_layout_surface_create,
++ .surface_configure = ivi_layout_surface_configure,
+ /**
+ * surface controller interfaces
+ */
+--
+1.8.3.1
diff --git a/recipes-graphics/wayland/weston_1.5.0.bbappend b/recipes-graphics/wayland/weston_1.5.0.bbappend
new file mode 100644
index 00000000..ee9422ff
--- /dev/null
+++ b/recipes-graphics/wayland/weston_1.5.0.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append = "\
+ file://0001-weston-patch-for-wl-shell-emulator.patch \
+ "