summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/wayland')
-rw-r--r--recipes-graphics/wayland/weston-agl-driver-conf.bb22
-rw-r--r--recipes-graphics/wayland/weston-agl-driver-conf/weston-agl-driver.conf5
2 files changed, 27 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston-agl-driver-conf.bb b/recipes-graphics/wayland/weston-agl-driver-conf.bb
new file mode 100644
index 00000000..763103d4
--- /dev/null
+++ b/recipes-graphics/wayland/weston-agl-driver-conf.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Weston systemd configuration to run as agl-driver user"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit systemd allarch features_check
+
+REQUIRED_DISTRO_FEATURES = "wayland systemd"
+
+SRC_URI = "file://weston-agl-driver.conf"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ # Install override drop-in
+ install -d ${D}${systemd_system_unitdir}/weston.service.d
+ install -m 0644 ${WORKDIR}/weston-agl-driver.conf ${D}${systemd_system_unitdir}/weston.service.d/
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "weston agl-users"
diff --git a/recipes-graphics/wayland/weston-agl-driver-conf/weston-agl-driver.conf b/recipes-graphics/wayland/weston-agl-driver-conf/weston-agl-driver.conf
new file mode 100644
index 00000000..75ab576a
--- /dev/null
+++ b/recipes-graphics/wayland/weston-agl-driver-conf/weston-agl-driver.conf
@@ -0,0 +1,5 @@
+[Service]
+User=
+User=agl-driver
+Group=
+Group=agl-driver