summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/aim-network/aim-network.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/aim-network/aim-network.bb')
-rw-r--r--recipes-kernel/aim-network/aim-network.bb11
1 files changed, 3 insertions, 8 deletions
diff --git a/recipes-kernel/aim-network/aim-network.bb b/recipes-kernel/aim-network/aim-network.bb
index ce504ead..b731f935 100644
--- a/recipes-kernel/aim-network/aim-network.bb
+++ b/recipes-kernel/aim-network/aim-network.bb
@@ -1,18 +1,16 @@
-DESCRIPTION = "Example of how to build an external Linux kernel module"
+DESCRIPTION = "Build networking driver for MOST"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
-# "
inherit module
PV = "0.1"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
+SRC_URI_append_porter = " file://0001-aim-network-backport-patch-for-3.10.31-ltsi.patch"
S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
-#SRCREV = "${AUTOREV}"
+SRCREV = "${AUTOREV}"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
@@ -24,6 +22,3 @@ do_install_append () {
echo "aim_network" > ${D}${sysconfdir}/modules-load.d/aim_network.conf
fi
}
-
-# These sources are currently for the porter kernel only
-COMPATIBLE_MACHINE = "porter"