summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/aim-sound
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/aim-sound')
-rw-r--r--recipes-kernel/aim-sound/aim-sound.bb25
-rw-r--r--recipes-kernel/aim-sound/files/0001-aim-sound-3.10.31-ltsi-backport.patch29
2 files changed, 0 insertions, 54 deletions
diff --git a/recipes-kernel/aim-sound/aim-sound.bb b/recipes-kernel/aim-sound/aim-sound.bb
deleted file mode 100644
index cb2b9836..00000000
--- a/recipes-kernel/aim-sound/aim-sound.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "Build ALSA driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-SRC_URI_append_porter = " file://0001-aim-sound-3.10.31-ltsi-backport.patch"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
- # modprobe automatically at boot
- if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
- install -d ${D}${sysconfdir}/modules-load.d
- echo "aim_sound" > ${D}${sysconfdir}/modules-load.d/aim_sound.conf
- fi
-}
diff --git a/recipes-kernel/aim-sound/files/0001-aim-sound-3.10.31-ltsi-backport.patch b/recipes-kernel/aim-sound/files/0001-aim-sound-3.10.31-ltsi-backport.patch
deleted file mode 100644
index b999b0d6..00000000
--- a/recipes-kernel/aim-sound/files/0001-aim-sound-3.10.31-ltsi-backport.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 686130266ff7968edc863d398fba82bd0f78bf29 Mon Sep 17 00:00:00 2001
-From: Christian Gromm <christian.gromm@microchip.com>
-Date: Wed, 28 Sep 2016 13:43:36 +0200
-Subject: [PATCH 1/4] backport module
-
-This patch replaces function snd_card_new() with snd_card_create() to match
-AGL/Renesas kernel API.
-
-Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
----
- aim-sound/sound.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/sound.c b/aim-sound/sound.c
-index 3dc625c..af0af2d 100644
---- a/sound.c
-+++ b/sound.c
-@@ -595,7 +595,7 @@ static int audio_probe_channel(struct most_interface *iface, int channel_id,
- return ret;
- }
-
-- ret = snd_card_new(NULL, -1, card_name, THIS_MODULE,
-+ ret = snd_card_create(-1, card_name, THIS_MODULE,
- sizeof(*channel), &card);
- if (ret < 0)
- return ret;
---
-1.7.9.5
-