summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/hdm-dim2/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/hdm-dim2/files/Makefile')
-rw-r--r--recipes-kernel/hdm-dim2/files/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-kernel/hdm-dim2/files/Makefile b/recipes-kernel/hdm-dim2/files/Makefile
new file mode 100644
index 00000000..a9dc62ab
--- /dev/null
+++ b/recipes-kernel/hdm-dim2/files/Makefile
@@ -0,0 +1,18 @@
+# Makefile
+#
+
+SRC := $(shell pwd)
+
+obj-m += hdm_dim2.o
+hdm_dim2-y := dim2_hdm.o dim2_hal.o dim2_sysfs.o
+CFLAGS_dim2_hdm.o := -I$(src)/../../mostcore/files -I$(src)/../../aim-network/files
+
+all:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules
+
+modules_install:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
+
+clean:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) clean
+