summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/aim-cdev/aim-cdev.bb8
-rw-r--r--recipes-kernel/aim-network/aim-network.bb8
-rw-r--r--recipes-kernel/aim-sound/aim-sound.bb8
-rw-r--r--recipes-kernel/aim-v4l2/aim-v4l2.bb8
-rw-r--r--recipes-kernel/hdm-dim2/hdm-dim2.bb8
-rw-r--r--recipes-kernel/hdm-i2c/hdm-i2c.bb8
-rw-r--r--recipes-kernel/hdm-usb/hdm-usb.bb8
-rw-r--r--recipes-kernel/mocca-usb/mocca-usb.bb8
-rw-r--r--recipes-kernel/mostcore/mostcore.bb8
9 files changed, 72 insertions, 0 deletions
diff --git a/recipes-kernel/aim-cdev/aim-cdev.bb b/recipes-kernel/aim-cdev/aim-cdev.bb
index b51fe236..b43800ec 100644
--- a/recipes-kernel/aim-cdev/aim-cdev.bb
+++ b/recipes-kernel/aim-cdev/aim-cdev.bb
@@ -16,3 +16,11 @@ SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "aim_cdev" > ${D}${sysconfdir}/modules-load.d/aim_cdev.conf
+ fi
+}
diff --git a/recipes-kernel/aim-network/aim-network.bb b/recipes-kernel/aim-network/aim-network.bb
index b51fe236..ce3d7677 100644
--- a/recipes-kernel/aim-network/aim-network.bb
+++ b/recipes-kernel/aim-network/aim-network.bb
@@ -16,3 +16,11 @@ SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "aim_network" > ${D}${sysconfdir}/modules-load.d/aim_network.conf
+ fi
+}
diff --git a/recipes-kernel/aim-sound/aim-sound.bb b/recipes-kernel/aim-sound/aim-sound.bb
index b51fe236..02d79077 100644
--- a/recipes-kernel/aim-sound/aim-sound.bb
+++ b/recipes-kernel/aim-sound/aim-sound.bb
@@ -16,3 +16,11 @@ SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "aim_sound" > ${D}${sysconfdir}/modules-load.d/aim_sound.conf
+ fi
+}
diff --git a/recipes-kernel/aim-v4l2/aim-v4l2.bb b/recipes-kernel/aim-v4l2/aim-v4l2.bb
index b51fe236..12336960 100644
--- a/recipes-kernel/aim-v4l2/aim-v4l2.bb
+++ b/recipes-kernel/aim-v4l2/aim-v4l2.bb
@@ -16,3 +16,11 @@ SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "aim_v4l2" > ${D}${sysconfdir}/modules-load.d/aim_v4l2.conf
+ fi
+}
diff --git a/recipes-kernel/hdm-dim2/hdm-dim2.bb b/recipes-kernel/hdm-dim2/hdm-dim2.bb
index b51fe236..d9cdf4d8 100644
--- a/recipes-kernel/hdm-dim2/hdm-dim2.bb
+++ b/recipes-kernel/hdm-dim2/hdm-dim2.bb
@@ -16,3 +16,11 @@ SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "hdm_dim2" > ${D}${sysconfdir}/modules-load.d/hdm_dim2.conf
+ fi
+}
diff --git a/recipes-kernel/hdm-i2c/hdm-i2c.bb b/recipes-kernel/hdm-i2c/hdm-i2c.bb
index b51fe236..6e51106b 100644
--- a/recipes-kernel/hdm-i2c/hdm-i2c.bb
+++ b/recipes-kernel/hdm-i2c/hdm-i2c.bb
@@ -16,3 +16,11 @@ SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "hdm_i2c" > ${D}${sysconfdir}/modules-load.d/hdm_i2c.conf
+ fi
+}
diff --git a/recipes-kernel/hdm-usb/hdm-usb.bb b/recipes-kernel/hdm-usb/hdm-usb.bb
index b51fe236..d8724d4f 100644
--- a/recipes-kernel/hdm-usb/hdm-usb.bb
+++ b/recipes-kernel/hdm-usb/hdm-usb.bb
@@ -16,3 +16,11 @@ SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "hdm_usb" > ${D}${sysconfdir}/modules-load.d/hdm_usb.conf
+ fi
+}
diff --git a/recipes-kernel/mocca-usb/mocca-usb.bb b/recipes-kernel/mocca-usb/mocca-usb.bb
index 6f4e5861..034585f1 100644
--- a/recipes-kernel/mocca-usb/mocca-usb.bb
+++ b/recipes-kernel/mocca-usb/mocca-usb.bb
@@ -12,3 +12,11 @@ SRCREV = "02ba272c0eb51b06160307b6cb71f91684772c8c"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "mocca_usb" > ${D}${sysconfdir}/modules-load.d/mocca_usb.conf
+ fi
+}
diff --git a/recipes-kernel/mostcore/mostcore.bb b/recipes-kernel/mostcore/mostcore.bb
index 3a2e1cfe..f170c58d 100644
--- a/recipes-kernel/mostcore/mostcore.bb
+++ b/recipes-kernel/mostcore/mostcore.bb
@@ -16,3 +16,11 @@ SRCREV = "7850efa9077fa84536e0442c65d39a36e25e39d1"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "mostcore" > ${D}${sysconfdir}/modules-load.d/mostcore.conf
+ fi
+}