summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux_agldemo.inc4
-rw-r--r--recipes-kernel/most/most.bbappend4
-rw-r--r--recipes-kernel/sllin/sllin.bb14
3 files changed, 11 insertions, 11 deletions
diff --git a/recipes-kernel/linux/linux_agldemo.inc b/recipes-kernel/linux/linux_agldemo.inc
index 84b61df0..40211774 100644
--- a/recipes-kernel/linux/linux_agldemo.inc
+++ b/recipes-kernel/linux/linux_agldemo.inc
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/linux:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/linux:"
# Enable assorted USB device support for demo systems
AGL_KCONFIG_FRAGMENTS += " \
@@ -35,4 +35,4 @@ AGL_KCONFIG_FRAGMENTS += "rtc.cfg"
AGL_KCONFIG_FRAGMENTS += "disable_most.cfg"
# Enable some things on qemuarm64 so MOST drivers will build and load.
-AGL_KCONFIG_FRAGMENTS_append_qemuarm64 = " most_deps.cfg"
+AGL_KCONFIG_FRAGMENTS:append:qemuarm64 = " most_deps.cfg"
diff --git a/recipes-kernel/most/most.bbappend b/recipes-kernel/most/most.bbappend
index 85bae749..af7ea687 100644
--- a/recipes-kernel/most/most.bbappend
+++ b/recipes-kernel/most/most.bbappend
@@ -1,6 +1,6 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-SRC_URI_append = " \
+SRC_URI:append = " \
file://0002-src-most-add-auto-conf-feature.patch \
file://0003-core-remove-kernel-log-for-MBO-status.patch \
file://0004-most-video-set-device_caps.patch \
diff --git a/recipes-kernel/sllin/sllin.bb b/recipes-kernel/sllin/sllin.bb
index 0c6793a1..70d1a931 100644
--- a/recipes-kernel/sllin/sllin.bb
+++ b/recipes-kernel/sllin/sllin.bb
@@ -12,7 +12,7 @@ S = "${WORKDIR}/git/sllin"
PV = "0.1+git${SRCPV}"
-SRC_URI_append = " \
+SRC_URI:append = " \
file://0001_update_makefile.patch;pnum=2 \
file://0002_fix_null_operation_check.patch;pnum=2 \
file://0003-Allow-recent-kernels-newer-4.11.x-to-build.patch;pnum=2 \
@@ -23,15 +23,15 @@ SRC_URI_append = " \
file://lin_config.conf \
"
-KERNEL_MODULE_AUTOLOAD_append = " sllin"
-KERNEL_MODULE_PROBECONF_append = " sllin"
+KERNEL_MODULE_AUTOLOAD:append = " sllin"
+KERNEL_MODULE_PROBECONF:append = " sllin"
SLLINBAUDRATE ??= "9600"
module_conf_sllin = "options sllin baudrate=${SLLINBAUDRATE}"
-SYSTEMD_SERVICE_${PN} = "sllin-demo.service"
+SYSTEMD_SERVICE:${PN} = "sllin-demo.service"
-do_install_append () {
+do_install:append () {
install -d 644 ${D}/${bindir}
install -m 755 ${WORKDIR}/start_lin_demo.sh ${D}/${bindir}/start_lin_demo.sh
install -d ${D}${systemd_system_unitdir}
@@ -40,6 +40,6 @@ do_install_append () {
install -m 0644 ${WORKDIR}/lin_config.conf ${D}${sysconfdir}/
}
-FILES_${PN} += "${bindir}/start_lin_demo.sh ${sysconfdir}/lin_config.conf"
+FILES:${PN} += "${bindir}/start_lin_demo.sh ${sysconfdir}/lin_config.conf"
-RDEPENDS_${PN} += "lin-config"
+RDEPENDS:${PN} += "lin-config"