summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/sllin/files/0005-Fix-build-with-5.13-kernel.patch24
-rw-r--r--recipes-kernel/sllin/files/0006-Fix-build-with-5.14-kernel.patch108
-rw-r--r--recipes-kernel/sllin/sllin/0001-update-makefile.patch21
-rw-r--r--recipes-kernel/sllin/sllin/0002-5.4-less-than-110-fix.patch25
-rw-r--r--recipes-kernel/sllin/sllin_git.bb22
5 files changed, 0 insertions, 200 deletions
diff --git a/recipes-kernel/sllin/files/0005-Fix-build-with-5.13-kernel.patch b/recipes-kernel/sllin/files/0005-Fix-build-with-5.13-kernel.patch
deleted file mode 100644
index 51147081..00000000
--- a/recipes-kernel/sllin/files/0005-Fix-build-with-5.13-kernel.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Remove TTY_LDISC_MAGIC usage
-
-The 5.13 kernel removed the .magic field from tty_ldisc_ops and
-the associated TTY_LDISC_MAGIC #define, so remove their use when
-building for 5.13 or newer.
-
-Upstream-Status: Inappropriate [no upstream]
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
----
-diff --git a/sllin/sllin.c b/sllin/sllin.c
-index 92c52ad..904cff9 100644
---- a/sllin/sllin.c
-+++ b/sllin/sllin.c
-@@ -1619,7 +1619,9 @@ static int sllin_ioctl(struct tty_struct *tty, struct file *file,
-
- static struct tty_ldisc_ops sll_ldisc = {
- .owner = THIS_MODULE,
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(5,13,0)
- .magic = TTY_LDISC_MAGIC,
-+#endif
- .name = "sllin",
- .open = sllin_open,
- .close = sllin_close,
diff --git a/recipes-kernel/sllin/files/0006-Fix-build-with-5.14-kernel.patch b/recipes-kernel/sllin/files/0006-Fix-build-with-5.14-kernel.patch
deleted file mode 100644
index bb0049f0..00000000
--- a/recipes-kernel/sllin/files/0006-Fix-build-with-5.14-kernel.patch
+++ /dev/null
@@ -1,108 +0,0 @@
-Updates for 5.14
-
-The 5.14 kernel reworked the tty register and unregister call
-arguments, and made one of the arguments to the receive_buf
-callback const, add some kernel version conditionals to handle
-those.
-
-Upstream-Status: Inappropriate [no upstream]
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
----
- sllin/sllin.c | 29 ++++++++++++++++++++++++-----
- 1 file changed, 24 insertions(+), 5 deletions(-)
-
-diff --git a/sllin/sllin.c b/sllin/sllin.c
-index 904cff9..b89d06d 100644
---- a/sllin/sllin.c
-+++ b/sllin/sllin.c
-@@ -72,6 +72,12 @@
- #include <linux/version.h>
- #include "linux/lin_bus.h"
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,14,0)
-+#define FP_CONST const
-+#else
-+#define FP_CONST
-+#endif
-+
- /* Should be in include/linux/tty.h */
- #define N_SLLIN 25
- /* -------------------------------- */
-@@ -185,9 +191,9 @@ struct sllin {
- static struct net_device **sllin_devs;
- static int sllin_configure_frame_cache(struct sllin *sl, struct can_frame *cf);
- static void sllin_slave_receive_buf(struct tty_struct *tty,
-- const unsigned char *cp, char *fp, int count);
-+ const unsigned char *cp, FP_CONST char *fp, int count);
- static void sllin_master_receive_buf(struct tty_struct *tty,
-- const unsigned char *cp, char *fp, int count);
-+ const unsigned char *cp, FP_CONST char *fp, int count);
-
-
- /* Values of two parity bits in LIN Protected
-@@ -492,7 +498,7 @@ static void sll_setup(struct net_device *dev)
- Routines looking at TTY side.
- ******************************************/
- static void sllin_master_receive_buf(struct tty_struct *tty,
-- const unsigned char *cp, char *fp, int count)
-+ const unsigned char *cp, FP_CONST char *fp, int count)
- {
- struct sllin *sl = (struct sllin *) tty->disc_data;
-
-@@ -735,7 +741,7 @@ static void sllin_slave_finish_rx_msg(struct sllin *sl)
- }
-
- static void sllin_slave_receive_buf(struct tty_struct *tty,
-- const unsigned char *cp, char *fp, int count)
-+ const unsigned char *cp, FP_CONST char *fp, int count)
- {
- struct sllin *sl = (struct sllin *) tty->disc_data;
- int lin_id;
-@@ -842,7 +848,7 @@ static void sllin_slave_receive_buf(struct tty_struct *tty,
- }
-
- static void sllin_receive_buf(struct tty_struct *tty,
-- const unsigned char *cp, char *fp, int count)
-+ const unsigned char *cp, FP_CONST char *fp, int count)
- {
- struct sllin *sl = (struct sllin *) tty->disc_data;
- netdev_dbg(sl->dev, "sllin_receive_buf invoked, count = %u\n", count);
-@@ -1619,6 +1625,9 @@ static int sllin_ioctl(struct tty_struct *tty, struct file *file,
-
- static struct tty_ldisc_ops sll_ldisc = {
- .owner = THIS_MODULE,
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,14,0)
-+ .num = N_SLLIN,
-+#endif
- #if LINUX_VERSION_CODE < KERNEL_VERSION(5,13,0)
- .magic = TTY_LDISC_MAGIC,
- #endif
-@@ -1648,7 +1657,11 @@ static int __init sllin_init(void)
- }
-
- /* Fill in our line protocol discipline, and register it */
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,14,0)
-+ status = tty_register_ldisc(&sll_ldisc);
-+#else
- status = tty_register_ldisc(N_SLLIN, &sll_ldisc);
-+#endif
- if (status) {
- pr_err("sllin: can't register line discipline\n");
- kfree(sllin_devs);
-@@ -1719,9 +1732,15 @@ static void __exit sllin_exit(void)
- kfree(sllin_devs);
- sllin_devs = NULL;
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,14,0)
-+ tty_unregister_ldisc(&sll_ldisc);
-+
-+#else
- i = tty_unregister_ldisc(N_SLLIN);
-+
- if (i)
- pr_err("sllin: can't unregister ldisc (err %d)\n", i);
-+#endif
- }
-
- module_init(sllin_init);
diff --git a/recipes-kernel/sllin/sllin/0001-update-makefile.patch b/recipes-kernel/sllin/sllin/0001-update-makefile.patch
deleted file mode 100644
index 7db57802..00000000
--- a/recipes-kernel/sllin/sllin/0001-update-makefile.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/sllin/Makefile b/sllin/Makefile
-index 8ae7510..037846f 100644
---- a/sllin/Makefile
-+++ b/sllin/Makefile
-@@ -1,10 +1,11 @@
- obj-m += sllin.o
--KPATH=/lib/modules/$(shell uname -r)/build
-+KPATH=$(KERNEL_SRC)
- #KPATH=/mnt/data/_dokumenty_/_w_/_dce_can_/src/can-benchmark/kernel/build/shark/3.0.4
- #KPATH=/mnt/data/_dokumenty_/_w_/_dce_can_/src/can-benchmark/kernel/build/shark/2.6.36
--
-+SRC := $(shell pwd)
- all:
-- make -C ${KPATH} M=$(PWD) modules
--
-+ make -C ${KPATH} M=$(SRC) modules
-+modules_install:
-+ make -C ${KPATH} M=$(SRC) modules_install
- clean:
-- make -C ${KPATH} M=$(PWD) clean
-+ make -C ${KPATH} M=$(SRC) clean
diff --git a/recipes-kernel/sllin/sllin/0002-5.4-less-than-110-fix.patch b/recipes-kernel/sllin/sllin/0002-5.4-less-than-110-fix.patch
deleted file mode 100644
index 8c13bfb5..00000000
--- a/recipes-kernel/sllin/sllin/0002-5.4-less-than-110-fix.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Fix compilation against kernels < 5.4.110
-
-The fix to handle the backport of 4e096a18 to linux-5.4.y is a bit
-too broad, as it breaks building against kernels older than 5.4.110,
-add a version check to fix.
-
-Upstream-Status: pending
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
-diff --git a/sllin/sllin.c b/sllin/sllin.c
-index b3f2636..a6fb120 100644
---- a/sllin/sllin.c
-+++ b/sllin/sllin.c
-@@ -1604,7 +1604,11 @@ static struct sllin *sll_alloc(dev_t line)
- sl = netdev_priv(dev);
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 4, 0)
- can_ml = (void *)sl + ALIGN(sizeof(*sl), NETDEV_ALIGN);
-+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 4, 110)
- can_set_ml_priv(dev, can_ml);
-+ #else
-+ dev->ml_priv = can_ml;
-+ #endif
- #endif
- /* Initialize channel control data */
- sl->magic = SLLIN_MAGIC;
diff --git a/recipes-kernel/sllin/sllin_git.bb b/recipes-kernel/sllin/sllin_git.bb
deleted file mode 100644
index f13bcd55..00000000
--- a/recipes-kernel/sllin/sllin_git.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-DESCRIPTION = "slLIN driver module"
-LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://sllin.c;beginline=7;endline=37;md5=6408e14dba951f8cbe3c2a003a0d89d2"
-
-inherit module
-
-DEPENDS = "virtual/kernel"
-
-SRC_URI = "git://github.com/lin-bus/linux-lin.git;protocol=https;branch=master \
- file://0001-update-makefile.patch;pnum=2 \
- file://0002-5.4-less-than-110-fix.patch;pnum=2 \
-"
-SRCREV = "beb057d7505e0c4d7c61f3f4927b76916ec00e88"
-S = "${WORKDIR}/git/sllin"
-
-PV = "0.1+git${SRCPV}"
-
-KERNEL_MODULE_AUTOLOAD:append = " sllin"
-KERNEL_MODULE_PROBECONF:append = " sllin"
-
-SLLINBAUDRATE ??= "9600"
-module_conf_sllin = "options sllin baudrate=${SLLINBAUDRATE}"