summaryrefslogtreecommitdiffstats
path: root/recipes-navigation
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-navigation')
-rw-r--r--recipes-navigation/geoclue/geoclue_agldemo.inc4
-rw-r--r--recipes-navigation/gpsd/gpsd_agldemo.inc10
-rw-r--r--recipes-navigation/osrm-backend/osrm-backend_git.bb2
-rw-r--r--recipes-navigation/protozero/protozero_git.bb2
4 files changed, 9 insertions, 9 deletions
diff --git a/recipes-navigation/geoclue/geoclue_agldemo.inc b/recipes-navigation/geoclue/geoclue_agldemo.inc
index 1e317031..14f730ee 100644
--- a/recipes-navigation/geoclue/geoclue_agldemo.inc
+++ b/recipes-navigation/geoclue/geoclue_agldemo.inc
@@ -1,9 +1,9 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI += "file://geoclue.conf.agl"
PACKAGECONFIG = "nmea lib"
-do_install_append() {
+do_install:append() {
install -D -m 0644 ${WORKDIR}/geoclue.conf.agl ${D}${sysconfdir}/geoclue/geoclue.conf
}
diff --git a/recipes-navigation/gpsd/gpsd_agldemo.inc b/recipes-navigation/gpsd/gpsd_agldemo.inc
index 5899505b..92303f8b 100644
--- a/recipes-navigation/gpsd/gpsd_agldemo.inc
+++ b/recipes-navigation/gpsd/gpsd_agldemo.inc
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/gpsd:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/gpsd:"
SRC_URI += "file://sw-device-hook"
-do_install_append() {
+do_install:append() {
# Install device-hook script for starting NMEA output on Sierra Wireless modems
install -d ${D}${sysconfdir}/gpsd
install -m 0755 ${WORKDIR}/sw-device-hook ${D}${sysconfdir}/gpsd/device-hook
@@ -10,11 +10,11 @@ do_install_append() {
-SYSTEMD_SERVICE_${PN}_append = " gpsdctl@.service"
+SYSTEMD_SERVICE:${PN}:append = " gpsdctl@.service"
-RPROVIDES_${PN}-conf_append = " virtual/gpsd-conf"
+RPROVIDES:${PN}-conf:append = " virtual/gpsd-conf"
-do_install_append() {
+do_install:append() {
# use the systemd compatible gpsd.rules
install -d ${D}/${sysconfdir}/udev/rules.d
install -m 0644 ${S}/gpsd.rules ${D}/${sysconfdir}/udev/rules.d/60-gpsd.rules
diff --git a/recipes-navigation/osrm-backend/osrm-backend_git.bb b/recipes-navigation/osrm-backend/osrm-backend_git.bb
index be93e210..0b5bd3a2 100644
--- a/recipes-navigation/osrm-backend/osrm-backend_git.bb
+++ b/recipes-navigation/osrm-backend/osrm-backend_git.bb
@@ -12,7 +12,7 @@ SRC_URI = "git://github.com/Project-OSRM/osrm-backend.git;protocol=http \
SRCREV = "5b58445535633eb1d6840ef4e8786ff521622867"
-FILES_${PN} += " \
+FILES:${PN} += " \
${datadir}/osrm/profiles/*.lua \
${datadir}/osrm/profiles/*/*.lua \
"
diff --git a/recipes-navigation/protozero/protozero_git.bb b/recipes-navigation/protozero/protozero_git.bb
index 3625dcad..c65968cd 100644
--- a/recipes-navigation/protozero/protozero_git.bb
+++ b/recipes-navigation/protozero/protozero_git.bb
@@ -15,6 +15,6 @@ SRCREV = "aa8b304cf63831589f52c254b5af2c688bdc2fc4"
S = "${WORKDIR}/git"
-CFLAGS_prepend = " -I${STAGING_DIR_HOST}/include"
+CFLAGS:prepend = " -I${STAGING_DIR_HOST}/include"
inherit cmake pkgconfig