summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-cluster-demo-flutter.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-platform/images/agl-cluster-demo-flutter.bb')
-rw-r--r--recipes-platform/images/agl-cluster-demo-flutter.bb16
1 files changed, 6 insertions, 10 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-flutter.bb b/recipes-platform/images/agl-cluster-demo-flutter.bb
index 5cf3daf9..b2581f87 100644
--- a/recipes-platform/images/agl-cluster-demo-flutter.bb
+++ b/recipes-platform/images/agl-cluster-demo-flutter.bb
@@ -7,31 +7,27 @@ require agl-demo-features.inc
IMAGE_FEATURES += "splash package-management ssh-server-openssh"
-# KUKSA.val databroker is not installed with "agl-demo-preload"
-# feature enabled, since demo unit configuration points at the
-# databroker on the IVI board in that setup.
IMAGE_FEATURES += " \
kuksa-val-databroker-client \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "kuksa-val-databroker", d)} \
+ kuksa-val-databroker \
"
# Generic
IMAGE_INSTALL += "\
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "psplash-inverted-config", "", d)} \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
+ weston-ini-conf-landscape \
\
packagegroup-agl-networking \
cluster-receiver \
\
simple-can-simulator \
- "
+"
# Flutter
IMAGE_INSTALL += "\
+ flutter-auto \
flutter-cluster-dashboard \
- ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "flutter-cluster-dashboard-conf-demo", "flutter-cluster-dashboard-conf", d)} \
+ flutter-cluster-dashboard-conf \
cluster-demo-config-flutter \
- flutter-auto \
- "
+"
CLANGSDK = "1"