summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/images/agl-cluster-demo-flutter-preconfigured-gateway.bb8
-rw-r--r--recipes-platform/images/agl-gateway-demo-preconfigured.bb10
-rw-r--r--recipes-platform/images/agl-gateway-demo.bb24
-rw-r--r--recipes-platform/images/agl-ivi-demo-flutter-preconfigured-gateway.bb14
4 files changed, 56 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-cluster-demo-flutter-preconfigured-gateway.bb b/recipes-platform/images/agl-cluster-demo-flutter-preconfigured-gateway.bb
new file mode 100644
index 00000000..767d339c
--- /dev/null
+++ b/recipes-platform/images/agl-cluster-demo-flutter-preconfigured-gateway.bb
@@ -0,0 +1,8 @@
+require agl-cluster-demo-flutter-preconfigured.bb
+
+SUMMARY = "AGL Cluster preconfigured gateway demo Flutter image"
+
+# Cluster application configuration needs to be replaced for
+# the full demo to handle different databroker configuration.
+FLUTTER_CLUSTER_DASHBOARD_CONF = "flutter-cluster-dashboard-conf-gateway-demo"
+
diff --git a/recipes-platform/images/agl-gateway-demo-preconfigured.bb b/recipes-platform/images/agl-gateway-demo-preconfigured.bb
new file mode 100644
index 00000000..4a9cf0b2
--- /dev/null
+++ b/recipes-platform/images/agl-gateway-demo-preconfigured.bb
@@ -0,0 +1,10 @@
+require agl-gateway-demo.bb
+
+SUMMARY = "AGL gateway preconfigured demo image"
+
+# Second CAN interface will be connected to the demo setup
+# steering wheel & HVAC in the full demo.
+IMAGE_INSTALL += " \
+ kuksa-dbc-feeder-conf-gw-hardware \
+ vss-agl-gw-hardware \
+"
diff --git a/recipes-platform/images/agl-gateway-demo.bb b/recipes-platform/images/agl-gateway-demo.bb
new file mode 100644
index 00000000..1e800c54
--- /dev/null
+++ b/recipes-platform/images/agl-gateway-demo.bb
@@ -0,0 +1,24 @@
+SUMMARY = "AGL gateway demo image"
+
+LICENSE = "MIT"
+
+require recipes-platform/images/agl-image-minimal.bb
+require agl-demo-features.inc
+
+IMAGE_FEATURES += " \
+ kuksa-val-databroker \
+ ssh-server-openssh \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'can-test-tools' , '', d)} \
+"
+
+AGL_DEVEL_INSTALL = " \
+ packagegroup-agl-kuksa-val-databroker-devel \
+ tcpdump \
+"
+
+IMAGE_INSTALL += " \
+ agl-vss-proxy \
+ kuksa-dbc-feeder-conf-gw-control-panel \
+ vss-agl-gw-control-panel \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '${AGL_DEVEL_INSTALL}', '', d)} \
+"
diff --git a/recipes-platform/images/agl-ivi-demo-flutter-preconfigured-gateway.bb b/recipes-platform/images/agl-ivi-demo-flutter-preconfigured-gateway.bb
new file mode 100644
index 00000000..1bbd483b
--- /dev/null
+++ b/recipes-platform/images/agl-ivi-demo-flutter-preconfigured-gateway.bb
@@ -0,0 +1,14 @@
+require agl-ivi-demo-flutter-preconfigured.bb
+
+SUMMARY = "AGL IVI preconfigured gateway demo Flutter image"
+
+# We do not want a local databroker instance
+IMAGE_FEATURES:remove = "kuksa-val-databroker"
+
+FLUTTER_ICS_HOMESCREEN_CONF = "flutter-ics-homescreen-conf-gateway-demo"
+ONDEMANDNAVI_CONF = "ondemandnavi-conf-gateway-demo"
+
+IMAGE_INSTALL += " \
+ agl-service-hvac-conf-gateway-demo \
+ agl-service-audiomixer-conf-gateway-demo \
+" \ No newline at end of file