summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/lin-config/files/0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch33
-rw-r--r--recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch20
-rw-r--r--recipes-support/lin-config/lin-config_git.bb25
3 files changed, 0 insertions, 78 deletions
diff --git a/recipes-support/lin-config/files/0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch b/recipes-support/lin-config/files/0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch
deleted file mode 100644
index fe08b7d8..00000000
--- a/recipes-support/lin-config/files/0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 59acd73ba3bd6cc4151b890d135c6d690a83374d Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Jan-Simon=20M=C3=B6ller?= <jsmoeller@linuxfoundation.org>
-Date: Tue, 1 Oct 2019 15:24:07 +0000
-Subject: [PATCH] Change Makefile to use pkg-config for libxml-2.0
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-instead of xml2-config.
-
-Upstream-Status: Pending
-
-Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
----
- lin_config/src/Makefile | 5 ++---
- 1 file changed, 2 insertions(+), 3 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index cf5c515..3fc4df1 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,6 +1,5 @@
--CC=gcc
--CFLAGS=-std=gnu99 -Wall -pedantic $(DEBUG) `xml2-config --cflags` `pkg-config --cflags libnl-route-3.0` -I$(INCLUDE)
--LIBS=`xml2-config --libs` `pkg-config --libs libnl-route-3.0`
-+CFLAGS=-std=gnu99 -Wall -pedantic $(DEBUG) `pkg-config --cflags libxml-2.0` `pkg-config --cflags libnl-route-3.0` -I$(INCLUDE)
-+LIBS=`pkg-config --libs libxml-2.0` `pkg-config --libs libnl-route-3.0`
- INCLUDE=../../sllin
- DEBUG=-ggdb
-
---
-2.16.4
-
diff --git a/recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch b/recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch
deleted file mode 100644
index 26364455..00000000
--- a/recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Use LDFLAGS when linking
-
-Use LDFLAGS when linking the output binary to quiet QA warnings due to
-missing link flags.
-
-Upstream-Status: Pending
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
---- a/Makefile 2019-11-05 11:08:11.060565285 +0000
-+++ b/Makefile 2019-11-05 11:09:38.663570084 +0000
-@@ -6,7 +6,7 @@
- objects = linc_parse_xml.o pcl_config.o sllin_config.o lin_config.o
-
- lin_config: $(objects)
-- $(CC) $(objects) $(LIBS) -o lin_config
-+ $(CC) $(LDFLAGS) $(objects) $(LIBS) -o lin_config
-
- %.o : %.c %.h
- $(CC) $(CFLAGS) $(LIBS) -c $< -o $@
diff --git a/recipes-support/lin-config/lin-config_git.bb b/recipes-support/lin-config/lin-config_git.bb
deleted file mode 100644
index a8c8f4fc..00000000
--- a/recipes-support/lin-config/lin-config_git.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "lin-config tool for the sllin driver module"
-LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://lin_config.c;beginline=4;endline=9;md5=196a29df19a30dbc752937bdfc819d7a"
-
-DEPENDS += "libnl libxml2"
-
-SRC_URI = "git://github.com/lin-bus/linux-lin.git;protocol=https;branch=master"
-SRCREV = "beb057d7505e0c4d7c61f3f4927b76916ec00e88"
-S = "${WORKDIR}/git/lin_config/src"
-
-SRC_URI:append = " \
- file://0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch \
- file://0002-Change-Makefile-to-use-LDFLAGS.patch \
- "
-
-inherit pkgconfig
-
-PV = "0.1+git${SRCPV}"
-
-do_configure[noexec] = "1"
-
-do_install:append() {
- install -d ${D}/${bindir}
- install -m 755 ${S}/lin_config ${D}/${bindir}
-}