summaryrefslogtreecommitdiffstats
path: root/recipes-test/pyagl/pyagl_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/pyagl/pyagl_git.bb')
-rw-r--r--recipes-test/pyagl/pyagl_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-test/pyagl/pyagl_git.bb b/recipes-test/pyagl/pyagl_git.bb
new file mode 100644
index 00000000..821a1de7
--- /dev/null
+++ b/recipes-test/pyagl/pyagl_git.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Python bindings and tests for Automotive Grade Linux services"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/pyagl"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/pyagl;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "dcc2f91e5ab3b70202e78ec7164a8e9d7501d70c"
+PV = "${AGL_BRANCH}+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+do_install_append() {
+ install -D -m 0755 ${S}/pyagl/scripts/pyagl ${D}${bindir}/pyagl
+}
+
+RDEPENDS_${PN} += " \
+ python3-asyncio \
+ python3-asyncssh \
+ python3-core \
+ python3-json \
+ python3-logging \
+ python3-math \
+ python3-parse \
+ python3-pprint \
+ python3-pytest \
+ python3-pytest-asyncio \
+ python3-pytest-dependency \
+ python3-pytest-reverse \
+ python3-typing \
+ python3-websockets \
+"