summaryrefslogtreecommitdiffstats
path: root/recipes-wam/chromium
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-wam/chromium')
-rw-r--r--recipes-wam/chromium/chromium-browser-service.bb19
-rw-r--r--recipes-wam/chromium/chromium.inc354
-rw-r--r--recipes-wam/chromium/chromium84_git.bb81
-rw-r--r--recipes-wam/chromium/files/add-a-delay-to-agl-ready-event.patch70
-rw-r--r--recipes-wam/chromium/files/chromium-quiche-invalid-offsetof.patch57
-rw-r--r--recipes-wam/chromium/files/chromium-skia-no_sanitize.patch63
-rw-r--r--recipes-wam/chromium/gn-utils.inc32
7 files changed, 0 insertions, 676 deletions
diff --git a/recipes-wam/chromium/chromium-browser-service.bb b/recipes-wam/chromium/chromium-browser-service.bb
deleted file mode 100644
index d9a4206d5..000000000
--- a/recipes-wam/chromium/chromium-browser-service.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-SUMMARY = "Chromium browser widget"
-DESCRIPTION = "Wgt packaging for running chromium installed browser"
-HOMEPAGE = "https://webosose.org"
-SECTION = "apps"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/chromium;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
-
-PV = "1.0+git${SRCPV}"
-S = "${WORKDIR}/git"
-
-#build-time dependencies
-DEPENDS += "af-binder af-main-native chromium84"
-
-inherit cmake aglwgt
-
-RDEPENDS:${PN} += "chromium84-browser"
diff --git a/recipes-wam/chromium/chromium.inc b/recipes-wam/chromium/chromium.inc
deleted file mode 100644
index 722ba9a34..000000000
--- a/recipes-wam/chromium/chromium.inc
+++ /dev/null
@@ -1,354 +0,0 @@
-# Copyright (c) 2018 LG Electronics, Inc.
-
-SUMMARY = "Chromium webruntime for webOS"
-AUTHOR = "Lokesh Kumar Goel <lokeshkumar.goel@lge.com>"
-SECTION = "webos/apps"
-LICENSE = "Apache-2.0 & BSD-3-Clause & LGPL-2.0 & LGPL-2.1"
-LIC_FILES_CHKSUM = "\
- file://src/LICENSE;md5=0fca02217a5d49a14dfe2d11837bb34d \
- file://src/third_party/blink/renderer/core/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
- file://src/third_party/blink/renderer/core/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
-"
-
-require gn-utils.inc
-
-inherit gettext qemu pythonnative
-
-DEPENDS = "virtual/gettext wayland wayland-native pixman freetype glib-2.0 fontconfig openssl pango cairo icu libxkbcommon libexif dbus pciutils udev libcap alsa-lib virtual/egl elfutils-native libdrm atk at-spi2-atk gperf-native gconf nss nss-native nspr nspr-native bison-native qemu-native"
-
-PROVIDES = "${BROWSER_APPLICATION}"
-
-SRCREV_v8 = "1e3af71f1ff3735e8a5b639c48dfca63a7b8a647"
-
-# we don't include SRCPV in PV, so we have to manually include SRCREVs in do_fetch vardeps
-do_fetch[vardeps] += "SRCREV_v8"
-SRCREV_FORMAT = "main_v8"
-
-S = "${WORKDIR}/git"
-
-SRC_DIR = "${S}/src"
-BUILD_TYPE = "Release"
-
-B = "${WORKDIR}/build"
-OUT_DIR = "${B}/${BUILD_TYPE}"
-
-WEBRUNTIME_BUILD_TARGET = "webos:weboswebruntime"
-BROWSER_APP_BUILD_TARGET = "chrome"
-BROWSER_APPLICATION = "chromium84-browser"
-BROWSER_APPLICATION_DIR = "/opt/chromium84"
-
-TARGET = "${WEBRUNTIME_BUILD_TARGET} ${BROWSER_APP_BUILD_TARGET}"
-
-# Skip do_install:append of webos_system_bus. It is not compatible with this component.
-WEBOS_SYSTEM_BUS_FILES_LOCATION = "${S}/files/sysbus"
-
-PACKAGECONFIG ?= "jumbo use-upstream-wayland"
-
-
-# Set a default value for jumbo file merge of 8. This should be good for build
-# servers and workstations with a big number of cores. In case build is
-# happening in a machine with less cores but still enough RAM a good value could
-# be 50.
-JUMBO_FILE_MERGE_LIMIT="8"
-PACKAGECONFIG[jumbo] = "use_jumbo_build=true jumbo_file_merge_limit=${JUMBO_FILE_MERGE_LIMIT}, use_jumbo_build=false"
-
-PACKAGECONFIG[lttng] = "use_lttng=true,use_lttng=false,lttng-ust,lttng-tools lttng-modules babeltrace"
-
-# Chromium can use v4l2 device for hardware accelerated video decoding on such boards as Renesas R-car M3, for example.
-# In case of R-car m3, additional patches are required for gstreamer and v4l2apps.
-# See https://github.com/igel-oss/meta-browser-hwdecode/tree/igalia-chromium71.
-PACKAGECONFIG[use-linux-v4l2] = "use_v4l2_codec=true use_v4lplugin=true use_linux_v4l2_only=true"
-
-PACKAGECONFIG[use-upstream-wayland] = " \
- ozone_platform_wayland_external=false ozone_platform_wayland=true, \
- ozone_platform_wayland_external=true ozone_platform_wayland=false \
-"
-
-GN_ARGS = "\
- enable_memorymanager_webapi=false\
- ffmpeg_branding=\"Chrome\"\
- host_os=\"linux\"\
- ozone_auto_platforms=false\
- proprietary_codecs=true\
- target_os=\"linux\"\
- treat_warnings_as_errors=false\
- is_agl=true\
- use_cbe=true\
- is_chrome_cbe=true\
- is_component_build=false\
- use_cups=false\
- use_custom_libcxx=false\
- use_kerberos=false\
- use_neva_media=false\
- use_ozone=true\
- use_xkbcommon=true\
- use_wayland_gbm=false\
- use_pmlog=false\
- use_system_debugger_abort=true\
- ${PACKAGECONFIG_CONFARGS}\
-"
-
-# From Chromium's BUILDCONFIG.gn:
-# Set to enable the official build level of optimization. This has nothing
-# to do with branding, but enables an additional level of optimization above
-# release (!is_debug). This might be better expressed as a tri-state
-# (debug, release, official) but for historical reasons there are two
-# separate flags.
-# See also: https://groups.google.com/a/chromium.org/d/msg/chromium-dev/hkcb6AOX5gE/PPT1ukWoBwAJ
-GN_ARGS += "is_debug=false is_official_build=true"
-
-# is_cfi default value is true for x86-64 builds with is_official_build=true.
-# As of M63, we explicitly need to set it to false, otherwise we fail the
-# following assertion in //build/config/sanitizers/sanitizers.gni:
-# assert(!is_cfi || is_clang,
-# "is_cfi requires setting is_clang = true in 'gn args'")
-GN_ARGS += "is_cfi=false"
-
-# By default, passing is_official_build=true to GN causes its symbol_level
-# variable to be set to "2". This means the compiler will be passed "-g2" and
-# we will end up with a very large chrome binary (around 5Gb as of M58)
-# regardless of whether DEBUG_BUILD has been set or not. In addition, binutils,
-# file and other utilities are unable to read a 32-bit binary this size, which
-# causes it not to be stripped.
-# The solution is two-fold:
-# 1. Make sure -g is not passed on 32-bit architectures via DEBUG_FLAGS. -g is
-# the same as -g2. -g1 generates an 800MB binary, which is a lot more
-# manageable.
-# 2. Explicitly pass symbol_level=0 to GN. This causes -g0 to be passed
-# instead, so that if DEBUG_BUILD is not set GN will not create a huge debug
-# binary anyway. Since our compiler flags are passed after GN's, -g0 does
-# not cause any issues if DEBUG_BUILD is set, as -g1 will be passed later.
-DEBUG_FLAGS:remove:arm = "-g"
-DEBUG_FLAGS:append:arm = "-g1"
-DEBUG_FLAGS:remove:x86 = "-g"
-DEBUG_FLAGS:append:x86 = "-g1"
-GN_ARGS += "symbol_level=0"
-
-# We do not want to use Chromium's own Debian-based sysroots, it is easier to
-# just let Chromium's build system assume we are not using a sysroot at all and
-# let Yocto handle everything.
-GN_ARGS += "use_sysroot=false"
-
-# ARM builds need special additional flags (see ${S}/build/config/arm.gni).
-# If we do not pass |arm_arch| and friends to GN, it will deduce a value that
-# will then conflict with TUNE_CCARGS and CC.
-# Note that as of M61 in some corner cases parts of the build system disable
-# the "compiler_arm_fpu" GN config, whereas -mfpu is always passed via ${CC}.
-# We might want to rework that if there are issues in the future.
-def get_compiler_flag(params, param_name, d):
- """Given a sequence of compiler arguments in |params|, returns the value of
- an option |param_name| or an empty string if the option is not present."""
- for param in params:
- if param.startswith(param_name):
- return param.split('=')[1]
- return ''
-
-ARM_FLOAT_ABI = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', 'hard', 'softfp', d)}"
-ARM_FPU = "${@get_compiler_flag(d.getVar('TUNE_CCARGS').split(), '-mfpu', d)}"
-ARM_TUNE = "${@get_compiler_flag(d.getVar('TUNE_CCARGS').split(), '-mcpu', d)}"
-ARM_VERSION:aarch64 = "8"
-ARM_VERSION:armv7a = "7"
-ARM_VERSION:armv7ve = "7"
-ARM_VERSION:armv6 = "6"
-
-# GN computes and defaults to it automatically where needed
-# forcing it from cmdline breaks build on places where it ends up
-# overriding what GN wants
-TUNE_CCARGS:remove = "-mthumb"
-
-GN_ARGS:append:arm = " \
- arm_float_abi=\"${ARM_FLOAT_ABI}\" \
- arm_fpu=\"${ARM_FPU}\" \
- arm_tune=\"${ARM_TUNE}\" \
- arm_version=${ARM_VERSION} \
-"
-# tcmalloc's atomicops-internals-arm-v6plus.h uses the "dmb" instruction that
-# is not available on (some?) ARMv6 models, which causes the build to fail.
-GN_ARGS:append:armv6 += 'use_allocator="none"'
-# The WebRTC code fails to build on ARMv6 when NEON is enabled.
-# https://bugs.chromium.org/p/webrtc/issues/detail?id=6574
-GN_ARGS:append:armv6 += 'arm_use_neon=false'
-
-# Disable glibc shims on musl
-# tcmalloc does not play well with musl as of M62 (and possibly earlier).
-# https://github.com/gperftools/gperftools/issues/693
-GN_ARGS:append:libc-musl = ' use_allocator_shim=false'
-
-# More options to speed up the build
-GN_ARGS += "\
- enable_nacl=false\
- disable_ftp_support=true\
- enable_print_preview=false\
- enable_remoting=false\
- use_glib=true\
- use_gnome_keyring=false\
- use_pulseaudio=false\
-"
-
-# Doesn't build for armv[45]*
-COMPATIBLE_MACHINE = "(-)"
-COMPATIBLE_MACHINE:aarch64 = "(.*)"
-COMPATIBLE_MACHINE:armv6 = "(.*)"
-COMPATIBLE_MACHINE:armv7a = "(.*)"
-COMPATIBLE_MACHINE:armv7ve = "(.*)"
-COMPATIBLE_MACHINE:x86 = "(.*)"
-COMPATIBLE_MACHINE:x86-64 = "(.*)"
-
-#CHROMIUM_PLUGINS_PATH = "${libdir}"
-CBE_DATA_PATH = "${libdir}/cbe"
-CBE_DATA_LOCALES_PATH = "${CBE_DATA_PATH}/locales"
-
-# The text relocations are intentional -- see comments in [GF-52468]
-# TODO: check if we need INSANE_SKIP on ldflags
-INSANE_SKIP:${PN} = "textrel ldflags"
-
-
-do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+"
-do_compile() {
- if [ ! -f ${OUT_DIR}/build.ninja ]; then
- do_configure
- fi
-
- export PATH="${S}/depot_tools:$PATH"
- ${S}/depot_tools/ninja ${PARALLEL_MAKE} -v -C ${OUT_DIR} ${TARGET}
-}
-
-do_configure() {
- configure_env
-}
-
-configure_env() {
- export GYP_CHROMIUM_NO_ACTION=1
- export PATH="${S}/depot_tools:$PATH"
-
- GN_ARGS="${GN_ARGS}"
- echo GN_ARGS is ${GN_ARGS}
- echo BUILD_TARGETS are ${TARGET}
- cd ${SRC_DIR}
- gn gen ${OUT_DIR} --args="${GN_ARGS}"
-}
-
-WINDOW_SIZE ?= "1920,1080"
-
-configure_browser_settings() {
- USER_AGENT="Mozilla/5.0 (Linux; NetCast; U) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/${CHROMIUM_VERSION} Safari/537.31"
- echo "${USER_AGENT}" > ${D_DIR}/user_agent_conf
- #We can replace below WINDOW_SIZE values from build configuration if available
- #echo "${WINDOW_SIZE}" > ${D_DIR}/window_size_conf
-}
-
-install_chromium_browser() {
- # Install browser files
- ${S}/depot_tools/ninja ${PARALLEL_MAKE} -C ${OUT_DIR} webos/install/default_browser
-
- D_DIR=${D}${BROWSER_APPLICATION_DIR}
- L_DIR=${D}${CBE_DATA_PATH}
- install -d ${D_DIR}
- install -d ${L_DIR}
-
- cp -R --no-dereference --preserve=mode,links -v ${OUT_DIR}/image/${BROWSER_APPLICATION_DIR}/* ${D_DIR}
-
- # AGL does not have PMLOG
- sed -i.bak s/PmLogCtl.*// ${D_DIR}/run_webbrowser
-
- # To execute chromium in JAILER, Security Part needs permissions change
- # run_webbrowser: Script file for launching chromium
- chmod -v 755 ${D_DIR}/chrome
- chmod -v 755 ${D_DIR}/kill_webbrowser
- chmod -v 755 ${D_DIR}/run_webbrowser
-
- configure_browser_settings
-}
-
-install_webruntime() {
-
- # # Generate install webos webview files
- # ${S}/depot_tools/ninja ${PARALLEL_MAKE} -C ${OUT_DIR} webos/install/weboswebruntime
-
- # # Move installation files to D directory
- # mv ${OUT_DIR}/image/* ${D}
- # # Rename include and locale directories
- # mv ${D}${includedir}/webruntime ${D}${includedir}/${BPN}
- # mv ${D}${CBE_DATA_PATH}/neva_locales ${D}${CBE_DATA_LOCALES_PATH}
-
- # # move this to separate mksnapshot-cross recipe once we figure out how to build just cross mksnapshot from chromium repository
- # install -d ${D}${bindir_cross}
- # gzip -c ${OUT_DIR}/${MKSNAPSHOT_PATH}mksnapshot > ${D}${bindir_cross}/${HOST_SYS}-mksnapshot.gz
-
- install -d ${D}${libdir}
- install -d ${D}${libdir}/swiftshader
- install -d ${D}${includedir}/${BPN}
- install -d ${D}${CBE_DATA_PATH}
- install -d ${D}${CBE_DATA_LOCALES_PATH}
-
- # Install webos webview files
- ${S}/depot_tools/ninja ${PARALLEL_MAKE} -C ${OUT_DIR} webos/install/weboswebruntime
-
- install -v -m 0644 ${OUT_DIR}/swiftshader/*.so ${D}${libdir}/swiftshader
-
- cp -R --no-dereference --preserve=mode,links -v ${OUT_DIR}/image/${includedir}/${BPN}/* ${D}${includedir}/${BPN}/
- install -v -m 0644 ${OUT_DIR}/image/${libdir}/*.so ${D}${libdir}
-
- install -v -m 0644 ${OUT_DIR}/image/${CBE_DATA_PATH}/icudtl.dat ${D}${CBE_DATA_PATH}
- install -v -m 0644 ${OUT_DIR}/image/${CBE_DATA_PATH}/snapshot_blob.bin ${D}${CBE_DATA_PATH}
- # app_runtime_content.pak, webos_content.pak, extensions_shell_and_test.pak
- install -v -m 0644 ${OUT_DIR}/image/${CBE_DATA_PATH}/*.pak ${D}${CBE_DATA_PATH}
-
- cp -R --no-dereference --preserve=mode,links -v ${OUT_DIR}/image/${CBE_DATA_LOCALES_PATH}/*.pak ${D}${CBE_DATA_LOCALES_PATH}
-
- chown root:root -R ${D}${libdir}
- chown root:root -R ${D}${includedir}
- chown root:root -R ${D}${CBE_DATA_LOCALES_PATH}
-
- # move this to separate mksnapshot-cross recipe once we figure out how to build just cross mksnapshot from chromium repository
- install -d ${D}${base_bindir}
- gzip -c ${OUT_DIR}/${MKSNAPSHOT_PATH}mksnapshot > ${D}${base_bindir}/${HOST_SYS}-mksnapshot.gz
-
-}
-
-do_install() {
- install_webruntime
- install_chromium_browser
-}
-
-WEBOS_SYSTEM_BUS_DIRS_LEGACY_BROWSER_APPLICATION = " \
- ${webos_sysbus_prvservicesdir}/${BROWSER_APPLICATION}.service \
- ${webos_sysbus_pubservicesdir}/${BROWSER_APPLICATION}.service \
- ${webos_sysbus_prvrolesdir}/${BROWSER_APPLICATION}.json \
- ${webos_sysbus_pubrolesdir}/${BROWSER_APPLICATION}.json \
-"
-
-SYSROOT_DIRS:append = " ${bindir_cross}"
-
-PACKAGES:prepend = " \
- ${PN}-cross-mksnapshot \
- ${BROWSER_APPLICATION} \
-"
-
-FILES:${BROWSER_APPLICATION} += " \
- ${BROWSER_APPLICATION_DIR} \
- ${WEBOS_SYSTEM_BUS_DIRS_LEGACY_BROWSER_APPLICATION} \
-"
-
-RDEPENDS:${BROWSER_APPLICATION} += "${PN}"
-
-VIRTUAL-RUNTIME_gpu-libs ?= ""
-RDEPENDS:${PN} += "${VIRTUAL-RUNTIME_gpu-libs}"
-
-# The text relocations are intentional -- see comments in [GF-52468]
-# TODO: check if we need INSANE_SKIP on ldflags
-INSANE_SKIP:${BROWSER_APPLICATION} += "libdir ldflags textrel"
-
-FILES:${PN} = " \
- ${libdir}/*.so \
- ${libdir}/swiftshader/*.so \
- ${CBE_DATA_PATH}/* \
- ${libdir}/${BPN}/*.so \
- ${WEBOS_SYSTEM_BUS_DIRS} \
-"
-
-FILES:${PN}-dev = " \
- ${includedir} \
-"
-
-FILES:${PN}-cross-mksnapshot = "${bindir_cross}/${HOST_SYS}-mksnapshot.gz"
diff --git a/recipes-wam/chromium/chromium84_git.bb b/recipes-wam/chromium/chromium84_git.bb
deleted file mode 100644
index 755c4ce92..000000000
--- a/recipes-wam/chromium/chromium84_git.bb
+++ /dev/null
@@ -1,81 +0,0 @@
-require chromium.inc
-
-SRC_URI = "\
- git://github.com/igalia/${PN};branch=koi;protocol=https;rev=${SRCREV_chromium84};name=chromium84 \
- git://github.com/webosose/chromium-v8;branch=@chromium84;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8 \
- file://add-a-delay-to-agl-ready-event.patch \
- file://chromium-quiche-invalid-offsetof.patch \
- file://chromium-skia-no_sanitize.patch \
-"
-
-# Needed by catapult
-DEPENDS += "libhomescreen python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
-
-SRCREV_chromium84 = "17ab9d58b9d5da9102b119d39cf49a002e61ea1b"
-SRCREV_v8 = "5c1d89dd2945a10cf7a6a3458050b3177a870b09"
-
-BROWSER_APPLICATION = "chromium84-browser"
-BROWSER_APPLICATION_DIR = "/opt/chromium84"
-MKSNAPSHOT_PATH = "v8_snapshot/"
-
-PACKAGECONFIG:remove="jumbo"
-
-GN_ARGS += "use_gtk=false"
-
-# Disable closure_compile
-# Else we need HOSTTOOLS += "java"
-GN_ARGS += "closure_compile=false"
-
-# When using meta-clang, one can switch to using the lld linker
-# by using the ld-is-lld distro feature otherwise use gold linker
-GN_ARGS += "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', 'use_lld=true use_gold=false', bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', 'use_lld=false use_gold=true', 'use_lld=false use_gold=false', d), d)}"
-
-# Toolchains we will use for the build. We need to point to the toolchain file
-# we've created, set the right target architecture and make sure we are not
-# using Chromium's toolchain (bundled clang, bundled binutils etc).
-GN_ARGS += "\
- host_toolchain=\"//build/toolchain/cros:host\" \
- cros_host_is_clang=false \
- use_custom_libcxx_for_host=false \
- cros_host_ar=\"${BUILD_AR}\" \
- cros_host_cc=\"${BUILD_CC} ${BUILD_CFLAGS}\" \
- cros_host_cxx=\"${BUILD_CXX} ${BUILD_CXXFLAGS}\" \
- cros_host_extra_ldflags=\"${BUILD_LDFLAGS}\" \
- custom_toolchain=\"//build/toolchain/cros:target\" \
- is_clang=false \
- use_custom_libcxx=false \
- target_cpu=\"${@gn_arch_name('${TUNE_ARCH}')}\" \
- cros_target_ar=\"${AR}\" \
- cros_target_cc=\"${CC}\" \
- cros_target_cxx=\"${CXX}\" \
- cros_target_extra_ldflags=\"${LDFLAGS}\" \
- v8_snapshot_toolchain=\"//build/toolchain/cros:v8_snapshot\" \
- cros_v8_snapshot_is_clang=false \
- cros_v8_snapshot_ar=\"${BUILD_AR}\" \
- cros_v8_snapshot_cc=\"${BUILD_CC}\" \
- cros_v8_snapshot_cxx=\"${BUILD_CXX}\" \
- linux_use_bundled_binutils=false \
- gold_path=\"\" \
- v8_enable_embedded_builtins=false \
- use_v8_context_snapshot=false \
-"
-
-GN_ARGS:append = " \
- use_system_minigbm=false \
- use_wayland_gbm=false \
-"
-
-GN_ARGS:append = " \
- is_webos=false \
- is_agl=true \
-"
-
-# TODO: drop this after we migrate to ubuntu 16.04 or above
-GN_ARGS += "\
- fatal_linker_warnings=false\
-"
-
-# TODO(rzanoni) copied from original recipe to fix qemux86 build.
-# check if it can be removed in the future.
-PACKAGECONFIG:remove:qemux86 = "gstreamer umediaserver neva-media gav neva-webrtc"
-#END TODO
diff --git a/recipes-wam/chromium/files/add-a-delay-to-agl-ready-event.patch b/recipes-wam/chromium/files/add-a-delay-to-agl-ready-event.patch
deleted file mode 100644
index 20caccbf6..000000000
--- a/recipes-wam/chromium/files/add-a-delay-to-agl-ready-event.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From d2d09d3e13a3874961971d343553106a1f3d5ac7 Mon Sep 17 00:00:00 2001
-From: Roger Zanoni <rzanoni@igalia.com>
-Date: Thu, 3 Jun 2021 10:53:40 +0200
-Subject: [PATCH] Add a delay to agl ready event
-
-Delay ready() to ensure that all the window and surfaces setup
-is done before notifying the compositor
----
- .../ozone/platform/wayland/host/wayland_window.cc | 14 +++++++++++++-
- .../ozone/platform/wayland/host/wayland_window.h | 5 +++++
- 2 files changed, 18 insertions(+), 1 deletion(-)
-
-diff --git a/src/ui/ozone/platform/wayland/host/wayland_window.cc b/src/ui/ozone/platform/wayland/host/wayland_window.cc
-index d2a9b0dae5..27749fd70d 100644
---- a/src/ui/ozone/platform/wayland/host/wayland_window.cc
-+++ b/src/ui/ozone/platform/wayland/host/wayland_window.cc
-@@ -299,7 +299,19 @@ WaylandWindow::SetAglReady(void)
- if (!connection_->agl_shell_manager) {
- return;
- }
-- connection_->agl_shell_manager->ready();
-+
-+ // Delay activation to ensure that all the setup is done
-+ // TODO(rzanoni): find a more deterministic way of doing this
-+ set_ready_timer_.Start(FROM_HERE,
-+ base::TimeDelta::FromMilliseconds(500),
-+ this,
-+ &WaylandWindow::SetReadyCallback);
-+}
-+
-+
-+void WaylandWindow::SetReadyCallback() {
-+ connection_->agl_shell_manager->ready();
-+ connection_->ScheduleFlush();
- }
-
- bool WaylandWindow::CanDispatchEvent(const PlatformEvent& event) {
-diff --git a/src/ui/ozone/platform/wayland/host/wayland_window.h b/src/ui/ozone/platform/wayland/host/wayland_window.h
-index 2acac98ae9..c10db38d21 100644
---- a/src/ui/ozone/platform/wayland/host/wayland_window.h
-+++ b/src/ui/ozone/platform/wayland/host/wayland_window.h
-@@ -15,6 +15,7 @@
- #include "base/containers/flat_set.h"
- #include "base/gtest_prod_util.h"
- #include "base/memory/ref_counted.h"
-+#include "base/timer/timer.h"
- #include "ui/events/platform/platform_event_dispatcher.h"
- #include "ui/gfx/geometry/rect.h"
- #include "ui/gfx/native_widget_types.h"
-@@ -232,6 +233,8 @@ class WaylandWindow : public PlatformWindow, public PlatformEventDispatcher {
- // Returns a root parent window.
- WaylandWindow* GetRootParentWindow();
-
-+ void SetReadyCallback();
-+
- // Install a surface listener and start getting wl_output enter/leave events.
- void AddSurfaceListener();
-
-@@ -311,6 +314,8 @@ class WaylandWindow : public PlatformWindow, public PlatformEventDispatcher {
- // The type of the current WaylandWindow object.
- ui::PlatformWindowType type_ = ui::PlatformWindowType::kWindow;
-
-+ base::OneShotTimer set_ready_timer_;
-+
- DISALLOW_COPY_AND_ASSIGN(WaylandWindow);
- };
-
---
-2.32.0
-
diff --git a/recipes-wam/chromium/files/chromium-quiche-invalid-offsetof.patch b/recipes-wam/chromium/files/chromium-quiche-invalid-offsetof.patch
deleted file mode 100644
index 4fdd98de4..000000000
--- a/recipes-wam/chromium/files/chromium-quiche-invalid-offsetof.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 4cea86e76af28b28aa72cb7c69ff7cf242b2bd5d Mon Sep 17 00:00:00 2001
-From: Stephan Hartmann <stha09@googlemail.com>
-Date: Sat, 27 Jun 2020 12:18:05 +0000
-Subject: [PATCH] GCC: supress invalid-offsetof warning
-
-GCC emits a warning if offsetof is used for non-POD
-types. However, GCC supports this and prints only
-the warning, because it might be nonportable code.
-Disable the warning for GCC with a pragma.
----
- src/net/third_party/quiche/src/quic/core/frames/quic_frame.h | 7 +++++++
- .../quiche/src/quic/core/frames/quic_inlined_frame.h | 7 +++++++
- 2 files changed, 14 insertions(+)
-
-diff --git a/src/net/third_party/quiche/src/quic/core/frames/quic_frame.h b/src/net/third_party/quiche/src/quic/core/frames/quic_frame.h
-index 756b69f..aceba76 100644
---- a/src/net/third_party/quiche/src/quic/core/frames/quic_frame.h
-+++ b/src/net/third_party/quiche/src/quic/core/frames/quic_frame.h
-@@ -110,8 +110,15 @@ struct QUIC_EXPORT_PRIVATE QuicFrame {
-
- static_assert(sizeof(QuicFrame) <= 24,
- "Frames larger than 24 bytes should be referenced by pointer.");
-+#if defined(__GNUC__)
-+#pragma GCC diagnostic push
-+#pragma GCC diagnostic ignored "-Winvalid-offsetof"
-+#endif
- static_assert(offsetof(QuicStreamFrame, type) == offsetof(QuicFrame, type),
- "Offset of |type| must match in QuicFrame and QuicStreamFrame");
-+#if defined(__GNUC__)
-+#pragma GCC diagnostic pop
-+#endif
-
- // A inline size of 1 is chosen to optimize the typical use case of
- // 1-stream-frame in QuicTransmissionInfo.retransmittable_frames.
-diff --git a/src/net/third_party/quiche/src/quic/core/frames/quic_inlined_frame.h b/src/net/third_party/quiche/src/quic/core/frames/quic_inlined_frame.h
-index 08c4869..804e4bb 100644
---- a/src/net/third_party/quiche/src/quic/core/frames/quic_inlined_frame.h
-+++ b/src/net/third_party/quiche/src/quic/core/frames/quic_inlined_frame.h
-@@ -17,8 +17,15 @@ namespace quic {
- template <typename DerivedT>
- struct QUIC_EXPORT_PRIVATE QuicInlinedFrame {
- QuicInlinedFrame(QuicFrameType type) : type(type) {
-+#if defined(__GNUC__)
-+#pragma GCC diagnostic push
-+#pragma GCC diagnostic ignored "-Winvalid-offsetof"
-+#endif
- static_assert(offsetof(DerivedT, type) == 0,
- "type must be the first field.");
-+#if defined(__GNUC__)
-+#pragma GCC diagnostic pop
-+#endif
- static_assert(sizeof(DerivedT) <= 24,
- "Frames larger than 24 bytes should not be inlined.");
- }
---
-2.26.2
-
diff --git a/recipes-wam/chromium/files/chromium-skia-no_sanitize.patch b/recipes-wam/chromium/files/chromium-skia-no_sanitize.patch
deleted file mode 100644
index abfba57ab..000000000
--- a/recipes-wam/chromium/files/chromium-skia-no_sanitize.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 04765936a0a8dd3ac3f530786fce6b5cea826d3e Mon Sep 17 00:00:00 2001
-From: Roger Zanoni <rzanoni@igalia.com>
-Date: Wed, 24 Feb 2021 13:50:27 +0100
-Subject: [PATCH] [skia][build] fix skia no_sanitize build issues for gcc
-
-Based on https://src.fedoraproject.org/rpms/chromium/blob/rawhide/f/chromium-skia-no_sanitize.patch
-
----
- .../skia/include/private/SkFloatingPoint.h | 24 +++++++++++++++++++
- 1 file changed, 24 insertions(+)
-
-diff --git a/src/third_party/skia/include/private/SkFloatingPoint.h b/src/third_party/skia/include/private/SkFloatingPoint.h
-index 110dda2ae4..8223e9b57d 100644
---- a/src/third_party/skia/include/private/SkFloatingPoint.h
-+++ b/src/third_party/skia/include/private/SkFloatingPoint.h
-@@ -159,7 +159,15 @@ static inline int64_t sk_float_saturate2int64(float x) {
- // Cast double to float, ignoring any warning about too-large finite values being cast to float.
- // Clang thinks this is undefined, but it's actually implementation defined to return either
- // the largest float or infinity (one of the two bracketing representable floats). Good enough!
-+#if defined(__GNUC__) && __GNUC__ >= 8
-+__attribute__((no_sanitize("float-cast-overflow")))
-+#else
-+# if defined(__GNUC__)
-+__attribute__((no_sanitize_undefined))
-+# else
- [[clang::no_sanitize("float-cast-overflow")]]
-+# endif
-+#endif
- static inline float sk_double_to_float(double x) {
- return static_cast<float>(x);
- }
-@@ -226,12 +234,28 @@ static inline float sk_float_rsqrt(float x) {
- // IEEE defines how float divide behaves for non-finite values and zero-denoms, but C does not
- // so we have a helper that suppresses the possible undefined-behavior warnings.
-
-+#if defined(__GNUC__) && __GNUC__ >= 8
-+__attribute__((no_sanitize("float-divide-by-zero")))
-+#else
-+# if defined(__GNUC__)
-+__attribute__((no_sanitize_undefined))
-+# else
- [[clang::no_sanitize("float-divide-by-zero")]]
-+# endif
-+#endif
- static inline float sk_ieee_float_divide(float numer, float denom) {
- return numer / denom;
- }
-
-+#if defined(__GNUC__) && __GNUC__ >= 8
-+__attribute__((no_sanitize("float-cast-overflow")))
-+#else
-+# if defined(__GNUC__)
-+__attribute__((no_sanitize_undefined))
-+# else
- [[clang::no_sanitize("float-divide-by-zero")]]
-+# endif
-+#endif
- static inline double sk_ieee_double_divide(double numer, double denom) {
- return numer / denom;
- }
---
-2.30.1
-
diff --git a/recipes-wam/chromium/gn-utils.inc b/recipes-wam/chromium/gn-utils.inc
deleted file mode 100644
index 156b56d2d..000000000
--- a/recipes-wam/chromium/gn-utils.inc
+++ /dev/null
@@ -1,32 +0,0 @@
-# Permission is hereby granted, free of charge, to any person obtaining a copy
-# of this software and associated documentation files (the "Software"), to deal
-# in the Software without restriction, including without limitation the rights
-# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-# copies of the Software, and to permit persons to whom the Software is
-# furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice shall be included in
-# all copies or substantial portions of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-# THE SOFTWARE.
-
-def gn_arch_name(yocto_arch):
- """Translates between Yocto's architecture values and the corresponding
- ones used by GN."""
- translation_table = {
- 'aarch64': 'arm64',
- 'arm': 'arm',
- 'i586': 'x86',
- 'i686': 'x86',
- 'x86_64': 'x64',
- }
- try:
- return translation_table[yocto_arch]
- except KeyError:
- bb.fatal('"%s" is not a supported architecture.' % yocto_arch)