summaryrefslogtreecommitdiffstats
path: root/recipes-wam/wam
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-wam/wam')
-rw-r--r--recipes-wam/wam/files/WebAppMgr@.service2
-rw-r--r--recipes-wam/wam/wam_git.bb14
2 files changed, 11 insertions, 5 deletions
diff --git a/recipes-wam/wam/files/WebAppMgr@.service b/recipes-wam/wam/files/WebAppMgr@.service
index a855bf9f..5dfed9c5 100644
--- a/recipes-wam/wam/files/WebAppMgr@.service
+++ b/recipes-wam/wam/files/WebAppMgr@.service
@@ -29,7 +29,7 @@ EnvironmentFile=-/etc/default/WebAppMgr.env
Environment=XDG_RUNTIME_DIR=/run/user/%i
Environment=DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/%i/bus
Environment=WAM_DATA_PATH="/home/%i/wamdata"
-ExecStart=/usr/bin/WebAppMgr --no-sandbox --in-process-gpu --remote-debugging-port=9998 --user-data-dir="/home/%i/wamdata" --webos-wam
+ExecStart=/usr/bin/WebAppMgr --no-sandbox --use-viz-fmp-with-timeout=0 --in-process-gpu --remote-debugging-port=9998 --user-data-dir="/home/%i/wamdata" --webos-wam
Restart=on-failure
RestartSec=50
diff --git a/recipes-wam/wam/wam_git.bb b/recipes-wam/wam/wam_git.bb
index d50a14fa..ab3a1ae0 100644
--- a/recipes-wam/wam/wam_git.bb
+++ b/recipes-wam/wam/wam_git.bb
@@ -5,27 +5,33 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7ca
inherit cmake
-DEPENDS = "glib-2.0 jsoncpp boost chromium68 wayland-ivi-extension libhomescreen"
+DEPENDS = "glib-2.0 jsoncpp boost chromium79 libhomescreen"
EXTRA_OECMAKE = "\
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=${prefix} \
-DPLATFORM_NAME=${@'${DISTRO}'.upper().replace('-', '_')} \
- -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium68"
+ -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium79"
PR="r0"
PROVIDES += "virtual/webruntime"
RPROVIDES_${PN} += "virtual/webruntime"
+# Disable some of securit_flags
+# Disable D_FORTIFY_SOURCE=2 and -fstack-protector-strong
+# Refer conf/distro/include/security_flags.inc in meta-webos/conf/distro/include/webos.inc
+lcl_maybe_fortify = ""
+SECURITY_STACK_PROTECTOR = ""
+
SRC_URI = "\
- git://github.com/igalia/${BPN}.git;branch=WIP@6.agl.compositor;protocol=https \
+ git://github.com/igalia/${BPN}.git;branch=@43.agl.jellyfish;protocol=https \
file://WebAppMgr@.service \
file://WebAppMgr.env \
file://trunc-webapp-roles.patch \
"
S = "${WORKDIR}/git"
-SRCREV = "bd650046b688eb1593ae68c16ba3912837507d08"
+SRCREV = "88e9df41cf6dfbcb5d2ea10c769a44e69171a1c3"
do_install_append() {
install -d ${D}${sysconfdir}/wam