summaryrefslogtreecommitdiffstats
path: root/recipes-wam
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-wam')
-rw-r--r--recipes-wam/chromium/chromium.inc5
-rw-r--r--recipes-wam/chromium/chromium_git.bb (renamed from recipes-wam/chromium/chromium84_git.bb)25
-rw-r--r--recipes-wam/wam/files/WebAppMgr.service2
-rw-r--r--recipes-wam/wam/wam_git.bb8
4 files changed, 24 insertions, 16 deletions
diff --git a/recipes-wam/chromium/chromium.inc b/recipes-wam/chromium/chromium.inc
index d45dfe79..0fc599bc 100644
--- a/recipes-wam/chromium/chromium.inc
+++ b/recipes-wam/chromium/chromium.inc
@@ -34,8 +34,8 @@ OUT_DIR = "${B}/${BUILD_TYPE}"
WEBRUNTIME_BUILD_TARGET = "webos:weboswebruntime"
BROWSER_APP_BUILD_TARGET = "chrome"
-BROWSER_APPLICATION = "chromium84-browser"
-BROWSER_APPLICATION_DIR = "/opt/chromium84"
+BROWSER_APPLICATION = "chromium-browser"
+BROWSER_APPLICATION_DIR = "/opt/chromium"
TARGET = "${WEBRUNTIME_BUILD_TARGET} ${BROWSER_APP_BUILD_TARGET}"
@@ -70,6 +70,7 @@ GN_ARGS = "\
proprietary_codecs=true\
target_os=\"linux\"\
treat_warnings_as_errors=false\
+ use_x11=false\
is_agl=true\
use_cbe=true\
is_chrome_cbe=true\
diff --git a/recipes-wam/chromium/chromium84_git.bb b/recipes-wam/chromium/chromium_git.bb
index aaff50bd..e58932c1 100644
--- a/recipes-wam/chromium/chromium84_git.bb
+++ b/recipes-wam/chromium/chromium_git.bb
@@ -1,25 +1,33 @@
require chromium.inc
SRC_URI = "\
- git://github.com/igalia/${PN};branch=marlin;protocol=https;rev=${SRCREV_chromium84};name=chromium84 \
- git://github.com/webosose/chromium-v8;branch=@chromium84;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8;protocol=https \
+ git://github.com/igalia/chromium87;branch=@10.agl.marlin;protocol=https;rev=${SRCREV_chromium87};name=chromium87 \
+ git://github.com/webosose/chromium-v8;branch=@chromium87;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8;protocol=https \
"
# Needed by catapult
DEPENDS += "python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
-SRCREV_chromium84 = "005a9257d3ba9eb363e19f5a8efc6758924dbf9b"
-SRCREV_v8 = "5c1d89dd2945a10cf7a6a3458050b3177a870b09"
+SRCREV_chromium87 = "7412ccde56b8054af89d6f515bc7c852287fc3b2"
+SRCREV_v8 = "935065d097cce0090bc858746e6aee0919b222de"
-BROWSER_APPLICATION = "chromium84-browser"
-BROWSER_APPLICATION_DIR = "/opt/chromium84"
+CHROMIUM_VERSION = "87.0.4280.88"
+PV_BRANCH_SUFFIX = "ose10.agl.marlin"
+
+PV = "${CHROMIUM_VERSION}.${PV_BRANCH_SUFFIX}+git"
+
+BROWSER_APPLICATION = "chromium-browser"
+BROWSER_APPLICATION_DIR = "/opt/chromium"
MKSNAPSHOT_PATH = "v8_snapshot/"
GN_ARGS += "use_gtk=false"
-# Disable closure_compile
+# Disable closure compile
# Else we need HOSTTOOLS += "java"
-GN_ARGS += "closure_compile=false"
+GN_ARGS += " \
+ enable_mojom_closure_compile=false\
+ enable_js_type_check=false\
+"
# When using meta-clang, one can switch to using the lld linker
# by using the ld-is-lld distro feature otherwise use gold linker
@@ -49,7 +57,6 @@ GN_ARGS += "\
cros_v8_snapshot_ar=\"${BUILD_AR}\" \
cros_v8_snapshot_cc=\"${BUILD_CC}\" \
cros_v8_snapshot_cxx=\"${BUILD_CXX}\" \
- linux_use_bundled_binutils=false \
gold_path=\"\" \
v8_enable_embedded_builtins=false \
use_v8_context_snapshot=false \
diff --git a/recipes-wam/wam/files/WebAppMgr.service b/recipes-wam/wam/files/WebAppMgr.service
index 5cb536d9..0fa7dbe5 100644
--- a/recipes-wam/wam/files/WebAppMgr.service
+++ b/recipes-wam/wam/files/WebAppMgr.service
@@ -21,7 +21,7 @@ Type=simple
UMask=0077
OOMScoreAdjust=-1000
EnvironmentFile=-/etc/default/WebAppMgr.env
-ExecStart=/usr/bin/WebAppMgr --enable-features=UseOzonePlatform --ozone-platform=wayland --no-sandbox --use-viz-fmp-with-timeout=0 --in-process-gpu --remote-debugging-port=9998 --user-data-dir="/home/%u/wamdata" --webos-wam
+ExecStart=/usr/bin/WebAppMgr --use-gl=egl --enable-features=UseOzonePlatform --ozone-platform=wayland --no-sandbox --use-viz-fmp-with-timeout=0 --in-process-gpu --remote-debugging-port=9998 --user-data-dir="/home/%u/wamdata" --webos-wam
Restart=on-failure
RestartSec=50
diff --git a/recipes-wam/wam/wam_git.bb b/recipes-wam/wam/wam_git.bb
index 18ace85e..81833bb3 100644
--- a/recipes-wam/wam/wam_git.bb
+++ b/recipes-wam/wam/wam_git.bb
@@ -5,13 +5,13 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7ca
inherit cmake
-DEPENDS = "glib-2.0 jsoncpp boost chromium84 protobuf protobuf-native"
+DEPENDS = "glib-2.0 jsoncpp boost chromium protobuf protobuf-native"
EXTRA_OECMAKE = "\
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=${prefix} \
-DPLATFORM_NAME=${@'${DISTRO}'.upper().replace('-', '_')} \
- -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium84"
+ -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium"
PR="r0"
@@ -25,12 +25,12 @@ lcl_maybe_fortify = ""
SECURITY_STACK_PROTECTOR = ""
SRC_URI = "\
- git://github.com/igalia/${BPN}.git;branch=marlin;protocol=https \
+ git://github.com/igalia/${BPN}.git;branch=@52.agl.marlin;protocol=https \
file://WebAppMgr.service \
file://WebAppMgr.env \
"
S = "${WORKDIR}/git"
-SRCREV = "478bc7b00d2704d74814c4685c60d62afca50872"
+SRCREV = "0a0e6c52fa2983f4703ef9fce68b01b631003043"
do_install:append() {
install -v -d ${D}${sysconfdir}/wam