summaryrefslogtreecommitdiffstats
path: root/recipes-extended/agl-qemu-runner/agl-qemu-runner.bb
blob: b3e3a67ddf88fad49cc1d52b6f1f6531ff2a33ce (plain)

@media only all and (prefers-color-scheme: dark) {
.highlight .hll { background-color: #49483e }
.highlight .c { color: #75715e } /* Comment */
.highlight .err { color: #960050; background-color: #1e0010 } /* Error */
.highlight .k { color: #66d9ef } /* Keyword */
.highlight .l { color: #ae81ff } /* Literal */
.highlight .n { color: #f8f8f2 } /* Name */
.highlight .o { color: #f92672 } /* Operator */
.highlight .p { color: #f8f8f2 } /* Punctuation */
.highlight .ch { color: #75715e } /* Comment.Hashbang */
.highlight .cm { color: #75715e } /* Comment.Multiline */
.highlight .cp { color: #75715e } /* Comment.Preproc */
.highlight .cpf { color: #75715e } /* Comment.PreprocFile */
.highlight .c1 { color: #75715e } /* Comment.Single */
.highlight .cs { color: #757
SUMMARY     = "AGL simple QEMU runner script"
LICENSE     = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"

inherit systemd allarch

SRC_URI = "file://agl-qemu-runner.sh \
           file://agl-qemu-runner@.service \
"

do_configure[noexec] = "1"
do_compile[noexec] = "1"

do_install() {
    # Install template unit
    install -d ${D}${systemd_system_unitdir}
    install -m 0644 ${WORKDIR}/agl-qemu-runner@.service ${D}${systemd_system_unitdir}/

    # Install script
    install -D -m 0755 ${WORKDIR}/agl-qemu-runner.sh ${D}${sbindir}/agl-qemu-runner.sh
}

FILES:${PN} += "${systemd_system_unitdir}"

RDEPENDS:${PN} += "bash qemu"