summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-10-03 23:14:57 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-11-01 20:10:23 +0000
commit8f4d303b74bb07d6787c5292e862588a2f6cb411 (patch)
tree357f711558952396f2f749e86c64cb1ccf53d436
parent7b6f9ba0aa18f264c3f231d55c575ff742679fab (diff)
Create AGL Instrument Cluster core package group
AGL Instrument Cluster has common api library and framework. This patch create package group for instrument cluster core packages. Bug-AGL: SPEC-4092 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Change-Id: Id9ec55dfc22cc7135f0973ef8a3421f8a614383d
-rw-r--r--meta-agl-lxc/recipes-platform/images/guest-image-minimal.bb4
-rw-r--r--meta-agl-lxc/recipes-platform/packagegroups/packagegroup-agl-ic-core.bb16
2 files changed, 20 insertions, 0 deletions
diff --git a/meta-agl-lxc/recipes-platform/images/guest-image-minimal.bb b/meta-agl-lxc/recipes-platform/images/guest-image-minimal.bb
index 82fcf4fe..6a47cfe5 100644
--- a/meta-agl-lxc/recipes-platform/images/guest-image-minimal.bb
+++ b/meta-agl-lxc/recipes-platform/images/guest-image-minimal.bb
@@ -5,3 +5,7 @@ require recipes-platform/images/agl-image-boot.inc
IMAGE_LINGUAS = " "
IMAGE_ROOTFS_EXTRA_SPACE:append = "${@bb.utils.contains("DISTRO_FEATURES", "systemd", " + 4096", "" ,d)}"
+
+IMAGE_INSTALL:append = " \
+ packagegroup-agl-ic-core \
+"
diff --git a/meta-agl-lxc/recipes-platform/packagegroups/packagegroup-agl-ic-core.bb b/meta-agl-lxc/recipes-platform/packagegroups/packagegroup-agl-ic-core.bb
new file mode 100644
index 00000000..316350f5
--- /dev/null
+++ b/meta-agl-lxc/recipes-platform/packagegroups/packagegroup-agl-ic-core.bb
@@ -0,0 +1,16 @@
+SUMMARY = "AGL Instrument Cluster Core Packages"
+DESCRIPTION = "This pacage group including AGL Instrument Cluster function core packages such as \
+ common library,framework."
+HOMEPAGE = "https://confluence.automotivelinux.org/display/IC"
+
+LICENSE = "Apache-2.0"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ic-core \
+"
+RDEPENDS:${PN} += "\
+ libclusteripc \
+ libclusterapi \
+"