summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-02-22 17:50:59 -0500
committerScott Murray <scott.murray@konsulko.com>2022-03-24 17:34:17 -0400
commit20d54af74a3a2053aaeb988ce4a35bac95aaa2c0 (patch)
tree50a8c2947b1a09c807e4e54ae0eb148edddb0fb2
parentcb091babab501993b44e91876b7ca4179c249ee3 (diff)
Declare layer compatibility with kirkstone
For tracking upstream, we need to update the layer compatibility. Bug-AGL: SPEC-3819 Change-Id: I23423baa371ed1b8b4a9024d9ac6f0c4d7e48185 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-drm-lease/conf/layer.conf2
-rw-r--r--meta-agl-flutter/conf/layer.conf2
-rw-r--r--meta-agl-jailhouse/conf/layer.conf4
-rw-r--r--meta-agl-lxc/conf/layer.conf2
-rw-r--r--meta-agl-ros2/conf/layer.conf2
-rw-r--r--meta-egvirt/conf/layer.conf2
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf2
-rw-r--r--templates/feature/agl-voiceagent-alexa-wakeword/amazonlite-2.3.patch2
-rw-r--r--templates/feature/agl-voiceagent-alexa/50_bblayers.conf.inc2
9 files changed, 10 insertions, 10 deletions
diff --git a/meta-agl-drm-lease/conf/layer.conf b/meta-agl-drm-lease/conf/layer.conf
index 36bfbd3b..b62098ff 100644
--- a/meta-agl-drm-lease/conf/layer.conf
+++ b/meta-agl-drm-lease/conf/layer.conf
@@ -20,4 +20,4 @@ BBFILES_DYNAMIC += " \
LAYERVERSION_agl-drm-lease = "1"
LAYERDEPENDS_agl-drm-lease = "core"
-LAYERSERIES_COMPAT_agl-drm-lease = "dunfell"
+LAYERSERIES_COMPAT_agl-drm-lease = "kirkstone"
diff --git a/meta-agl-flutter/conf/layer.conf b/meta-agl-flutter/conf/layer.conf
index f7c437d3..85cc3aa7 100644
--- a/meta-agl-flutter/conf/layer.conf
+++ b/meta-agl-flutter/conf/layer.conf
@@ -11,4 +11,4 @@ BBFILE_PRIORITY_meta-agl-flutter = "61"
LAYERVERSION_meta-agl-flutter = "1"
LAYERDEPENDS_meta-agl-flutter = "core meta-flutter"
-LAYERSERIES_COMPAT_meta-agl-flutter = "dunfell"
+LAYERSERIES_COMPAT_meta-agl-flutter = "kirkstone"
diff --git a/meta-agl-jailhouse/conf/layer.conf b/meta-agl-jailhouse/conf/layer.conf
index 2031e788..5dd68b2c 100644
--- a/meta-agl-jailhouse/conf/layer.conf
+++ b/meta-agl-jailhouse/conf/layer.conf
@@ -11,11 +11,11 @@ BBFILE_PRIORITY_agl-jailhouse = "61"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_agl-jailhouse = "1"
-LAYERSERIES_COMPAT_agl-jailhouse = "dunfell"
+LAYERSERIES_COMPAT_agl-jailhouse = "kirkstone"
# This is only needed for Raspberry Pi
# TODO: can this be expressed dynamically?
-LAYERDEPENDS_agl-jailhouse = "meta-arm"
+LAYERDEPENDS_agl-jailhouse = "meta-arm meta-arm-toolchain"
BBFILES_DYNAMIC += " \
raspberrypi:${LAYERDIR}/dynamic-layers/raspberrypi/*/*/*.bbappend \
diff --git a/meta-agl-lxc/conf/layer.conf b/meta-agl-lxc/conf/layer.conf
index 64db95a2..acf7dbbe 100644
--- a/meta-agl-lxc/conf/layer.conf
+++ b/meta-agl-lxc/conf/layer.conf
@@ -14,4 +14,4 @@ BBFILES_DYNAMIC += " \
rcar-gen3:${LAYERDIR}/dynamic-layers/meta-rcar-gen3/*/*/*.bbappend \
"
-LAYERSERIES_COMPAT_aglcontainermc = "dunfell"
+LAYERSERIES_COMPAT_aglcontainermc = "kirkstone"
diff --git a/meta-agl-ros2/conf/layer.conf b/meta-agl-ros2/conf/layer.conf
index 7134bc5e..c616d800 100644
--- a/meta-agl-ros2/conf/layer.conf
+++ b/meta-agl-ros2/conf/layer.conf
@@ -9,4 +9,4 @@ BBFILE_COLLECTIONS += "aglros2"
BBFILE_PATTERN_aglros2 = "^${LAYERDIR}/"
BBFILE_PRIORITY_aglros2 = "70"
-LAYERSERIES_COMPAT_aglros2 = "dunfell" \ No newline at end of file
+LAYERSERIES_COMPAT_aglros2 = "kirkstone" \ No newline at end of file
diff --git a/meta-egvirt/conf/layer.conf b/meta-egvirt/conf/layer.conf
index 5c4d8e67..e9b0181f 100644
--- a/meta-egvirt/conf/layer.conf
+++ b/meta-egvirt/conf/layer.conf
@@ -11,6 +11,6 @@ BBFILE_PRIORITY_egvirt = "6"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_egvirt = "1"
-LAYERSERIES_COMPAT_egvirt = "dunfell"
+LAYERSERIES_COMPAT_egvirt = "kirkstone"
LAYERDEPENDS_egvirt = "core"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf b/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf
index 811fd237..10c86f64 100644
--- a/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf
+++ b/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf
@@ -12,5 +12,5 @@ BBFILE_PRIORITY_agl-basesystem = "60"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_agl-basesystem = "1"
-LAYERSERIES_COMPAT_agl-basesystem = "dunfell"
+LAYERSERIES_COMPAT_agl-basesystem = "kirkstone"
LAYERDEPENDS_agl-basesystem = "core"
diff --git a/templates/feature/agl-voiceagent-alexa-wakeword/amazonlite-2.3.patch b/templates/feature/agl-voiceagent-alexa-wakeword/amazonlite-2.3.patch
index 0db3a0a5..ec9975fa 100644
--- a/templates/feature/agl-voiceagent-alexa-wakeword/amazonlite-2.3.patch
+++ b/templates/feature/agl-voiceagent-alexa-wakeword/amazonlite-2.3.patch
@@ -24,7 +24,7 @@
BBFILE_PATTERN_aac-amazonlite = "^${LAYERDIR}/"
BBFILE_PRIORITY_aac-amazonlite = "6"
-+LAYERSERIES_COMPAT_aac-amazonlite = "dunfell"
++LAYERSERIES_COMPAT_aac-amazonlite = "kirkstone"
+
AMAZONLITE ?= "ON"
AMAZONLITE_PACKAGES = "${LAYERDIR}/packages"
diff --git a/templates/feature/agl-voiceagent-alexa/50_bblayers.conf.inc b/templates/feature/agl-voiceagent-alexa/50_bblayers.conf.inc
index 088268ab..94d877ae 100644
--- a/templates/feature/agl-voiceagent-alexa/50_bblayers.conf.inc
+++ b/templates/feature/agl-voiceagent-alexa/50_bblayers.conf.inc
@@ -12,4 +12,4 @@ BBFILES += "${METADIR}/external/alexa-auto-sdk/extensions/experimental/system-au
# For now, tweak the layer's compatibility to allow using with zeus,
# since we know it works without major issues.
-LAYERSERIES_COMPAT_aac:append = " dunfell" \ No newline at end of file
+LAYERSERIES_COMPAT_aac:append = " kirkstone"