summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-06-24 16:51:08 -0400
committerScott Murray <scott.murray@konsulko.com>2024-06-24 16:58:07 -0400
commit97310e350b19bc5e8cc391aba8394912eea19b4f (patch)
tree2f8f6ab2994d2d7b92ff461a561b392c97a6f54e
parenta3086a6f01a30a7c66acc82bc2616476c52c92ad (diff)
meta-agl-flutter: rework agl-image-flutterricefish_17.92.0ricefish/17.92.017.92.0
Rework agl-image-flutter to serve more as an example of including a Flutter application into a production image, while also keeping it being somewhat of a bit of a build smoketest for meta-flutter integration. Changes: - Switch agl-image-flutter over to using the release version of the Flutter engine, and dropping the SDK, dev, and test packages. - Re-enable having the gallery application get auto-started. - Add a "-debug" version of the image that keeps most of the dev bits from the previous agl-image-flutter, and bakes in stuff like package management and debug tools. This keeps an example of how such an image can be built, and will still work in the standalone case when agl-devel is not used. Bug-AGL: SPEC-5182 Change-Id: I8e59fe71f8739ae67dd9f8c743a7024fd4f52b84 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-gallery_aglflutter.inc5
-rw-r--r--meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb29
-rw-r--r--meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb9
3 files changed, 31 insertions, 12 deletions
diff --git a/meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-gallery_aglflutter.inc b/meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-gallery_aglflutter.inc
index 61bcaa0e..68c07f18 100644
--- a/meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-gallery_aglflutter.inc
+++ b/meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-gallery_aglflutter.inc
@@ -8,11 +8,6 @@ do_install:append() {
install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
}
-#FILES:${PN} += "${systemd_system_unitdir}"
-
RDEPENDS:${PN} += "agl-flutter-env"
SYSTEMD_SERVICE:${PN} = "flutter-gallery.service"
-# Explicitly disable auto-start to avoid interferring with Toyota workspace
-# tooling usecase.
-SYSTEMD_AUTO_ENABLE:${PN} = "disable"
diff --git a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb
new file mode 100644
index 00000000..c9c1f298
--- /dev/null
+++ b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb
@@ -0,0 +1,29 @@
+require recipes-platform/images/agl-image-compositor.bb
+
+SUMMARY = "Example Flutter application debug image for development"
+LICENSE = "MIT"
+
+CLANGSDK = "1"
+
+# NOTES:
+# - the package-management IMAGE_FEATURE and packagegroup-agl-core-devel
+# are explicitly added here to cover the usecase of building without
+# passing agl-devel to aglsetup.sh. This is explicitly a debug image
+# where those are are always desired.
+# - Getting the debug version of the application requires changing
+# the value of FLUTTER_APP_RUNTIME_MODES to include "debug",
+# which is outside the scope of this image recipe.
+
+IMAGE_FEATURES += "ssh-server-openssh package-management dbg-pkgs"
+
+IMAGE_INSTALL += "\
+ packagegroup-agl-core-devel \
+ \
+ weston-ini-conf-landscape \
+ \
+ flutter-auto-verbose-logs \
+ \
+ flutter-engine-sdk-dev \
+ \
+ flutter-gallery \
+"
diff --git a/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb b/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb
index b42e2ade..0fdb7da0 100644
--- a/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb
+++ b/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb
@@ -1,6 +1,6 @@
require recipes-platform/images/agl-image-compositor.bb
-SUMMARY = "Baseline Flutter Image for Development"
+SUMMARY = "Example Flutter application image"
LICENSE = "MIT"
CLANGSDK = "1"
@@ -10,12 +10,7 @@ IMAGE_FEATURES += "ssh-server-openssh"
IMAGE_INSTALL += "\
weston-ini-conf-landscape \
\
- flutter-auto-verbose-logs \
- \
- flutter-engine-sdk-dev \
+ flutter-auto \
\
flutter-gallery \
- meta-flutter-tests-textures-test-egl \
- \
"
-