summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-06-24 16:51:08 -0400
committerScott Murray <scott.murray@konsulko.com>2024-06-24 16:58:07 -0400
commit97310e350b19bc5e8cc391aba8394912eea19b4f (patch)
tree2f8f6ab2994d2d7b92ff461a561b392c97a6f54e
parenta3086a6f01a30a7c66acc82bc2616476c52c92ad (diff)
meta-agl-flutter: rework agl-image-flutterricefish_17.92.0ricefish/17.92.017.92.0
Rework agl-image-flutter to serve more as an example of including a Flutter application into a production image, while also keeping it being somewhat of a bit of a build smoketest for meta-flutter integration. Changes: - Switch agl-image-flutter over to using the release version of the Flutter engine, and dropping the SDK, dev, and test packages. - Re-enable having the gallery application get auto-started. - Add a "-debug" version of the image that keeps most of the dev bits from the previous agl-image-flutter, and bakes in stuff like package management and debug tools. This keeps an example of how such an image can be built, and will still work in the standalone case when agl-devel is not used. Bug-AGL: SPEC-5182 Change-Id: I8e59fe71f8739ae67dd9f8c743a7024fd4f52b84 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-gallery_aglflutter.inc5
-rw-r--r--meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb29
-rw-r--r--meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb9
3 files changed, 31 insertions, 12 deletions
diff --git a/meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-gallery_aglflutter.inc b/meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-gallery_aglflutter.inc
index 61bcaa0e..68c07f18 100644
--- a/meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-gallery_aglflutter.inc
+++ b/meta-agl-flutter/dynamic-layers/flutter-apps-layer/recipes-graphics/flutter-apps/first-party/flutter-gallery_aglflutter.inc
@@ -8,11 +8,6 @@ do_install:append() {
install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
}
-#FILES:${PN} += "${systemd_system_unitdir}"
-
RDEPENDS:${PN} += "agl-flutter-env"
SYSTEMD_SERVICE:${PN} = "flutter-gallery.service"
-# Explicitly disable auto-start to avoid interferring with Toyota workspace
-# tooling usecase.
-SYSTEMD_AUTO_ENABLE:${PN} = "disable"
diff --git a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb
new file mode 100644
index 00000000..c9c1f298
--- /dev/null
+++ b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb
@@ -0,0 +1,29 @@
+require recipes-platform/images/agl-image-compositor.bb
+
+SUMMARY = "Example Flutter application debug image for development"
+LICENSE = "MIT"
+
+CLANGSDK = "1"
+
+# NOTES:
+# - the package-management IMAGE_FEATURE and packagegroup-agl-core-devel
+# are explicitly added here to cover the usecase of building without
+# passing agl-devel to aglsetup.sh. This is explicitly a debug image
+# where those are are always desired.
+# - Getting the debug version of the application requires changing
+# the value of FLUTTER_APP_RUNTIME_MODES to include "debug",
+# which is outside the scope of this image recipe.
+
+IMAGE_FEATURES += "ssh-server-openssh package-management dbg-pkgs"
+
+IMAGE_INSTALL += "\
+ packagegroup-agl-core-devel \
+ \
+ weston-ini-conf-landscape \
+ \
+ flutter-auto-verbose-logs \
+ \
+ flutter-engine-sdk-dev \
+ \
+ flutter-gallery \
+"
diff --git a/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb b/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb
index b42e2ade..0fdb7da0 100644
--- a/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb
+++ b/meta-agl-flutter/recipes-platform/images/agl-image-flutter.bb
@@ -1,6 +1,6 @@
require recipes-platform/images/agl-image-compositor.bb
-SUMMARY = "Baseline Flutter Image for Development"
+SUMMARY = "Example Flutter application image"
LICENSE = "MIT"
CLANGSDK = "1"
@@ -10,12 +10,7 @@ IMAGE_FEATURES += "ssh-server-openssh"
IMAGE_INSTALL += "\
weston-ini-conf-landscape \
\
- flutter-auto-verbose-logs \
- \
- flutter-engine-sdk-dev \
+ flutter-auto \
\
flutter-gallery \
- meta-flutter-tests-textures-test-egl \
- \
"
-
375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558 559 560 561 562 563 564 565 566 567 568 569 570 571 572 573 574 575 576 577 578 579 580 581 582 583 584 585 586