summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-11-26 22:21:18 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-11-26 22:21:18 +0100
commit73279d6fd1570ce556295ad9744b528056a1e5da (patch)
treed427401c05ea4ce2a3e01be1bfb7c640092fc1e3
parentfc66c9aa0ca099d91d6769b25a9af9d5d9a8a3e8 (diff)
Fix recipe not using AGL_APP_REVISION
Recipes need to use AGL_APP_REVISION (for apps) and AGL_DEFAULT_REVISION (for non-apps) respectively instead of plain AUTOREV. AGL_APP_REVISION / AGL_DEFAULT_REVISION will default to AUTOREV in normal operation until a release is cut in which case we will put in the tag. See conf/distro/poky-agl.conf Change-Id: Ib346e9c9bd118d245cccbec3c4bbd3c99e1ec457 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/4a-alsa-core/4a-alsa-core_git.bb4
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/4a-hal-community/4a-hal-community_git.bb7
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/4a-hal-reference/4a-hal-reference_git.bb4
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/4a-hal-unicens/4a-hal-unicens_git.bb4
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb4
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/agl-service-unicens/agl-service-unicens_git.bb4
6 files changed, 13 insertions, 14 deletions
diff --git a/meta-audio-4a-framework/recipes-multimedia/4a-alsa-core/4a-alsa-core_git.bb b/meta-audio-4a-framework/recipes-multimedia/4a-alsa-core/4a-alsa-core_git.bb
index 20d493cd..55eb6c11 100644
--- a/meta-audio-4a-framework/recipes-multimedia/4a-alsa-core/4a-alsa-core_git.bb
+++ b/meta-audio-4a-framework/recipes-multimedia/4a-alsa-core/4a-alsa-core_git.bb
@@ -7,9 +7,9 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/src/4a-alsa-core;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AUTOREV}"
+SRCREV = "${AGL_APP_REVISION}"
-PV = "0.1"
+PV = "0.1+git${SRCPV}"
S = "${WORKDIR}/git"
inherit afb-system-cmake
diff --git a/meta-audio-4a-framework/recipes-multimedia/4a-hal-community/4a-hal-community_git.bb b/meta-audio-4a-framework/recipes-multimedia/4a-hal-community/4a-hal-community_git.bb
index d39de517..80bd6be8 100644
--- a/meta-audio-4a-framework/recipes-multimedia/4a-hal-community/4a-hal-community_git.bb
+++ b/meta-audio-4a-framework/recipes-multimedia/4a-hal-community/4a-hal-community_git.bb
@@ -6,12 +6,11 @@ SECTION = "apps"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/src/4a-hal-community;protocol=https;branch=${AGL_BRANCH} \
- "
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/src/4a-hal-community;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AUTOREV}"
+SRCREV = "${AGL_APP_REVISION}"
-PV = "0.1"
+PV = "0.1+git${SRCPV}"
S = "${WORKDIR}/git"
inherit afb-system-cmake
diff --git a/meta-audio-4a-framework/recipes-multimedia/4a-hal-reference/4a-hal-reference_git.bb b/meta-audio-4a-framework/recipes-multimedia/4a-hal-reference/4a-hal-reference_git.bb
index d29343c3..7629b69d 100644
--- a/meta-audio-4a-framework/recipes-multimedia/4a-hal-reference/4a-hal-reference_git.bb
+++ b/meta-audio-4a-framework/recipes-multimedia/4a-hal-reference/4a-hal-reference_git.bb
@@ -8,9 +8,9 @@ LIC_FILES_CHKSUM = "file://Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/src/4a-hal-reference;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AUTOREV}"
+SRCREV = "${AGL_APP_REVISION}"
-PV = "0.1"
+PV = "0.1+git${SRCPV}"
S = "${WORKDIR}/git"
inherit afb-system-cmake
diff --git a/meta-audio-4a-framework/recipes-multimedia/4a-hal-unicens/4a-hal-unicens_git.bb b/meta-audio-4a-framework/recipes-multimedia/4a-hal-unicens/4a-hal-unicens_git.bb
index a013a3a4..e555f05a 100644
--- a/meta-audio-4a-framework/recipes-multimedia/4a-hal-unicens/4a-hal-unicens_git.bb
+++ b/meta-audio-4a-framework/recipes-multimedia/4a-hal-unicens/4a-hal-unicens_git.bb
@@ -7,9 +7,9 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/src/4a-hal-unicens;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AUTOREV}"
+SRCREV = "${AGL_APP_REVISION}"
-PV = "0.1"
+PV = "0.1+git${SRCPV}"
S = "${WORKDIR}/git"
inherit afb-system-cmake
diff --git a/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb b/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb
index 5165f949..a0bb6d90 100644
--- a/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb
+++ b/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb
@@ -7,9 +7,9 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-audio-4a;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AUTOREV}"
+SRCREV = "${AGL_APP_REVISION}"
-PV = "0.1"
+PV = "0.1+git${SRCPV}"
S = "${WORKDIR}/git"
inherit cmake aglwgt pkgconfig
diff --git a/meta-audio-4a-framework/recipes-multimedia/agl-service-unicens/agl-service-unicens_git.bb b/meta-audio-4a-framework/recipes-multimedia/agl-service-unicens/agl-service-unicens_git.bb
index 12de70bf..0e5029f4 100644
--- a/meta-audio-4a-framework/recipes-multimedia/agl-service-unicens/agl-service-unicens_git.bb
+++ b/meta-audio-4a-framework/recipes-multimedia/agl-service-unicens/agl-service-unicens_git.bb
@@ -7,9 +7,9 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-unicens;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AUTOREV}"
+SRCREV = "${AGL_APP_REVISION}"
-PV = "0.1"
+PV = "0.1+git${SRCPV}"
S = "${WORKDIR}/git"
inherit cmake aglwgt pkgconfig