summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-10-17 22:57:29 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-11-17 15:43:33 +0000
commit44d32c8910306ab189459339ba31c4b68aa2942e (patch)
tree87b27255e40eec5d23caaf9ad93a990928834a7b
parent7ff24f36c69161ec3fc488c7aa3b5396b158ef48 (diff)
Add momiscreen into ivi guest
The momiscreen is example home screen for IVI guest demo. This patch add momiscreen. Bug-AGL: SPEC-4101 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Change-Id: If3e926dc01cab7dfb9062f001a765a0fcab26a2a
-rw-r--r--meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager/agl.json52
-rw-r--r--meta-agl-lxc/recipes-demo/momiscreen/momiscreen/momiscreen7
-rw-r--r--meta-agl-lxc/recipes-demo/momiscreen/momiscreen/momiscreen.service12
-rw-r--r--meta-agl-lxc/recipes-demo/momiscreen/momiscreen_git.bb43
-rw-r--r--meta-agl-lxc/recipes-platform/images/guest-image-ivi-demo.bb1
5 files changed, 94 insertions, 21 deletions
diff --git a/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager/agl.json b/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager/agl.json
index 2abdf7b8..80028c50 100644
--- a/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager/agl.json
+++ b/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager/agl.json
@@ -1,26 +1,12 @@
{
"screen": [
{
- "name": "cluster-screen",
- "dispname": "HDMI-A-2"
- },
- {
"name": "ivi-screen",
"dispname": "HDMI-A-1"
}
],
"layer": [
{
- "name": "cluster-layer",
- "id": 1000,
- "width": 1920,
- "height": 720,
- "x": 0,
- "y": 0,
- "z": 10,
- "attach": "cluster-screen"
- },
- {
"name": "ivi-layer",
"id": 2000,
"width": 1920,
@@ -33,15 +19,15 @@
],
"surface": [
{
- "name": "cluster-app",
- "id": 10,
+ "name": "momiscreen",
+ "id": 2000,
"x": 0,
- "y": 0,
- "z": 100,
- "attach": "cluster-layer"
+ "y": 988,
+ "z": 10,
+ "attach": "ivi-layer"
},
{
- "name": "ivi-app",
+ "name": "mominavi",
"id": 2010,
"x": 0,
"y": 0,
@@ -49,11 +35,35 @@
"attach": "ivi-layer"
},
{
+ "name": "momiplay",
+ "id": 2011,
+ "x": 0,
+ "y": 0,
+ "z": 110,
+ "attach": "ivi-layer"
+ },
+ {
+ "name": "momiradio",
+ "id": 2012,
+ "x": 0,
+ "y": 0,
+ "z": 120,
+ "attach": "ivi-layer"
+ },
+ {
+ "name": "momisetting",
+ "id": 2013,
+ "x": 0,
+ "y": 0,
+ "z": 130,
+ "attach": "ivi-layer"
+ },
+ {
"name": "xdg-test",
"id": 9801,
"x": 0,
"y": 0,
- "z": 110,
+ "z": 300,
"attach": "ivi-layer"
}
]
diff --git a/meta-agl-lxc/recipes-demo/momiscreen/momiscreen/momiscreen b/meta-agl-lxc/recipes-demo/momiscreen/momiscreen/momiscreen
new file mode 100644
index 00000000..4af77b8c
--- /dev/null
+++ b/meta-agl-lxc/recipes-demo/momiscreen/momiscreen/momiscreen
@@ -0,0 +1,7 @@
+XDG_RUNTIME_DIR=/run/user/0
+QT_QPA_PLATFORM=wayland-egl
+QT_WAYLAND_DISABLE_WINDOWDECORATION=1
+QT_QPA_FONTDIR=/usr/share/fonts/truetype
+QT_IVI_SURFACE_ID=2000
+QT_WAYLAND_SHELL_INTEGRATION=ivi-shell
+HOME=/home/root
diff --git a/meta-agl-lxc/recipes-demo/momiscreen/momiscreen/momiscreen.service b/meta-agl-lxc/recipes-demo/momiscreen/momiscreen/momiscreen.service
new file mode 100644
index 00000000..a3f54e0c
--- /dev/null
+++ b/meta-agl-lxc/recipes-demo/momiscreen/momiscreen/momiscreen.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=momiscreen
+After=multi-user.target weston.service
+Requires=multi-user.target weston.service
+
+[Service]
+Type=simple
+EnvironmentFile=/etc/default/momiscreen
+ExecStart=/usr/bin/momiscreen
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-agl-lxc/recipes-demo/momiscreen/momiscreen_git.bb b/meta-agl-lxc/recipes-demo/momiscreen/momiscreen_git.bb
new file mode 100644
index 00000000..55253ffa
--- /dev/null
+++ b/meta-agl-lxc/recipes-demo/momiscreen/momiscreen_git.bb
@@ -0,0 +1,43 @@
+SUMMARY = "Momiyama home screen example"
+DESCRIPTION = "The momiscreen is a home screen example. \
+ The momiscreen is not require agl-appfw."
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
+
+DEPENDS = " \
+ qtbase \
+ qtquickcontrols2 \
+ qtgraphicaleffects \
+ qtsvg \
+ "
+
+PV = "0.2.0"
+
+SRC_URI = "git://github.com/AGLExport/momiscreen.git;protocol=https;branch=main \
+ file://momiscreen.service \
+ file://momiscreen \
+ "
+SRCREV = "bc3ef09ffad15b97941f28b165dc2019f5950105"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 systemd
+
+QT_INSTALL_PREFIX = "/usr"
+
+do_install_append() {
+ install -d ${D}/lib/systemd/system
+ install -m 0644 ${WORKDIR}/momiscreen.service ${D}/lib/systemd/system
+
+ install -m 0755 -d ${D}${sysconfdir}/default/
+ install -m 0755 ${WORKDIR}/momiscreen ${D}${sysconfdir}/default/
+}
+
+FILES:${PN} += " \
+ ${systemd_unitdir} \
+ ${sysconfdir}/*/* \
+ "
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE:${PN} = "momiscreen.service"
+
+RDEPENDS:${PN} = "qtsvg "
diff --git a/meta-agl-lxc/recipes-platform/images/guest-image-ivi-demo.bb b/meta-agl-lxc/recipes-platform/images/guest-image-ivi-demo.bb
index 4c9dd177..1086e17c 100644
--- a/meta-agl-lxc/recipes-platform/images/guest-image-ivi-demo.bb
+++ b/meta-agl-lxc/recipes-platform/images/guest-image-ivi-demo.bb
@@ -10,6 +10,7 @@ IMAGE_INSTALL += " \
ilm-manager \
mominavi \
momiplay \
+ momiscreen \
qtquickcontrols \
qtquickcontrols2 \
qtwayland \
id='n472' href='#n472'>472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558 559 560 561 562 563 564 565 566 567 568 569 570 571 572 573 574 575 576 577 578 579 580 581 582 583 584 585 586 587 588 589 590 591 592 593 594 595 596 597 598 599 600 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 641 642 643 644 645 646 647 648 649 650 651 652 653 654 655 656 657 658