aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2018-06-26 16:54:14 +0200
committerronan Le Martret <ronan.lemartret@iot.bzh>2018-06-27 08:59:47 +0000
commit2a3a88bca60cfe14ea258e16e92fa169d126e3ff (patch)
tree64ce6112d12fae0f3709ed6b17a23033d640445b
parent184f8b79f85fac04262e78fec8b160f8617fbd30 (diff)
Create a 4a-mixer recipes providing virttual/mixer
* mixer and 4a-mixer are two different package. mixer used qmake workflow to build and 4a-mixer cmake. Bug-AGL: SPEC-1520 Change-Id: I82b2c2a871f8bc0691291749e844f01fb9d5d7e9 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
-rw-r--r--meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc17
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/4a-mixer/4a-mixer_git.bb25
-rw-r--r--templates/feature/agl-audio-4a-framework/50_local.conf.inc17
3 files changed, 44 insertions, 15 deletions
diff --git a/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc b/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc
new file mode 100644
index 00000000..491f6d2a
--- /dev/null
+++ b/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc
@@ -0,0 +1,17 @@
+# In order to enable the audio-4a-framework features ,
+# enables the following line:
+#
+DISTRO_FEATURES_append = " agl-audio-4a-framework "
+
+# asound.conf is provided by the 4a-hal-config (and not by asound.state)
+#VIRTUAL-RUNTIME_alsa-state = "4a-hal-config"
+VIRTUAL_RUNTIME_alsa-state = ""
+# additionally there is a bug in alsa-utils-alsactl where it pulls in alsa-state directly
+RRECOMMENDS_pn-alsa-utils-alsactl = "VIRTUAL-RUNTIME_alsa-state"
+
+# why should a config package have -dev ... I'll leave that answer to you.
+PACKAGES_pn-alsa-state_remove = "alsa-state-dev"
+PACKAGES_pn-alsa-state_remove = "alsa-states-dev"
+PACKAGES_pn-alsa-state = "alsa-state alsa-states"
+
+PREFERRED_PROVIDER_virtual/mixer ?= "4a-mixer"
diff --git a/meta-audio-4a-framework/recipes-multimedia/4a-mixer/4a-mixer_git.bb b/meta-audio-4a-framework/recipes-multimedia/4a-mixer/4a-mixer_git.bb
new file mode 100644
index 00000000..c784ea6e
--- /dev/null
+++ b/meta-audio-4a-framework/recipes-multimedia/4a-mixer/4a-mixer_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Mixer for CES2017 AGL Demonstration"
+DESCRIPTION = "AGL HMI application for control of PulseAudio mixer elements"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mixer"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/mixer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 \
+ qtwebsockets \
+ pulseaudio \
+ virtual/libhomescreen \
+ qlibwindowmanager \
+"
+
+RPROVIDES_${PN} += "virtual/mixer"
+
+inherit cmake_qt5 aglwgt \ No newline at end of file
diff --git a/templates/feature/agl-audio-4a-framework/50_local.conf.inc b/templates/feature/agl-audio-4a-framework/50_local.conf.inc
index af1ea596..91d4c863 100644
--- a/templates/feature/agl-audio-4a-framework/50_local.conf.inc
+++ b/templates/feature/agl-audio-4a-framework/50_local.conf.inc
@@ -1,15 +1,2 @@
-# In order to enable the audio-4a-framework features ,
-# enables the following line:
-#
-DISTRO_FEATURES_append = " agl-audio-4a-framework "
-
-# asound.conf is provided by the 4a-hal-config (and not by asound.state)
-#VIRTUAL-RUNTIME_alsa-state = "4a-hal-config"
-VIRTUAL_RUNTIME_alsa-state = ""
-# additionally there is a bug in alsa-utils-alsactl where it pulls in alsa-state directly
-RRECOMMENDS_pn-alsa-utils-alsactl = "VIRTUAL-RUNTIME_alsa-state"
-
-# why should a config package have -dev ... I'll leave that answer to you.
-PACKAGES_pn-alsa-state_remove = "alsa-state-dev"
-PACKAGES_pn-alsa-state_remove = "alsa-states-dev"
-PACKAGES_pn-alsa-state = "alsa-state alsa-states"
+#see meta-agl-devel/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc
+require conf/include/agl-audio-4a-framework.inc