summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKazumasa Mitsunari <knimitz@witz-inc.co.jp>2017-10-23 13:09:08 +0900
committerKazumasa Mitsunari <knimitz@witz-inc.co.jp>2017-10-25 11:49:57 +0900
commit66f48eeddb11edffe9da053b8ebe215c121ac334 (patch)
tree33a4688a48e66ee08da491cc260d510ae1ad1da1
parent0dec413d25c38f94e03bd95c5ae8fe9441927fac (diff)
Split library from soundmanager
To improve independency, library from soundmanager service binder should be splitted [PatchSet2] Modify DESCRIPTION Move down S variable to SRC_URI Removed do_install_append : Related to https://gerrit.automotivelinux.org/gerrit/#/c/11529/ Change-Id: If379d0fbbf4e18390fd004e79b2c4f83fee50534 Signed-off-by: Kazumasa Mitsunari <knimitz@witz-inc.co.jp>
-rw-r--r--meta-hmi-framework/recipes-multimedia/agl-service-soundmanager-2017/agl-service-soundmanager-2017_git.bb29
1 files changed, 7 insertions, 22 deletions
diff --git a/meta-hmi-framework/recipes-multimedia/agl-service-soundmanager-2017/agl-service-soundmanager-2017_git.bb b/meta-hmi-framework/recipes-multimedia/agl-service-soundmanager-2017/agl-service-soundmanager-2017_git.bb
index 1cdc0af0..24e72005 100644
--- a/meta-hmi-framework/recipes-multimedia/agl-service-soundmanager-2017/agl-service-soundmanager-2017_git.bb
+++ b/meta-hmi-framework/recipes-multimedia/agl-service-soundmanager-2017/agl-service-soundmanager-2017_git.bb
@@ -1,11 +1,9 @@
-SUMMARY = "Sound Manager binding and client library for application"
-ESCRIPTION = "Sound Manager is the binding library to communicate \
- with Genivi Audio Manager. Genivi Audio Manager is the policy manager \
- about sound. It controls volume and routing according to various situations.\
- This recipe also provides client library to communicate with sound manager. \
- "
+SUMMARY = "Sound Manager binding"
+DESCRIPTION = "Sound Manager is the service binding to communicate \
+ with Genivi Audio Manager. Genivi Audio Manager is the policy manager \
+ for sound. It controls volume and routing according to various situations.\
+ "
HOMEPAGE = "https://wiki.automotivelinux.org/soundmanager"
-S = "${WORKDIR}/git"
SECTION = "multimedia"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
@@ -13,20 +11,7 @@ DEPENDS = "dbus glib-2.0 af-binder json-c"
RDEPENDS_${PN} = "audiomanager audiomanager-plugins"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-soundmanager-2017;protocol=https;branch=master"
-SRCREV = "2ad2d4f0879d091debf3853cfac0cd5129d5699a"
+SRCREV = "693a0cfd691d7089238407b9a418a02a77401221"
+S = "${WORKDIR}/git"
inherit cmake aglwgt
-
-do_install_append() {
- install -d ${D}${sysconfdir}/dbus-1/system.d
- install -m 0644 ${S}/conf/soundmanager-dbus.conf ${D}${sysconfdir}/dbus-1/system.d/
- install -d ${D}${libdir}/pkgconfig
- install -m 0644 ${B}/soundmanager.pc ${D}${libdir}/pkgconfig
- install -d ${D}${includedir}
- install -m 0644 ${S}/include/libsoundmanager.hpp ${D}${includedir}
-
- install -m -0755 ${B}/libsoundmanager/libsoundmanager.so ${D}${libdir}/libsoundmanager.so.0.1
- ln -sf libsoundmanager.so.0.1 ${D}${libdir}/libsoundmanager.so
-}
-
-FILES_${PN} += "${sysconfdir}/dbus-1/system.d/soundmanager-dbus.conf"