summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-11-21 16:22:02 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2017-11-21 16:22:02 +0100
commit7436db84e9fbd0404bf53a30cb4d7c7f1e273fc0 (patch)
tree0f5c866a7881935dbd657b805e2d735bc0d6afbd
parenta23e72fee795c4d09156368108df6a2feae53048 (diff)
agl-service-audio-4a: Update the fix for new AFM
The new version of the framework makes more use of system units. This patch has 2 effects: - it doesn't stop the system forever in case of error implying the lose of the awaited files - it accepts the service file to reside in either system or user scope Change-Id: I7bd8a38811a9f0dccddcf922a330ed15b652ccc3 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb b/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb
index 260c636d..457de1af 100644
--- a/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb
+++ b/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb
@@ -18,12 +18,15 @@ DEPENDS += "alsa-lib json-c systemd af-binder glib-2.0"
do_aglwgt_deploy_append() {
cat <<'EOF' >${D}/${sysconfdir}/agl-postinsts/99_4A_service_patch.sh
-svcfile=/usr/local/lib/systemd/user/afm-service-agl-service-audio-4a@1.0.service
+N=100
+svcfile="/usr/local/lib/systemd/*/afm-service-agl-service-audio-4a*.service"
set -x
echo "-- TMP 4A INSTALL FIX from meta-agl/meta-app-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb - MUST BE REMOVED !!!"
-while [ ! -f $svcfile ]; do
+while ! ls $svcfile > /dev/null; do
+ if [ $N = 0 ]; then echo "-- TMP 4A INSTALL NOT FIXED"; exit 0; fi
echo .
sleep 0.2
+ N=$(expr $N - 1)
done
sed -i -e 's|--verbose |--verbose --ldpath=/usr/libexec/agl/afb-aaaa/lib/:/usr/libexec/agl/4a-alsa-core/lib/ |' $svcfile
echo "-- TMP 4A INSTALL FIX END"