summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2018-06-13 11:28:36 +0200
committerStéphane Desneux <stephane.desneux@iot.bzh>2018-06-13 23:39:38 +0000
commit8c4c336c621a51524e60a49c6445b0333424e1e2 (patch)
tree48e2a3a5b2fc0460b22bf973e2220450814bc6b2
parente44d0a738c1f0b6eabc2bcf8a0a9fa373ddb9d8f (diff)
agl-audio-4a-framework: enable specific kernel config
4A requires some specific options in the linux kernel, like CONFIG_SND_ALOOP for softmixer. This patch adds config fragments to the default linux kernel recipe only when feature agl-audio-4a-framework is enabled. Change-Id: I443219998652562e9aed963d4e835aa4de60e614 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
-rw-r--r--meta-audio-4a-framework/recipes-kernel/linux/files/4a-sound.cfg1
-rw-r--r--meta-audio-4a-framework/recipes-kernel/linux/linux-%.bbappend21
2 files changed, 22 insertions, 0 deletions
diff --git a/meta-audio-4a-framework/recipes-kernel/linux/files/4a-sound.cfg b/meta-audio-4a-framework/recipes-kernel/linux/files/4a-sound.cfg
new file mode 100644
index 00000000..780e1ad5
--- /dev/null
+++ b/meta-audio-4a-framework/recipes-kernel/linux/files/4a-sound.cfg
@@ -0,0 +1 @@
+CONFIG_SND_ALOOP=y
diff --git a/meta-audio-4a-framework/recipes-kernel/linux/linux-%.bbappend b/meta-audio-4a-framework/recipes-kernel/linux/linux-%.bbappend
new file mode 100644
index 00000000..cc613708
--- /dev/null
+++ b/meta-audio-4a-framework/recipes-kernel/linux/linux-%.bbappend
@@ -0,0 +1,21 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+IS_KERNEL_RECIPE := "${@bb.data.inherits_class('kernel', d) and 'yes' or 'no'}"
+
+4A_KERNEL_SRC_URI_no = ""
+4A_KERNEL_SRC_URI_yes = ""
+
+4A_KERNEL_CONFIG_FRAGMENT_no = ""
+4A_KERNEL_CONFIG_FRAGMENT_yes = ""
+
+# ---------- 4a-sound.cfg ------------
+
+4A_KERNEL_SRC_URI_yes += "file://4a-sound.cfg"
+4A_KERNEL_CONFIG_FRAGMENT_yes += "${WORKDIR}/4a-sound.cfg"
+
+
+# append to SRC_URI and KERNEL_CONFIG_FRAGMENTS (see meta-agl/meta-agl-bsp/recipes-kernel/linux/linux-agl.inc)
+
+SRC_URI_append = " ${4A_KERNEL_SRC_URI_${IS_KERNEL_RECIPE}}"
+KERNEL_CONFIG_FRAGMENTS_append = " ${4A_KERNEL_CONFIG_FRAGMENT_${IS_KERNEL_RECIPE}}"
+