summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-02-08 14:22:58 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2018-02-08 14:22:58 +0000
commitb9a905bf1248e4d0f149af4c3b7114ad849e03ec (patch)
treec22da719066c0f6cba35db1da1ce0d40c50e5ee9
parentc3322a0ece606dd2a1ad264ef7ea0171b9d9e13d (diff)
parent8aad28035b318701059db8129947186210f25c97 (diff)
Merge "Add hmi-debug recipe"
-rw-r--r--meta-hmi-framework/recipes-demo-hmi/hmi-debug/files/hmi-debug8
-rw-r--r--meta-hmi-framework/recipes-demo-hmi/hmi-debug/hmi-debug_git.bb19
-rw-r--r--meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb1
3 files changed, 28 insertions, 0 deletions
diff --git a/meta-hmi-framework/recipes-demo-hmi/hmi-debug/files/hmi-debug b/meta-hmi-framework/recipes-demo-hmi/hmi-debug/files/hmi-debug
new file mode 100644
index 00000000..fee9573b
--- /dev/null
+++ b/meta-hmi-framework/recipes-demo-hmi/hmi-debug/files/hmi-debug
@@ -0,0 +1,8 @@
+#You can select log level of HMI framework
+#1 ERROR
+#2 WARNING
+#3 NOTICE
+#4 INFO
+#5 DEBUG
+#If you want to output debug log about hmi-framework, please uncomment the following.
+#USE_HMI_DEBUG=5
diff --git a/meta-hmi-framework/recipes-demo-hmi/hmi-debug/hmi-debug_git.bb b/meta-hmi-framework/recipes-demo-hmi/hmi-debug/hmi-debug_git.bb
new file mode 100644
index 00000000..27fb60d6
--- /dev/null
+++ b/meta-hmi-framework/recipes-demo-hmi/hmi-debug/hmi-debug_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Configurations for HMI framework"
+
+SECTION = "HMI"
+LICENSE = "Apache-2.0"
+
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = " \
+ file://hmi-debug \
+"
+
+FILES_${PN} = " \
+ ${sysconfdir}/afm/unit.env.d \
+"
+
+do_install() {
+ install -d ${D}${sysconfdir}/afm/unit.env.d
+ install -m 644 ${WORKDIR}/hmi-debug ${D}${sysconfdir}/afm/unit.env.d
+}
diff --git a/meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb b/meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
index d935e6c1..7f202351 100644
--- a/meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
+++ b/meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
@@ -13,4 +13,5 @@ RDEPENDS_${PN} += " \
qlibwindowmanager \
libhomescreen-2017 \
runxdg \
+ hmi-debug \
"