aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-07-13 11:46:51 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-07-13 11:46:51 +0200
commit63c6b83bc69eb8658aea8a200510ef8aadae1847 (patch)
tree0043ae6b7ed9b32dcab84648ab43d30194a78827
parentce8323a75aec9a3601284b83996895a4610344fa (diff)
Fix 4a-mixer parsing error on nogfx build variant
The nogfx build variant fails with 4a enabled ( https://gerrit.automotivelinux.org/gerrit/#/c/15051/ ) This is documented in SPEC-1588. To fix this we apply a conditional inclusion in meta-audio-4a-framework to only pull-in the mixer if we are including meta-agl-demo. Can be more fine-grained (profile-graphical-qt5 maybe) later. Bug-AGL: SPEC-1588 Fast inclusion requested as it is a blocker for RC2 due to enabling 4a in CI. Change-Id: I59b82748ba8e1736358318373d29f8f9fed2a5c5 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-audio-4a-framework/conf/layer.conf11
-rw-r--r--meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb (renamed from meta-audio-4a-framework/recipes-multimedia/4a-mixer/4a-mixer_git.bb)0
2 files changed, 11 insertions, 0 deletions
diff --git a/meta-audio-4a-framework/conf/layer.conf b/meta-audio-4a-framework/conf/layer.conf
index 1b2ee279..7c3237a7 100644
--- a/meta-audio-4a-framework/conf/layer.conf
+++ b/meta-audio-4a-framework/conf/layer.conf
@@ -1,6 +1,17 @@
# We have a conf and classes directory, add to BBPATH
BBPATH .= ":${LAYERDIR}"
+# Fix for SPEC-1588
+# Let us add layer-specific bbappends which are only applied when that
+# layer is included in our configuration -
+# e.g. only add layers if a bsp is present.
+# This is based on the BBFILE_COLLECTIONS name of the layer.
+BBFILES += "${@' '.join('${LAYERDIR}/meta-%s/recipes*/*/*.bbappend' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+BBFILES += "${@' '.join('${LAYERDIR}/meta-%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+
+
# We have recipes-* directories, add to BBFILES
BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
${LAYERDIR}/recipes-*/*/*.bbappend"
diff --git a/meta-audio-4a-framework/recipes-multimedia/4a-mixer/4a-mixer_git.bb b/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb
index c784ea6e..c784ea6e 100644
--- a/meta-audio-4a-framework/recipes-multimedia/4a-mixer/4a-mixer_git.bb
+++ b/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb