aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-07-27 12:02:48 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2018-07-27 12:02:48 +0000
commitd7796f220dd23780a78a73814329efbf23bcdef1 (patch)
tree5e91c31ff15805ea05697fa171b300523bcce5e6
parent0bbe245a64a61af0ae5bb82e8bb131f4f3db9734 (diff)
parent3200cbfaccec7767aa61167e56a687544f922296 (diff)
Merge changes from topic 'SPEC-1601'
* changes: 4a-mixer: remove useless dependency on pulseaudio Fix yocto virtual recipes parsing
-rw-r--r--meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc1
-rw-r--r--meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb2
2 files changed, 2 insertions, 1 deletions
diff --git a/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc b/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc
index 935b9ad1..12711f66 100644
--- a/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc
+++ b/meta-audio-4a-framework/conf/include/agl-audio-4a-framework.inc
@@ -14,6 +14,7 @@ PACKAGES_pn-alsa-state_remove = "alsa-state-dev"
PACKAGES_pn-alsa-state_remove = "alsa-states-dev"
PACKAGES_pn-alsa-state = "alsa-state alsa-states"
+PREFERRED_PROVIDER_virtual/mixer ?= "4a-mixer"
PREFERRED_RPROVIDER_virtual/mixer ?= "4a-mixer"
PREFERRED_VERSION_alsa-lib = "1.1.6"
diff --git a/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb b/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb
index 93fd1b70..f5192ae3 100644
--- a/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb
+++ b/meta-audio-4a-framework/meta-agl-demo/recipes-multimedia/4a-mixer/4a-mixer_git.bb
@@ -15,11 +15,11 @@ S = "${WORKDIR}/git"
# build-time dependencies
DEPENDS += "qtquickcontrols2 \
qtwebsockets \
- pulseaudio \
virtual/libhomescreen \
qlibwindowmanager \
"
+PROVIDES += "virtual/mixer"
RPROVIDES_${PN} += "virtual/mixer"
inherit cmake_qt5 aglwgt