summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2018-06-28 17:42:43 +0900
committerZheng Wenlong <wenlong_zheng@nexty-ele.com>2018-07-03 11:00:15 +0000
commit35327849b830f6b6328aa75119dd8f6e08fcc100 (patch)
tree20db6f87331ed757deb22286803d0a02fa5858c8
parent3c7785ecb9f69c62bad390e0395d122cf825a819 (diff)
Add launcher recipes and add into packagegroup
Add launcher recipes and add into packagegroupi. Change-Id: I18b47cbd0076434a97f2aad70b062f2702ba0e5a Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
-rw-r--r--meta-hmi-framework/recipes-demo-hmi/launcher/launcher_git.bb25
-rw-r--r--meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb1
2 files changed, 26 insertions, 0 deletions
diff --git a/meta-hmi-framework/recipes-demo-hmi/launcher/launcher_git.bb b/meta-hmi-framework/recipes-demo-hmi/launcher/launcher_git.bb
new file mode 100644
index 00000000..9d78ff1a
--- /dev/null
+++ b/meta-hmi-framework/recipes-demo-hmi/launcher/launcher_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL Launcher Application"
+DESCRIPTION = "AGL Launcher Application build with recipe method"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/launcher"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://launcher/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "\
+ qtbase \
+ qtdeclarative \
+ qtquickcontrols2 \
+ qtwebsockets \
+ qlibwindowmanager \
+ qlibhomescreen \
+"
+
+inherit qmake5 systemd pkgconfig aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
diff --git a/meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb b/meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
index 61af066d..516e5230 100644
--- a/meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
+++ b/meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
@@ -15,4 +15,5 @@ RDEPENDS_${PN} += " \
qlibhomescreen \
runxdg \
hmi-debug \
+ launcher \
"