aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Farrugia <mark.farrugia@fiberdyne.com.au>2019-04-08 12:16:59 +1000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-05-01 11:50:52 +0000
commit80a24bc69093d3fc5fa2d57242014fbc21307b24 (patch)
treeaaed381a1f4314b8ae5ac9129f67670ee2c14462
parent0bfe1a36c4bcc9c4d309f9005b2d8da23ca0eed8 (diff)
Update avirt kernel module and libavirt userspace library
Update the avirt core kernel module and the accompanying libavirt userspace library to the latest releases. The key new feature is a completed and finalized audio path routing system, enabling audio routing at the kernel level. Change-Id: I69eaa578390f4ba67ad71506c359276bee252b19 Signed-off-by: Mark Farrugia <mark.farrugia@fiberdyne.com.au>
-rw-r--r--meta-audio-4a-framework/recipes-kernel/snd-avirt/files/0001-snd-avirt-backport-kernel-4.12-api.patch50
-rw-r--r--meta-audio-4a-framework/recipes-kernel/snd-avirt/snd-avirt.bb2
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/4a-softmixer/4a-softmixer_git.bb2
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/libavirt/libavirt_git.bb2
4 files changed, 32 insertions, 24 deletions
diff --git a/meta-audio-4a-framework/recipes-kernel/snd-avirt/files/0001-snd-avirt-backport-kernel-4.12-api.patch b/meta-audio-4a-framework/recipes-kernel/snd-avirt/files/0001-snd-avirt-backport-kernel-4.12-api.patch
index 689d64f4..fa737cb4 100644
--- a/meta-audio-4a-framework/recipes-kernel/snd-avirt/files/0001-snd-avirt-backport-kernel-4.12-api.patch
+++ b/meta-audio-4a-framework/recipes-kernel/snd-avirt/files/0001-snd-avirt-backport-kernel-4.12-api.patch
@@ -1,32 +1,40 @@
-From ea9a8ede7f343d589c8d9fac945f7b3d9dca9c3f Mon Sep 17 00:00:00 2001
+From 2fc07fedd17650f64f9bfcdb8682b55dad75cccd Mon Sep 17 00:00:00 2001
From: Mark Farrugia <mark.farrugia@fiberdyne.com.au>
-Date: Thu, 15 Nov 2018 09:47:29 +1100
-Subject: [PATCH] snd-avirt-backport-Kernel-API
+Date: Mon, 8 Apr 2019 16:38:13 +1000
+Subject: [PATCH] 0001-snd-avirt-backport-kernel-4.12-api
-Backport snd-pcm-ops struct callbacks for kernels prior to
-4.13
-
-Signed-off-by: Mark Farrugia <mark.farrugia@fiberdyne.com.au>
---
- core.c | 5 ++---
- 1 file changed, 2 insertions(+), 3 deletions(-)
+ core.c | 9 ++++-----
+ 1 file changed, 4 insertions(+), 5 deletions(-)
diff --git a/core.c b/core.c
-index 35998c0..6fd3ab3 100644
+index c2e32c5..2bb6616 100644
--- a/core.c
+++ b/core.c
-@@ -250,9 +250,8 @@ static struct snd_pcm *pcm_create(struct snd_avirt_stream *stream)
- PCM_OPS_SET(pcm_ops_ap, &pcm_ops, trigger);
- PCM_OPS_SET(pcm_ops_ap, &pcm_ops, pointer);
- PCM_OPS_SET(pcm_ops_ap, &pcm_ops, get_time_info);
-- PCM_OPS_SET(pcm_ops_ap, &pcm_ops, fill_silence);
-- PCM_OPS_SET(pcm_ops_ap, &pcm_ops, copy_user);
-- PCM_OPS_SET(pcm_ops_ap, &pcm_ops, copy_kernel);
-+ PCM_OPS_SET(pcm_ops_ap, &pcm_ops, silence);
-+ PCM_OPS_SET(pcm_ops_ap, &pcm_ops, copy);
- PCM_OPS_SET(pcm_ops_ap, &pcm_ops, mmap);
- PCM_OPS_SET(pcm_ops_ap, &pcm_ops, ack);
+@@ -219,9 +219,8 @@ int snd_avirt_stream_try_complete(struct snd_avirt_stream *stream)
+ /* Set PCM ops for the Audio Path*/
+ PCM_OPS_SET(pcm_ops_ap, &stream->pcm_ops, pointer);
+ PCM_OPS_SET(pcm_ops_ap, &stream->pcm_ops, get_time_info);
+- PCM_OPS_SET(pcm_ops_ap, &stream->pcm_ops, fill_silence);
+- PCM_OPS_SET(pcm_ops_ap, &stream->pcm_ops, copy_user);
+- PCM_OPS_SET(pcm_ops_ap, &stream->pcm_ops, copy_kernel);
++ PCM_OPS_SET(pcm_ops_ap, &stream->pcm_ops, silence);
++ PCM_OPS_SET(pcm_ops_ap, &stream->pcm_ops, copy);
+ PCM_OPS_SET(pcm_ops_ap, &stream->pcm_ops, mmap);
+ PCM_OPS_SET(pcm_ops_ap, &stream->pcm_ops, ack);
+
+@@ -331,9 +330,9 @@ snd_avirt_route_endpoint_copy(struct snd_pcm_substream *substream,
+
+ switch (endpoint) {
+ case SND_AVIRT_ROUTE_SOURCE:
+- return endpoint_ap->pcm_capture_ops->copy_kernel;
++ return endpoint_ap->pcm_capture_ops->copy;
+ case SND_AVIRT_ROUTE_SINK:
+- return endpoint_ap->pcm_playback_ops->copy_kernel;
++ return endpoint_ap->pcm_playback_ops->copy;
+ }
+ return NULL;
--
2.17.1
diff --git a/meta-audio-4a-framework/recipes-kernel/snd-avirt/snd-avirt.bb b/meta-audio-4a-framework/recipes-kernel/snd-avirt/snd-avirt.bb
index c5727344..ebf6fb36 100644
--- a/meta-audio-4a-framework/recipes-kernel/snd-avirt/snd-avirt.bb
+++ b/meta-audio-4a-framework/recipes-kernel/snd-avirt/snd-avirt.bb
@@ -9,6 +9,6 @@ PV = "0.1"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/avirt;protocol=https;branch=${AGL_BRANCH}"
S = "${WORKDIR}/git"
-SRCREV = "42000f29ef6775f092dab2c80f8b3a6a319b5658"
+SRCREV = "7eb743b7bdebaa1d3e3ae3be986034ea30c5cf76"
KERNEL_MODULE_AUTOLOAD += "snd-avirt-core snd-avirt-ap-loopback"
diff --git a/meta-audio-4a-framework/recipes-multimedia/4a-softmixer/4a-softmixer_git.bb b/meta-audio-4a-framework/recipes-multimedia/4a-softmixer/4a-softmixer_git.bb
index 1ae24d2d..75f725e6 100644
--- a/meta-audio-4a-framework/recipes-multimedia/4a-softmixer/4a-softmixer_git.bb
+++ b/meta-audio-4a-framework/recipes-multimedia/4a-softmixer/4a-softmixer_git.bb
@@ -7,7 +7,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/src/4a-softmixer.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "17ad00443eecdb2ed7b92da01c7be6f316e04b64"
+SRCREV = "6c627f8650b88b19704dd4e513fe7fff701c00c1"
DEPENDS += "lua liburcu"
diff --git a/meta-audio-4a-framework/recipes-multimedia/libavirt/libavirt_git.bb b/meta-audio-4a-framework/recipes-multimedia/libavirt/libavirt_git.bb
index 19b3bdee..6d224e4e 100644
--- a/meta-audio-4a-framework/recipes-multimedia/libavirt/libavirt_git.bb
+++ b/meta-audio-4a-framework/recipes-multimedia/libavirt/libavirt_git.bb
@@ -7,7 +7,7 @@ LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libavirt;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "3205195333eb1435bdef8257e0d122c25d0b7e6f"
+SRCREV = "379ea3c132f53eb6f5cf26d1c8a5ca335eb32a2e"
PV = "0.1+git${SRCPV}"
S = "${WORKDIR}/git"