aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntia Puentes <apuentes@igalia.com>2019-09-19 18:16:13 +0200
committerAntia Puentes <apuentes@igalia.com>2019-09-20 10:55:48 +0000
commit88e8728b22e50ae9ae47d0df496720bd6cf73af1 (patch)
tree95b5f78225b9532ebcbbd89160aa9947485a57c7
parent941df29b9a69a1ea40332dbf0d6b26b38dc340d7 (diff)
wam: auto-enable remote debug when agl-devel is on
Apart from preventing remote debugging when agl-devel is not set, which was tackled in SPEC-2327, we are interested in having remote debugging available by default when agl-devel is set. WAM checks if files: * /var/agl-devel/preferences/devmode_enabled * /var/agl-devel/preferences/debug_system_apps exist to enable the dev mode and the remote web inspector, so we create those files by default when agl-devel is set. Bug-AGL: SPEC-2782 Change-Id: I557a633802e6baa15339708b00719d66adbcf1ac Signed-off-by: Antia Puentes <apuentes@igalia.com>
-rw-r--r--meta-html5-framework/recipes-wam/wam/wam_git.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-html5-framework/recipes-wam/wam/wam_git.bb b/meta-html5-framework/recipes-wam/wam/wam_git.bb
index a4012faa..16737cab 100644
--- a/meta-html5-framework/recipes-wam/wam/wam_git.bb
+++ b/meta-html5-framework/recipes-wam/wam/wam_git.bb
@@ -42,3 +42,10 @@ RDEPENDS_${PN} += "wam-tinyproxy"
FILES_${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so ${systemd_system_unitdir}"
CXXFLAGS_append_agl-devel = " -DAGL_DEVEL"
+
+do_install_append_agl-devel() {
+ # Enable remote inspector and dev mode
+ install -d ${D}${localstatedir}/agl-devel/preferences
+ touch ${D}${localstatedir}/agl-devel/preferences/debug_system_apps
+ touch ${D}${localstatedir}/agl-devel/preferences/devmode_enabled
+} \ No newline at end of file