summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2019-06-26 18:01:30 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-27 13:29:30 +0000
commit0f01dcc26aa0b9eecb8c04fbce42999beecde302 (patch)
tree4f30f63100e8a55da61cbccb877c36cecb2aa460
parentf048f1929149d6ae99f532031e09af67f6f49ac7 (diff)
pipewire: install environment variable files
DISABLE_RTKIT saves us from nasty error messages about not being able to connect to dbus. This doesn't make sense anyway, real-time mode should not be enabled on embedded. PIPEWIRE_DEBUG/G_MESSAGES_DEBUG are put there in comments so that people can easily uncomment to figure out what is wrong with their pipewire setup. Bug-AGL: SPEC-2473 Change-Id: Id07d3d21f472885434158c300a227d53020c2189 Signed-off-by: George Kiagiadakis <george.kiagiadakis@collabora.com>
-rw-r--r--meta-pipewire/recipes-multimedia/pipewire/pipewire-conf-agl/client.env10
-rw-r--r--meta-pipewire/recipes-multimedia/pipewire/pipewire-conf-agl/server.env12
-rw-r--r--meta-pipewire/recipes-multimedia/pipewire/pipewire-conf-agl_git.bb13
-rw-r--r--meta-pipewire/recipes-multimedia/pipewire/pipewire/pipewire@.service1
4 files changed, 34 insertions, 2 deletions
diff --git a/meta-pipewire/recipes-multimedia/pipewire/pipewire-conf-agl/client.env b/meta-pipewire/recipes-multimedia/pipewire/pipewire-conf-agl/client.env
new file mode 100644
index 00000000..9b44cee0
--- /dev/null
+++ b/meta-pipewire/recipes-multimedia/pipewire/pipewire-conf-agl/client.env
@@ -0,0 +1,10 @@
+# This file contains environment variables that will apply
+# to pipewire clients started by the application framework
+
+# libpipewire by default tries to obtain real-time scheduling
+# for the streaming thread. This is only useful on the desktop, disable here.
+DISABLE_RTKIT=1
+
+# Uncomment to enable libpipewire debug for clients
+# 1=error, 2=warning, 3=info, 4=debug, 5=trace
+#PIPEWIRE_DEBUG=4
diff --git a/meta-pipewire/recipes-multimedia/pipewire/pipewire-conf-agl/server.env b/meta-pipewire/recipes-multimedia/pipewire/pipewire-conf-agl/server.env
new file mode 100644
index 00000000..c74b941d
--- /dev/null
+++ b/meta-pipewire/recipes-multimedia/pipewire/pipewire-conf-agl/server.env
@@ -0,0 +1,12 @@
+# This file contains environment variables that will apply
+# to the pipewire daemon as well as its session manager
+
+# Disable rtkit for wireplumber, which is also a client
+DISABLE_RTKIT=1
+
+# Uncomment to enable wireplumber debug
+#G_MESSAGES_DEBUG=all
+
+# Uncomment to enable pipewire debug
+# 1=error, 2=warning, 3=info, 4=debug, 5=trace
+#PIPEWIRE_DEBUG=4
diff --git a/meta-pipewire/recipes-multimedia/pipewire/pipewire-conf-agl_git.bb b/meta-pipewire/recipes-multimedia/pipewire/pipewire-conf-agl_git.bb
index 4c0b6609..2bb76f9d 100644
--- a/meta-pipewire/recipes-multimedia/pipewire/pipewire-conf-agl_git.bb
+++ b/meta-pipewire/recipes-multimedia/pipewire/pipewire-conf-agl_git.bb
@@ -9,6 +9,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
SRC_URI = " \
file://pipewire.conf \
+ file://client.env \
+ file://server.env \
"
do_configure[noexec] = "1"
@@ -19,13 +21,20 @@ do_install_append() {
# replace the one installed by pipewire
install -d ${D}/${sysconfdir}/pipewire/
install -m 0644 ${WORKDIR}/pipewire.conf ${D}${sysconfdir}/pipewire/pipewire.conf
+
+ # install environment variable files
+ install -d ${D}/${sysconfdir}/afm/unit.env.d/
+ install -m 0644 ${WORKDIR}/client.env ${D}/${sysconfdir}/afm/unit.env.d/pipewire
+ install -m 0644 ${WORKDIR}/server.env ${D}${sysconfdir}/pipewire/environment
}
FILES_${PN} = "\
- ${sysconfdir}/pipewire/pipewire.conf \
+ ${sysconfdir}/pipewire/* \
+ ${sysconfdir}/afm/unit.env.d/* \
"
CONFFILES_${PN} += "\
- ${sysconfdir}/pipewire/pipewire.conf \
+ ${sysconfdir}/pipewire/* \
+ ${sysconfdir}/afm/unit.env.d/* \
"
RPROVIDES_${PN} += "virtual/pipewire-config"
diff --git a/meta-pipewire/recipes-multimedia/pipewire/pipewire/pipewire@.service b/meta-pipewire/recipes-multimedia/pipewire/pipewire/pipewire@.service
index a603fdb3..e116dc1f 100644
--- a/meta-pipewire/recipes-multimedia/pipewire/pipewire/pipewire@.service
+++ b/meta-pipewire/recipes-multimedia/pipewire/pipewire/pipewire@.service
@@ -12,6 +12,7 @@ ExecStart=/usr/bin/pipewire
Environment=XDG_RUNTIME_DIR=/run/user/%i
Environment=DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/%i/bus
+EnvironmentFile=-/etc/pipewire/environment
User=%i
Slice=user-%i.slice