summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacobo Aragunde Pérez <jaragunde@igalia.com>2019-06-17 10:43:41 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-27 01:05:56 +0000
commit1f508156a212eae16c98b628dde6bae9d652277d (patch)
treeca169956976f6825b3e3c18dcd161f75ee62d3b9
parentb816ad574b51d42f5cf6399e412b8ebc278facf7 (diff)
wam: Remove any Qt dependencies and port to CMake
Recipe changed to use CMake instead of QMake. After Qt usage removal from WAM implementation, boost is now used for some functionalities previously provided by Qt (e.g: File system). Additionally, add glib-2.0 missing dependency. Finally, bump to latest WAM. Included changes: 3e9ce0d [agl][qtless] Port to CMake 971df2a [agl][qtless] Use unordered_map instead of std::map aaa56e3 [agl][qtless] Get rid of Qt usage in webos/DeviceInfoImpl 20a1ec2 [agl][qtless] Remove Qt dependency from qmake files 2615c15 [agl][qtless] Use const char arrays instead of macros for WindowTypes 42770ee [agl][qtless] Trim timestamp string in NetworkStatus 0c7d257 [agl][qtless] Replace QLocale by Boost.Locale 45108f9 [agl][qtless] Remove QVariant leftovers 00f7a1f [agl][qtless] Add Url parsing code 9f74ec6 [agl][qtless] QString-less WAM: Remove leftovers a5ebdc5 [agl][qtless] Migrate PalmSystem away from QString 41ecf4c [agl][qtless] Do not use QString in WebAppManagerConfig 815191c [agl][qtless] Do not use QString in NetworkStatus 47bd88b [agl][qtless] Do not use QString in WebPage ba7ece0 [agl][qtless] Migrate WebAppWayland away from QVariant 903e2fa [agl][qtless] QString-less WebApp: Remove leftovers 502b9f6 [agl][qtless] QString-less WebApp/WebPage: appId 20f57de [agl][qtless] QString-less WebAppManager: SystemLanguage and DeviceInfo e055f56 [agl][qtless] Do not use QString WebAppManager in JS strings building 8949895 [agl][qtless] Migrate WebAppManager away from QString 75aaf56 [agl][qtless] Get rid of QString usage in WebProcessManager 700e456 [agl][qtless] Migrate ApplicationDescription away from QString ba798eb [agl][qtless] Replace Qt data container types by their STL counterpars 159cef4 [agl][qtless] Fix error handling when converting strings to numbers 9c875f1 [agl][qtless] Add StringUtils initial implementation Bug-AGL: SPEC-1871 Change-Id: I7e7725e6a5e9790fd4660f104e4142084f100b62 Signed-off-by: Nick Diego Yamane <nickdiego@igalia.com> Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com> (cherry picked from commit fcfbd7497c73413bd35d1a641686f2c095626daa)
-rw-r--r--meta-html5-framework/recipes-wam/chromium/chromium68_git.bb2
-rw-r--r--meta-html5-framework/recipes-wam/wam/wam_git.bb18
2 files changed, 10 insertions, 10 deletions
diff --git a/meta-html5-framework/recipes-wam/chromium/chromium68_git.bb b/meta-html5-framework/recipes-wam/chromium/chromium68_git.bb
index 5a94e3c3..70255bf3 100644
--- a/meta-html5-framework/recipes-wam/chromium/chromium68_git.bb
+++ b/meta-html5-framework/recipes-wam/chromium/chromium68_git.bb
@@ -14,7 +14,7 @@ require gn-utils.inc
inherit gettext qemu
-DEPENDS = "virtual/gettext wayland wayland-native pixman freetype fontconfig openssl pango cairo icu libxkbcommon libexif dbus pciutils udev libcap alsa-lib virtual/egl elfutils-native libdrm atk gperf-native gconf nss nss-native nspr nspr-native bison-native qemu-native"
+DEPENDS = "virtual/gettext wayland wayland-native pixman freetype glib-2.0 fontconfig openssl pango cairo icu libxkbcommon libexif dbus pciutils udev libcap alsa-lib virtual/egl elfutils-native libdrm atk gperf-native gconf nss nss-native nspr nspr-native bison-native qemu-native"
PROVIDES = "${BROWSER_APPLICATION}"
diff --git a/meta-html5-framework/recipes-wam/wam/wam_git.bb b/meta-html5-framework/recipes-wam/wam/wam_git.bb
index b2487dde..123c915e 100644
--- a/meta-html5-framework/recipes-wam/wam/wam_git.bb
+++ b/meta-html5-framework/recipes-wam/wam/wam_git.bb
@@ -3,9 +3,15 @@ AUTHOR = "Jani Hautakangas <jani.hautakangas@lge.com>"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-inherit qmake5
+inherit cmake
-DEPENDS = "qtbase glib-2.0 jsoncpp chromium68 wayland-ivi-extension libhomescreen libwindowmanager"
+DEPENDS = "glib-2.0 jsoncpp boost chromium68 wayland-ivi-extension libhomescreen libwindowmanager"
+
+EXTRA_OECMAKE = "\
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=${prefix} \
+ -DPLATFORM_NAME=${@'${DISTRO}'.upper().replace('-', '_')} \
+ -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium68"
PR="r0"
@@ -14,13 +20,7 @@ RPROVIDES_${PN} += "virtual/webruntime"
SRC_URI = "git://github.com/webosose/${PN}.git;branch=@6.agl.guppy;protocol=https"
S = "${WORKDIR}/git"
-SRCREV = "ed37e18d3b7acaecc5e40c2548b6dbda98a4f755"
-
-EXTRA_QMAKEVARS_PRE += "CONFIG_BUILD+=agl_service"
-EXTRA_QMAKEVARS_PRE += "PREFIX=/usr"
-EXTRA_QMAKEVARS_PRE += "PLATFORM=${@'PLATFORM_' + '${DISTRO}'.upper().replace('-', '_')}"
-EXTRA_QMAKEVARS_PRE += "CHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium68"
-OE_QMAKE_CXXFLAGS += "-Wno-unused-variable"
+SRCREV = "3e9ce0d4d85a1ea1210e5453906d5bdb084dd305"
do_install_append() {
install -d ${D}${sysconfdir}/wam