summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-06-12 19:45:22 -0400
committerScott Murray <scott.murray@konsulko.com>2019-06-12 19:48:48 -0400
commitad067495451eb53aadd456e67b01ebe58ddd5ee8 (patch)
tree2536b45bbf50b8e1949bdfe7f0f22b92fb94cc63
parent01f27c5740a70d6d61fd3c5d78e2d1348df0d218 (diff)
pipewire: Add user session socket activation
Add a bbappend to the pipewire recipe to create the required symlink in /etc/systemd/user/sockets.target.wants to enable per-user socket activation. A bbappend is used as this change is likely to be AGL specific (for now?). Bug-AGL: SPEC-2521 Change-Id: I4b349ab8151eabfb933f2dcfcf9d293fcb3ea321 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-pipewire/recipes-multimedia/pipewire/pipewire_git.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-pipewire/recipes-multimedia/pipewire/pipewire_git.bbappend b/meta-pipewire/recipes-multimedia/pipewire/pipewire_git.bbappend
new file mode 100644
index 00000000..06b969a6
--- /dev/null
+++ b/meta-pipewire/recipes-multimedia/pipewire/pipewire_git.bbappend
@@ -0,0 +1,11 @@
+do_install_append() {
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ # Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
+ # because it does not support systemd's user mode.
+ mkdir -p ${D}${sysconfdir}/systemd/user/sockets.target.wants/
+ ln -sf ${systemd_user_unitdir}/pipewire.socket ${D}${sysconfdir}/systemd/user/sockets.target.wants/pipewire.socket
+ fi
+}
+
+FILES_${PN} += "${sysconfdir}/systemd/user/"
+